LibreELEC 9.2.1 can't connect to wifi on Raspberry Pi 4 model B

  • Hi,


    I've installed LibreELEC v9.2.1 on my Raspberry Pi 4 model B (4GB). It boots nicely but I can't connect to my home wi-fi router.


    Here's what I'm doing:

    1. I go to Settings > LibreELEC > Connections
    2. My router's SSID is shown, having the strongest signal
    3. I choose it and click Connect
    4. I enter my wi-fi password
    5. I see the status changing from 'idle' to 'association'
    6. After a few seconds it changes back to 'idle'
    7. I try connecting again. I'm not prompted for a password
    8. I see the status changing from 'idle' to 'association'
    9. After a few seconds I'm shown a Network Error saying 'Input/output error'
    10. The status changes back to 'idle'


    Am I doing it right? What am I missing?


    Thanks,

    urig


    PS - I'm setup for WPA2-PSK but I see no mention of this in the LibreELEC GUI

    • Official Post

    There are some RPi 4B reports about 5GHz problems when using internal WiFi.

    If you're an 5GHz-only user, then activate another frequency band on your router.


    My theory about this issue is higher energy consumption at 5GHz, and the need of developing a proper energy management. I still have no confirmation for this theory, but it looks like they are working on it.

  • The 2.4 Ghz band has better penetrating power for a given distance than the 5.8 Ghz. As suggested by Da Flex, try a different wifi band. Wifi signals are similar to a flashlight (torch in the UK). Try: different orientations of the wifi router, possibly its antennas, reducing the distance between the RPI and the wifi router.

  • Thanks all, I'm trying your advices now. As for "Wait for network" it's set to false, which is the default I think.

  • Problem solved. Should have tried this earlier - I've turned my wifi range extender off and on again and now LibreELEC connects to it just fine. Thank you all of your help.