Raspberry Pi 4 Model B (4GB) freezes when playing movies.

  • I've read good reviews on Raspberry Pi4 so I decided to replace my NUC 8i3 by Pi4.

    I purchased Raspberry Pi 4 Model B (4GB), installed LibreELEC-RPi4.arm-9.2.0.img and tested on 4k TV. It didn't play smoothly, freezing every several seconds. I blamed software so I installed LibreELEC-RPi4.arm-9.2.0.img on new SD card but have the same results. I tried 2160p/24fps, 1080p/60fps, 1080p/24fps. Movies are freezing. I don't use WiFi, just Ethernet cable. Frustrated I contacted seller but they claim that all Pi4 are tested and that they have no returns.

    I purchased Raspberry Pi 3 B+, installed LibreELEC-RPi2.arm-9.2.0.img and it works perfectly from the start. Plays movies 1080p/60fps on the same TV connected to the same Ethernet cable.

    So NUC works perfectly up to 2160p/60, Pi3 works perfectly up to 1080p/60, but Pi4 doesn't. Should I try something else or just return Pi4 and ask for replacement.

    Regards

    ZW

  • RPi4 software is not quite as mature as RPi3, but I've been using one as the family daily driver since before the public launch and I don't see any real-world issues with any media apart from HDR which plays with washed out colours due to the current lack of HDR support (but is otherwise fine).


    In the absence of a debug log file which would allow us to spot the config errors and such, we have to guess. I'm guessing you've enabled 4K60 modes and set the GUI to 4K60 (or if not enabled, it's running at 4K30) and you haven't done refresh/resolution whitelisting, so 23.976 media is being forced to run at the desktop resolution (30 or 60 Hz) which requries resampling .. and RPi4 is still a low-power ARM device so that will suck and cause a nice stuttery experience.


    Keep the desktop at 1080p60, set "adjust refresh" to start/stop and configure the whitelist for 1080p/4k 23.976/24/50/59.97/60 only, and don't force 4k60 in config.txt unless you actually intend to watch 4k60 media (there is none in use apart from test files).

  • Thanks for info.

    I gathered debug file yesterday and today but I don't know how to get them from RPi4.

    No I didn't enable 4K60. I didn't change anything in config. Just installed software, installed Confluence skin - to match other player for comparo, set resolution to 2160/24 and then to 1080p/60 and 1080p/24 when tried to play movies.

    Today, following your advice, I set white list for 1080p/4k 23.976/24/59.97/60 and set "adjust refresh" to start/stop.

    After setting resolution to 1080p/60 I could play 1080p movie for several minutes without freezing. The same after setting refresh rate to 23.98 and 24 fps.

    Then I changed resolution to 2160p/24 and still could play this movie with only one freeze, but later played well for several minutes without any problem.

    UHD movies are different story. I tried "3:10 to Yuma" and "Murder in orient express" and both movies were played with hiccups and audio was ahead ~2 seconds. Movie freeze from time to time.

    I can send you debug log if you tell me how to retrieve it.


    My Best

    ZW

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Note: Full logs only. No partial or modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.
  • Linking to the pastebin website alone is not going to help us...


    Once you have pasted your log into a pastebin website (whichever one)), you will need to give us the URL for that uploaded log file.

    Otherwise, try Kodi's log upload website. Upload your log, press the diskette/save button, a new URL appears, and copy/paste that URL link here.

  • It's not a Kodi debug log, and there is no attempt to play anything. Fix those details and use "cat /storage/.kodi/temp/kodi.log | paste" and share the URL (less effort than copy/pasting to pastebin).

  • I did following:

    Went to System>Settings>System>Logging and enabled debug logging.

    Went to System>Settings>System>Display and set output to 1080p/60

    Started HD movie and played for while, than changed output to 2160p/24 and continued the same movie. It was fine.

    Than started UHD movie "3:10 to Yuma" and there were problems. Then I switched to another UHD movie "Murder in orient express", problems continued and system crashed.

    I went to LibreELEC>System and uploaded both logs; kodi.log and kodi_crash.log: http://ix.io/2cPz and http://ix.io/2cPA

    I hope that this time I did it right.

    Regards

    ZW

  • Is it still incorrect?

    When I click on link it starts:

    Code
    1. System log output for: LibreELEC (official): 9.2.0
    2. RPi Hardware Revision: 00c03111
    3. ========== /storage/.kodi/temp/kodi.log ==========

    So it should be OK. Is it?


    Regards

    ZW

  • I agree with Zigmund. I used Kodi 15.2 Isengard for near 5 years. I expected, that the RPi4 version will be faster and better. But it isn't. It is not able to play MPEG2 files I recorded by my camera for instance. It is not true, that the processor has enough power that it do not need HW decoder, or there there is decoder speed problem. RPI3 still play it without any problem. It has huge problem with simple HD video played from Internet (PC version is able to play, so the problem is inside RPi). RPi4 many times do not detect IR commands correctly (I use the same receiver).

    And what I don't understand, why every version needs new database version. I checked the content and it is really not necessary. This is big problem if store database and metadata in central "server".

    vprheli

  • And what I don't understand, why every version needs new database version.

    Why does software get a new version number? Because there is a new feature or a bugfix. The same applies to databases.


    BTW, Kodi Krypton and Leia use the same video database version. For Matrix, so far AFAIK, there is still the same video database. The music database version has gone from 72 to 73.


    I checked the content and it is really not necessary. This is big problem if store database and metadata in central "server".

    We are looking forward to your explanation as to what you have checked and how the checks were done, and how you arrived at your conclusion.

    And yes, Kodi is not backwards compatible.

  • Hi guys

    Did you find out anything in my logs?

    It is not very important to me anymore because I gave up on RPi4. I set it to 1080p/60 and put in in the kitchen to watch morning TV and eventually to screen some movies before watch them on big screen. Unfortunately it doesn't play my own videos, but it is only 1/5 of cost of NUC it replaced, so I am not returning it. It will stay in the kitchen.


    Regards

    ZW

  • Hello, help me too, please. I bought a Libre router, but the TV set-top box (I have Switchonshop) does not catch the signal. Who can advise? Help!

  • Hello, help me too, please. I bought a Libre router, but the TV set-top box (I have Switchonshop) does not catch the signal. Who can advise? Help!

    Start your own thread (with more details)

  • Hello, help me too, please.

    Thanks to several people (or perhaps just one) who have been spamming this forum and the Kodi forum with useless posts, your *shop is regarded a persona non-grata. Thus, you will have to find your support elsewhere. Perhaps your favorite shop can help out why the hardware you bought, is not working.


    We are not the free support department for Switchonshop.

  • About the database. As I checked, and it must be done every times, new fields are added at the end of of previous version (alter table). You can store somewhere in the database the current database version - it is in Kodi. But it is not reason to build new database image which is not accesible from older one. Older Kodi version will read/write/update only their fields, which understand, rest will be filled with defaults. New Kodi version will be able understand new fields and use it. If you extend table with ratings fields for instance, Krypton can use them. Isengard has no code for ratings, but it is still able to read it's fields.Another situation is if SQL use stored procedures, but not here. Developers must remember, that there is many platforms and updates are not build for each one.(Show me Krypton version for RPI). Does developers try migrate Isengard database to the Leia? It failed. Not all people change version if new release is available. "If something is working - do not touch".