[8.0.2e] LibreELEC 8.0 for S905/S905X

  • lama0900 , i know how to convert e2 channel list to vdr or tvh format but vdr to e2 not (I do not know is it possible) . I have own e2 channel list from many years which I updating every time and using with tvh , vdr or my dreambox. It is very easy to manage that list in dreambox edit or dreamset and customize it under our preferences. In tvh or vdr I am not using scanning and mapping channels. I always use my converted e2 list and is perfect


    Yes. I'm using a few dreamboxes also. So i've ended setting up TVH for the first time. There EPG is working very good. I don't know why EPG didn't work with VDR. In the beginning of the S905 8.0 releases TVH had a lot of issues with audio sync, but seems fixed.


    Thank's anyway.

  • Greetings,


    I've just installed LibreELEC-S905.arm-8.0-8.0.2e on a RUPA M8S Pro box, which has a p201 platform and S905 chip 2G/16G and Gigabit network.

    I've noticed some things when playing with different dtb files:


    - the only ones working (booting) on this device are the gxbb_p201_2G.dtb from either the normal or LIRC trees.

    - with either of these - neither LIRC nor the Gigabit LAN is working.


    Any clues/hints on the Gigabit?

    LIRC issue will survive, CEC is working fine.


    Thanks in advance for your opinions.

  • wkchick [HOWTO + FAQ] Install community builds on S905/S905X/S912 device


    You don't need dtb for C2 but you have to update boot.ini

    I did - used the boot.ini extracted from C2.tar you provide - is this correct?

    But it just gives me the "libreelec - booting screen"


    What i did:

    - came from official libreelec 8.0.2


    - download "LibreELEC-S905.arm-8.0-8.0.2e-C2.tar"

    - SSH: "touch /storage/.update/.nocompat"

    - put "LibreELEC-S905.arm-8.0-8.0.2e-C2.tar" to update folder via SAMBA

    - reboot, update gets launched

    - reboot, just seeing "libreelec - booting screen"

    - disconnect eMMC and put to PC => copy boot.ini from "LibreELEC-S905.arm-8.0-8.0.2e-C2.tar"

    - boot, just seeing "libreelec - booting screen"

    what can i do?

  • For building on tag 8.0.2e it seems one cannot download dvb_tv-aml 6bfb250.tar.gz from any of the locations

    https:// codeload.github.com/kszaq/dvb_tv-aml/tar.gz/6bfb250

    http:// sources.libreelec.tv/mirror/dvb_tv-aml/dvb_tv-aml-6bfb250.tar.gz

    https:// github.com/kszaq/dvb_tv-aml/archive/6bfb250.tar.gz

    (added space after :// for avoiding URL shortcut)

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • andy5macht Download .img.gz, open first partition (e.g. using 7-zip) and extract all files from there to your eMMC. You should also note that after upgrading from aarch64 (official) binary addons will stop working.

  • andy5macht Download .img.gz, open first partition (e.g. using 7-zip) and extract all files from there to your eMMC. You should also note that after upgrading from aarch64 (official) binary addons will stop working.

    thanks - got it!

    you are right, is your build 32bit as raybuntu´s?

  • Nofan Tasi Sorry, looks like I forgot to push it to GitHub. I need to ask you to wait a few days, I am away from my compile server.

    sure, no problem at all

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • UPDATE: Downgraded to 8.0.2b and I get the same result when trying to copy to nand. All I get is a black screen when I try to boot from the nand; no boot logo, nothing, just pure blackness. When I put the USB stick that has LibreElec on it, it boots up fine from the USB stick.


    Any suggestions? As I stated previously, I've had these builds running off the internal disk before I tried to update to 8.0.2d.

    Update 2: Thanks kszaq for updating to 8.0.2e. Not sure what you changed, but I updated to the latest version and used the MXQ Pro 4K device tree and now we're back in business. I was able to install LibreElec on the internal drive and works great!


    Thanks again for your hardwork.

  • Just wanted to also say that 25p content using LE 8 (I'm on the latest 'e' version) does exhibit random frame skips/drops/stutter etc. This happens on all 25p content (HEVC, 720p) that I have tested so far (UK TV series mainly). 23.976p content appears so far to playback very smoothly at 24hz without any stutter. I haven't any 24p content to test.


    The behaviour is inconsistent in the timing of the frame drops/skips (if I restart the video the skips do not seem to occur at the same place), but is consistent in that all 25p content (so far) exhibits the problem. I have a couple of S905 and S905X boxes and all boxes display the same behaviour.


    I don't know if a log or sample would help as it appears to be random as to when the jumps occur and has happened on all versions of LE 8 that I have downloaded.


    Same files on LE 7 playback without any issues. I would stay on LE 7 apart from the fact that in Kodi Krypton, a long standing bug was fixed where resuming a video now resumes from the nearest video keyframe 'before' the resume point. Prior to this, resumes would choose the 'next' keyframe. Sometimes (in extreme cases), the resume could be up to 10 seconds or so after the 'actual' resume point.


    I believe the video player was completely redesigned/rewritten by the Kodi team in Krypton - probably causing these playback issues.


    Does anybody else notice the same problem with 25p content (this is with auto refresh rate turned on so that the TV switches to 1080p/50Hz mode)??


    TIA.


    Update: I did find a 24p video and that played back without any glitches. The drop/skip frames with 25p content does not happen very often (difficult to give an average but I would say maybe 4-5 times per hour). The video is still watchable.

    Edited once, last by ukmark62 ().

  • When can we expect Kodi 18 Leia build for the infamous chinese TV Boxes ?

    i know i should not ask for ETA, but RPi has got already an Alpha Build....

    It is not bad at all to try these Images if available. Isnt it Kszaq ?

  • kszaq

    How can we turn off the blue led on the Odroid-C2 ? In Raybuntu's build I can turn off the led by using this command:

    echo none > /sys/class/leds/blue\:heartbeat/trigger

    But in your build, it gives this error:

    -sh: can't create /sys/class/leds/blue:heartbeat/trigger: nonexistent directory


    Thanks.

    Edited once, last by kidiavn ().

  • kidiavn It looks like I did not include LED driver. It's a bit hard to track what needs to be included in kernel config, that's why the build is marked as "a bit experimental". I hope to make it work in a next build.

  • Need a bit of help please guys !7

    I have libreelec installed on nand on S905 box, was working fine until this evening. I couldn't switch it on using remote so had to plug and unplug it at the back of the box. It came up with corrupted message and press any key within 120 .....

    Now I pluged in sd card and it boots fine from sd card but the remote doesn't work. Not sure what to do to get it fixed again ? any help would be greatly appreciated

  • Just tried spare usb controler and it works fine. It seems I can use original remote that came with the box to switch on the box but after that it doesn't work at all. I could use original remote to switch on the box and use my other usb remote for everything else but ideally i would like to use original remote only. still stuck don't know what to do