Enable SSH setting

  • If you have NOT enabled SSH during the install process of LE 7.0.2, where is the ability to do this found after installation.
    Under LE settings > services only the option to Disable SSH password exists.
    Is it tucked away somewhere?
    Thanks


    I had a look at the WIKI but the screen shots there do not represent the reality of the existing services tab, as it shows a page with enable ssh.

    Edited once, last by bromerzz ().

  • Did you enable ssh via /flash/cmdline.txt? If so the option won't show up in the settings add-on.

  • Not as far as I am aware.
    During the LE install/setup the default is samba which is enabled, but go left and the option is there to enable ssh.
    Does that help?

  • I guess the question is: did you (accidentally) enabled SSH in the Welcome wizard, or was the SSH option already enabled? Because it seems as if it was enabled, and thus the SSH option in the Settings addon becomes invisible.

  • No defiantly I had to enable the ssh option in the wizard.
    [hr]
    OK just installed a fresh .img of 7.0.2 and the default setup has samba enabled but not ssh, so for test purposes only I have not enabled ssh, when the wizard completes and I go to settings and services the option is there to enable ssh.
    I have taken some images of those three screens - iPhone snaps- if you want to verify things or maybe see what I mean. I can post if necessary.
    However if you enable ssh during the wizard process you do not get the same settings . services option.
    Edited content_
    Just to clarify I personally always enable ssh during the wizard setup. However I am actually asking this question because someone else says they do not get the option to enable ssh from the services page and I believe they have enabled ssh during the wizard setup, but are unable to ssh in.

    Edited once, last by bromerzz ().

  • I suppose the first question that needs answering: Is ssh already working, and have you simply assumed ssh is not working because you haven't found the ssh option?


    As already explained, you won't see the ssh enable/disable option when ssh has been added to the boot command line, because then the Settings add-on no longer controls the service - your boot command line does.


    Double check your boot command line (/flash/cmdline.txt for RPi/RPi2, /flash/syslinux.cfg [or EFI version] for Generic, no doubt something else for other projects - I've no idea what hardware you have) to ensure it doesn't include ssh. Paste the contents here if you're not sure.


    I've been testing this today with latest master builds of LibreELEC and as far as I can tell it behaves exactly as described here, so if you're seeing something different in 7.0.2 then it's possible the issue is already fixed.
    [hr]


    However if you enable ssh during the wizard process you do not get the same settings . services option.


    I'm not able to reproduce with latest master - if I enable or disable ssh in the wizard (with ssh not added to boot command line) then the enable/disable ssh option is always present in Settings > Services.

    Edited once, last by milhouse ().

  • Thanks for the replies and help.
    I really don't have a personal use problem with ssh. I need to ask the person, on another forum, who could not gain ssh access a few more questions. Just not had the need to look at LE services for some time to see that the enable/disable ssh option was gone(because i enable in the wizard process).
    Thanks again for the help I will of course come back if I need to.
    Good night.

  • Although they may claim otherwise, the other user activated SSH during install which hardcodes it into syslinux.conf and this disables the normal on/off capability in the first-run wizard and settings add-on. From the next alpha build (7.90.008) the ability to force SSH has been removed as part of a general cleanup of the installer.


    NB: If it is forced on, one reason for not being able to connect is an old (out of date) PuTTY version which is trying to use cipher suites that we no longer support in the SSL versions we use.

  • chewitt Is it still possible to force SSH? I don't have a display and seems like I can't access the Installation Wizard. I can only access the port :8080 on my local network but when I do I don't see the Installation Wizard. What am I supposed to change in the cmdline.txt file?

  • add "ssh" to boot params and the service is forced to start on boot

    I'm sorry, but how do you do that? :D Do I need to access the ext3 partition on the SD Card? 'Cause I can't get that to work on Windows with ext2fsd either :/