Support for Nvidia gtx 1650 super

  • The latest 9.2 didn't support gtx 1650 super, I tried installing nightly build ,LibreELEC-Generic.x86_64-9.80-nightly-20200214-70b69eb.img.gz, it installed correctly But when I played videos its getting stuck. Can someone help me to figure out a solution to get Libreelec run on my GTX 1650 super.


    Tried building 9.2 with nvidia driver version 440.59 but no scope lots of build errors :(

    latest error below,

    ...

    FAILED: NATIVE/bin/llvm-tblgen

    cd /mnt/home/krish/libreelec/LibreELEC.tv/build.LibreELEC-Generic.x86_64-9.2-devel/llvm-8.0.0/.x86_64-linux-gnu/NATIVE && /mnt/home/krish/libreelec/LibreELEC.tv/build.LibreELEC-Generic.x86_64-9.2-devel/toolchain/bin/cmake --build /mnt/home/krish/libreelec/LibreELEC.tv/build.LibreELEC-Generic.x86_64-9.2-devel/llvm-8.0.0/.x86_64-linux-gnu/NATIVE --target llvm-tblgen --config Release

    ninja: build stopped: subcommand failed.

    ^[[1;31mFAILURE: scripts/build llvm:host has failed!



    I'm using Ubuntu 18.04.4 LTS

  • You can try the Kodi 19 test builds which include 440.59: LibreELEC Testbuilds for x86_64 (Kodi 19.0) (avoid #0215 and #0216 as they have issues with Netflix, but #0214 should be OK).


    We'll backport 440.59 support to libreelec-9.2 soon.

    So is the one I'm using a stable build ? ( LibreELEC-Generic.x86_64-9.80-nightly-20200214-70b69eb.img.gz )

    Or is it different from LibreELEC-Generic.x86_64-9.80-Milhouse-20200214210338-#0214-gd1fdc57.tar what u shared ? Because both are 0214.

  • So is the one I'm using a stable build ? ( LibreELEC-Generic.x86_64-9.80-nightly-20200214-70b69eb.img.gz )

    No, that's an unstable build based on Master (which does include 440.59)


    Or is it different from LibreELEC-Generic.x86_64-9.80-Milhouse-20200214210338-#0214-gd1fdc57.tar what u shared ? Because both are 0214.

    The nightly build is different from the Milhouse build in that the Milhouse build includes future changes that are not yet in Master, so Milhouse is Master++.


    Both the nightly and Milhouse builds are the same in terms of 440.59 support as both have included 440.59 since 5th Feb, and your "getting stuck" issues would need more detailed investigation - maybe the Milhouse build already includes fixes that resolve whatever issue you are experiencing.


    I'd like to get 440.59 (and support for your GTX 1650 Super) in LibreELEC 9.2.x before the next release. I did recently upload a test build of "stable" LibreELEC 9.2 with 440.59 for another team member to test, but due to time commitments that hasn't happened, so please give this LibreELEC 9.2.x build (with Kodi 18.5) a try and confirm if it works for you or not:


    LibreELEC-Generic.x86_64-9.2.0-20200218193037.tar

  • this LibreELEC-Generic.x86_64-9.2.0-20200218193037.tar is not working for me cant boot up saying failed to start Xorg Server, the same error as 9.2.0, I think the driver is not 440.59.


    Both the nightly and Milhouse builds are the same in terms of 440.59 support as both have included 440.59 since 5th Feb, and your "getting stuck" issues would need more detailed investigation - maybe the Milhouse build already includes fixes that resolve whatever issue you are experiencing


    I tried using the Milhouse build also, this one boots up as the nightly build but same issues when playing the videos fully stuck, tried with atmos files and small normal files but same. :(

  • I tried using the Milhouse build also, this one boots up as the nightly build but same issues when playing the videos fully stuck, tried with atmos files and small normal files but same.

    Hmm... Weird.


    Milhouse's #0218 testbuild for some reason chose the legacy driver 430.50 on both my GTX950 machine and GT1030 machine. It's perhaps a mishap in the build. Videoplay had no issues.


    SBYG6x0.png

  • Mine is gtx 1650 super the latest one, did anyone tested on this specific card.?

    The following link confirm that 440.59 supports 1650 super.

    nvidia driver

    Also I can see lots of white dots on the progress bar while playing. What may be the actual problem ?:(:(


    Any help is greatly appreciated.