Argon One Fan Control

  • Hi,

    since i updated to libreelec 10, my fan isn't working anymore with argonone. tried to reinstall the script but didn't help. I tried your zip file, but won't install with libreelec 10. How did you install it ?

  • LE10 beta is not yet supported.

    For me, the fan control still doesn't work as I set it to. I wrote to the support of argon40 again. With the price of this pi case, i can ask for everything to work ex works without having to spend hours of programming. I am very disappointed!

    • Official Post

    They attempted to PR an Argon40 add-on to the Kodi repo; but it was Python2 and also LE specific so it was (correctly) rejected. I've since noticed an LE package in their GitHub repo; but it's a standalone package and it's not in a fork of our repo which is a rather odd approach (first time I've seen a dev get that wrong). The code is still Python2 and the package.mk had numerous other issues. I was kind of expecting them to reach out and ask Q's on how to submit to our repo .. but I've not noticed any emails. I'm sure they'll figure it out eventually.

  • Hello,


    I'm new in this forum. The reason for me to registrate here was the story of the Argonone fan with Kodi 19 (LE 9.95.1). Today I updated my Kodi 18.9 on my Pi4 to Kodi 19 and I have had the issue with the fan. After reading here I tried some things. I disinstall Rpi-Tools and System Tools. Then I install it new. Then I start the setup procedure from Argon40 for the fan from the beginning. After restart my Pi4 the fan is working.


    sorry for my bad english


    Regards

    Edited 2 times, last by Bobesch ().

  • I was to fast...

    There is still an issue. After power down the fan don't work anymore. I have to start the argononed.py in /storage/.config.

    This file starts the fan and the buttons but it then hangs and I must abort it with ctrl-c.

    But then thevfan is working till next power down. With a softreboot the button still work.

    • Official Post

    There is still an issue. After power down the fan don't work anymore. I have to start the argononed.py in /storage/.config.

    This file starts the fan and the buttons but it then hangs and I must abort it with ctrl-c.

    Create /storage/.config/autostart.sh with this content:

    Bash
    #!/bin/sh
    
    (
        python /storage/.config/argononed.py
    ) &
  • Starting within autostart.sh works here too, thanks!

    But why does the daemon not work? The deamon is started by system.d the same way as "python /storage/.config/argononed.py"

  • Create /storage/.config/autostart.sh with this content:

    Bash
    #!/bin/sh
    
    (
        python /storage/.config/argononed.py
    ) &

    do i have to do anything else except the above?because i created the autostart.sh and pasted the code and later copied it to the /.config/ but the problem persists and every time i open the libreelec on my rp4 it crashes (on the start logo libreelec screen)and restart and show that argon one fan and button failed to start and then libreelec opens normally,any ideas?


    Thank you all for your time

  • linuxuser Comment out the Python line of autostart.sh, manually start argononed.py on SSH session and post the output. I don't have this device, Argon One owners can provide better support. /shrug

    sorry if tis dumb question but how do i comment out,manually start the py and get the output?(i know that its dumb question but i am still learning....)


    Thank you for your time

  • Starting within autostart.sh works here too, thanks!

    But why does the daemon not work? The deamon is started by system.d the same way as "python /storage/.config/argononed.py"

    did you finaly achieved to get it working normally?if yes can you please write the steps, thank you

    • Official Post

    sorry if tis dumb question but how do i comment out,manually start the py and get the output?(i know that its dumb question but i am still learning....)

    You really don't have the right user name. 8o


    Login by SSH.

    Open autostart.sh by nano editor.

    Comment out the Python line by adding a leading #. (like at line 1 - the magic line 8) )

    Save the change and close nano editor.

    Type python /storage/.config/argononed.py and press Enter.

    Copy the resulting text output into your next post.

  • You really don't have the right user name. 8o

    Comment out the Python line by adding a leading #. (like at line 1 - the magic line 8) )

    Login by SSH, type python /storage/.config/argononed.py and press Enter.

    I will try fresh install first

  • Creating autostart.sh file solved my problem too, now fan is working as intended.

    Anyone found an installer for the argon one v2 ir sensor working with LE 9.95.x?