[unoffical] LE-9.2/9.80-Images for RK3229/RK3228

  • Hi,


    help me. Can somebody say to me how to compile ssv6x5x for unofficial libreelec for rk3229/rk3228 box (mxq pro 4k 5g with rk3228a chipset) . The module for ssv6051 is loading at startup but wifi don't work.


    The kernel is 4.4.194 linux. I know that the ssv6x5x works with armbian with this kernel but i don't know how to cross compile it.


    which source do i use :



    GitHub - khadas/android_hardware_wifi_icomm_drivers_ssv6xxx
    Contribute to khadas/android_hardware_wifi_icomm_drivers_ssv6xxx development by creating an account on GitHub.
    github.com



    or



    GitHub - paolosabatino/ssv6x5x: ssv6x5x driver adapted to for rockchip rk322x
    ssv6x5x driver adapted to for rockchip rk322x. Contribute to paolosabatino/ssv6x5x development by creating an account on GitHub.
    github.com


    How proceed.



    Thank a lot.


    Bests regards.

  • It's best to ask for help in the Armbian forums where they have some experience with that driver. LE no longer uses the 4.4 kernel and that driver does not work on anything newer than ~4.10 due to crypto APi changes in the kernel.

  • ericmartin971

    Hello eric, you speaking of two different things. In reality there are two drivers , one is ssv6051 other is ssv6x5x and they are different but... but..since the reference in pid vid is the same... the kernel loads sometimes the wrong one. For this reason is necessary blacklist the offending one
    If i can suggest identify the right chip you have, if 5ghz it COULD or could-not be ssv6256P . In this case you also need ssv6x5x-sw.bin and ssv6x5x-wifi.cfg in the right places, usually under /etc/firmware

    As chewitt already said first you have to REMAIN on 4.4.194 , second if you will you can have a peek in the armbian forum ( thanks chewitt for mentioning it) where jock and myself are " fightening" :) against those different situations

  • Hello everyone, I would like to know if someone could help me with my TVbox, it is a mxq 4k 5g RK3228a but at the time of loading the correct image it does not give me a video signal either in HDMI or Av Does it happen to someone else? And if so, does it have a solution? /shrug

  • Hello everyone, I would like to know if someone could help me with my TVbox, it is a mxq 4k 5g RK3228a but at the time of loading the correct image it does not give me a video signal either in HDMI or Av Does it happen to someone else? And if so, does it have a solution? /shrug

    I have a similar problem. My H8 mini also does not give any video signal, although I loaded the correct loader and correct image. (I had 2 similar device, one worked, the other not). I also tried to load anroid image, but that also didn't work. I tried many loaders + images, nothing worked.

  • Hi,


    after some time I started working on my libreelec-9.2 fork again.

    Updates below:


    - updated some packages to allow build on more modern systems

    - return to working u-boot version

    - fix for booting from NAND (tested with my V88Mars clone). Now I'm able to install libreelec directly into the internal memory. (thanks to jock  fabiobassa and the guys behind the armbian port)

    - fix repository addons

    - added Hauppauge WinTV-SoloHD dvb receiver


    this time I've built and shared all the images for the boxes in the first post, but keep in mind that I've only one :)


    code: https://github.com/ilmich/LibreELEC.tv

    images: https://drive.google.com/drive…Ee4EJ5ZaMby1G?usp=sharing


    thanks again to knaerzche for creating this project.

  • I have a second MXQ PRO 4k (Android 7.1.2 (fake 10.1) 1GB/8GB).

    I have tested several .img versions and none give me an image over hdmi.


    I noticed that my router shows an ip address with the name LibreELEC. Too bad ssh is not enabled by default, maybe something could be done.

    So it works with the Alfawise A8 version (RK3228B, DDR2) but no HDMI response.

    Fresh version from Ilmich - for mxq4kpro also starts but... TV responds, appears "kodi" as a description of the channel but still black screen.

    What else can I do?

    Maybe a problem with the resolution? Android works with HDready not FullHD

  • hi karkow, try to force lower resolution by editing the extlinux.conf in the FAT partition of your boot media.

    Add something like this


    video=HDMI-A-1:1280x720


    in the kernel parameters.

    Maybe your TV has some trouble (try also with another TV if you can) with legacy kernel of my images


    Edited once, last by ilmich ().

  • I change "video=TV-1:d" to "video=HDMI-A-1:1280x720" still no image (try monitor lcd dvi<->hdmi too)


    How to enable ssh without accessing the menu?


    /btw

    Android has root so maybe some root/ files would be useful?

    Edited once, last by karkow ().

  • karkow to enable SSH try to add 'ssh' in the kernel parameter.


    if it's ok, share the kernel dmesg output.

    Are you able to share the device tree of your android working firmware (or post the link for download)? If you can, I'll try to take a look.

  • hi karkow , try with this experimental image (for mxq4kpro)


    experimental – Google Drive


    With this image I've builted a more updated kernel for rockchip


    GitHub - mrfixit2001/rockchip-kernel: Fork of Rockchip's BSP kernel with lots of patches, backports, and custom fixes - currently tested on the RockPi4, Rock64, Rockbox, and Rockpro64
    Fork of Rockchip&#39;s BSP kernel with lots of patches, backports, and custom fixes - currently tested on the RockPi4, Rock64, Rockbox, and Rockpro64 - GitHub…
    github.com


    It's very experimental (I've only tested that my box boot correctly and nothing more), but maybe if hdmi works for you, it's a good starting point.

  • ilmich how is it possible to install on the nand? Do you know how I can solve a wifi module error that it does not want to recognize after a sudden shutdown....

    Edited once, last by markosc ().

  • shMatrix try with one of this builds. My experimental build is abandoned for now.

  • shMatrix try with one of this builds. My experimental build is abandoned for now.

    I compiled from the repository for my tv box v88 4k 1gb, it looks faster, but the channels through the tvdeadend client look bad with defects , netflix at 720p is very clear all that with a hdd used as the main disk but with SD yes there are jerks......good job reviving those boxes: D