Raspberry Pi 4 - Netgear D7000: Ethernet not working

  • Hi guys,


    I've been breaking my head on this one for days. I bought a Raspberry Pi 4 (the 4GB version) and installed the latest LibreELEC-RPi4.arm-9.1.502.img on it.

    After booting up, everything works fine except the ethernet port. WiFi works, but there is absolutely no activity on the ethernet port. The lights are not flashing and the ethernet network is not showing up in the network settings in LibreElec. The list is just empty when I disable WiFi and enable Ethernet. (advanced IP scanner can't find it on my network either). I made sure the cable and the connection to my router is alright, so I connected a laptop to it and the laptop works absolutely fine; it gets an IP via DHCP and I can browse my network.

    To be sure it was not my network, I installed Raspbian and booted up the Pi. Also with Raspbian, no Ethernet :(

    So, I thought the RPi was defective. I sent it back, received a brand new board today and tested it again after freshly installing the image on the SD card.


    It still doesn't work!

    I SSH'd into the Pi and had a look at /storage/.cache/connman and only the WiFi settings are there.


    It must be something related to my network but I have no idea where to look anymore. /shrug


    My setup is:


    - Netgear Nighthawk D7000 modem/router with latest firmware

    - Netgear Gigabit 8 port switch

    - Rapsberry Pi 3 with Pi-Hole running and acting as DHCP (router DHCP is disabled)

    - All CAT6 cabling with solid connectors


    Weird thing is, when I connect a USB to Ethernet adapter, it works...


    Do you guys have any suggestions/idea's where to troubleshoot this? Any thoughts on this are greatly appreciated :S

  • Also with Raspbian, no Ethernet

    That is pretty weird, perhaps an update went bad. I installed Raspbian on a RPi4B-4GB a few weeks ago (haven't updated anything yet) and all ethernet stuff worked.


    Try connecting to the router directly, and double check the IP config on the router's DHCP pool an on the RPi4. Perhaps you're getting a 172.* address?

  • I've been using the RPi4 4G version since it first came out, and have never had an issue with ethernet. I've never seen any reports on the Raspberry Pi forums to suggest that there is a H/W issue either.


    By virtue that it also doesn't work on Raspbian seems to suggest it's something to do with your setup (as you mentioned).


    I would try a CAT5 cable - just in case. and then slowly eliminate each device in your N/W chain to see where the problem lies.


    If after that it still doesn't work, I would post the question on the Raspberry Pi Forum as there will be RPi hardware engineers who might have a better idea.

  • Thanks guys. I will try to move around the cabling and see what happens. I've been reading some posts which mention that sometimes there can be a conflict between certain routers and the Pi ethernet. I will rule that out by changing the connection. Now it's connected directly to my router, but I will see what happens when I connect it to my 8 port switch. I have to fiddle around with the cabling though, which is a pain.

    I will report back here after.

  • Hi guys,


    Back again with the Raspberry Pi working. It turned out that my Router was the culprit. Connected directly to the router, the RPi refused to establish a link. I have a Netgear 8 ports Gigabit switch connected to the Router and once I moved the cables around and connected the RPi to the switch, the link was established and everything started to work.

    Never knew this could actually happen, but it did. So, interesting information: Raspberry Pi 4 connected to a Netgear D7000 -> doesn't work!


    This topic can be closed now.


    Thanks!