LAN file transfer speed

  • Hello,
    I wanna ask if Libreelec too have limited transfer speeds over LAN to approx. 30MB/s ?
    I am currently using Openelec, which has such a limitation because of samba, and nobody wants to do anything about it. I have tired various tips, settings of buffers, etc. Nothing work.
    When I install windows, the speed is limited only by speed of my HDDs, which is 60-90MB/s.
    Is really weird on 21. century to copy huge files such as HDrips just about the speed of usb 2.0 over gigabit home LAN from windows pc to htpc using openelec.

    My htpc setup is:
    asrock am1h-itx
    athlon x4 5350
    2GB RAM
    GPU integrated in CPU.


  • LibreELEC has put not any speed limitation on itself in any area. Only the 'Wait for network' option comes close, since LibreELEC can boot too fast before the network is actually up.

    Comparing network speeds to Windows installation 'speeds' is like comparing apples and oranges. Different situations altogether.

    Drive speeds and network speeds can be different for various reasons. Disks that get full will become slower in writing, different Linux kernels can have different network drivers, different usage of cache... I see differences in Ubuntu 14.04 and 16.04: copying files over the network was fine with 14.04, now with 16.04 things have apparently changed and not for the better. (I might even go back to 14.04).

    Edited once, last by Klojum (October 22, 2016 at 1:50 PM).

  • Its not about that :)
    Im talking about copying files from my main pc with windows, to htpc running openelec. It was doing this from very first time when I install openelec there, about 2yrs ago. There it was v 4.0, today I have newest 6.0.3, but nothing changed over entire time.

    Copying speed via wired gigabit LAN was always like 30MB/s. Did some research and at the end, everyone just told me that it is because of something with samba. It just run this slowly when there is file transfer from windows pc. From replies on openelec forum, they will do nothing about it. And I dont simply understand, why I must go 30MB/s, when I can go 90MB/s.

    I just want to know if there is any benefit running libreelec, if it does have something better solved under the hood than openelec in this case. I dont know, maybe newer version of samba, which has this resolved, or something like that. I dont know nothing about compiling such a system like *elec, so its just my plain thinking :)

    Im working in IT and altough not dealing with linux much, cant just believe that nobody have resolved this over those years of samba development.
    Just imagine running network in some company like this, with maximum speed about 30MB/s. Just because of samba and nobody takes care about it.

  • Thanks for the hint. I have checked it and it says that dialect is 1.5
    I checked it via PS command "Get-SmbConnection"
    I have put the samba.conf file to the use so I can set parameters to samba in openelec (rename samba.conf.sample to samba.conf and reboot openelec htpc). There is setting about smb "max protocol = SMB2" but even after restart of both pc's, it still using 1.5.
    Main windows pc is windows 10 x64, which reports dialect 3.1.1
    Is there any way to tell openelec to use higher dialect for greater speeds over LAN?

    Edited once, last by shiro (October 22, 2016 at 4:42 PM).

  • As I expected, the protocol is a version of SMB 1.

    I don't know exactly what features each 1.x dialect brings but for sure it is stuck with all the SMB 1 stuff causing low performance and high CPU utilization. 16-bit data size etc.

    I believe Kodi and LE uses Samba 3.6.x which was the first version of Samba to add 'basic support' SMB 2.0. Basic support is their term, so this support may only be partial, maybe that's why it is not working. Samba is currently on v 4.5.0 but I believe there is some technical reason why Kodi/LE cannot go above 3.6.x yet.

    At the end of the day I don't think it's fair nor realistic to expect Samba to be as fast or efficient as the native Windows implementation. But for sure performance can get a little better when Samba is eventually bumped.
    Roadmap - SambaWiki

    Edited once, last by trent (October 22, 2016 at 6:14 PM).

  • Well, only if I know how to do it. I dont have much experience even with ubuntu and BFU distros like it, not even speaking about with such minimalistic distros like OE or LE.

  • I seriously doubt that OE/LE samba is limiting speeds to 30MB/s, old version or not. Why don't you try copying to any of the internal shares and compare the speeds?

  • No, I always copying from HDD to HDD, I have nothing on htpc's SSD, only OS

    So, I just formatted htpc and installed fresh LE 7.0.2.
    After initial set-up (ip adress, htpc name), I tried to copy some files.

    - copy between directories through KODI's file manager on internal HDD in htpc PC running LE 7.0.2 fresh install - speed was about 25-35MB/s
    - copy between directories on htpc's local HDD like before, but I did it on windows PC through windows explorer - speed was around 20-35MB/s
    - copy from windows pc to htpc running LE - 20-35MB/s
    - copy from htpc to windows pc - from 59MB/s to almost 100MB/s depending from the particular file

    htpc's internal HDD is 1TB WD black, and has over 100GB of free space.

    I did nothing else so far, only those everything is set up as it comes with fresh install of LE 7.0.2.
    so...why I can copy from HTPC to windows pc with minimal speed of 60MB/s, but writing is only about 20-30MB/s, even on libreelec?

    Edited once, last by shiro (November 13, 2016 at 6:39 PM).

  • - copy between directories through KODI's file manager on internal HDD in htpc PC running LE 7.0.2 fresh install - speed was about 25-35MB/s

    As this is copying locally: SMB, even the whole network, isn't involved. So it's either a slow HDD or an compatibility/driver issue with the SATA chipset.

    AFAIK the am1h-itx has 4 SATA ports, two controlled by the boards AMD chipset, two controlled by an ASMedia chip. So I would suggest to try the HDD on a different SATA port, for example if it's currently connected to a port controlled by the ASMedia chip use one controlled by the AMD chipset and vice versa.

    so...why I can copy from HTPC to windows pc with minimal speed of 60MB/s, but writing is only about 20-30MB/s, even on libreelec?

    Because the read speed on HDDs is usually much higher than the write speed.

    Edited once, last by Grimson (November 13, 2016 at 8:45 PM).

  • Today, I tested some new things:
    - flash AM1H-ITX's BIOS to latest version
    - change SATA cable between MB and HDD
    - enable/disable CSM in BIOS
    - connect HDD to ASMedia SATA controller (didnt use it and have it disabled in BIOS before to speed up boot)
    - free another 100GB on HDD to test if its caused by drive's speed because of occupied space
    - checked SATA config in BIOS - all in set as AHCI

    I have installed LE as in UEFI mode. I have installed also OE before in UEFI mode. Idk if that can change something...problably not.

    ...and nothing helps . I really dont know where is the problem.