Pi4 + 9.1.002 cannot add smb w10 shared folder

  • Hello,

    I parsed the forum about this issue, reinstalled Librelec, add pwds, PC and PI4 are on the same wired network, but I still cannot add smb from kodi. Always "Operation not permitted" so i cannot even access to id/pwd.

    For information, i used it without any issue on Zidoo X9S & Kodi 18+ on the same network, with the same configurations;

    Thanks for advance,


  • Same thing here. But another LE/Kodi droidbox (kodi 17.3/LE 8.0.1) does connect to the same server (corsair) but not my Minix (17.6/LE 8.2.5). This problem Minix U9H can connect to other pcs on the same network (both w7 & w10) but not to my corsair w10 server. I get "operation not permitted" and or "cannot connect to network server"

    I've tried connecting the Minix to the network via ether net wire and wifi. No change. The

    When I try to create a new source using the SMB source, and "browse for new share," it opens to WORKGROUP but clicking on that returns "invalid argument" which should not be.

    I wish I knew where I was holding my mouth wrong.

    I can ping the Minix IP addr from the corsair so there is a connection, but I cannot seem to go the other way.

    Any help would be wonderful.


    Edited once, last by Ezriderz ().

  • Enable "Wait for network before starting Kodi". I get "invalid argument" errors unless I enable it.

  • Thanks, smp.

    I set it to "wait for network before starting Kodi" but when I click on one of my video sources it says, "operation not permitted" and after clicking OK, it says "Couldn't connect to network server". Same as before. Thanks for the tip, though. Might be helpful later.

    Edited once, last by Ezriderz ().

  • I forgot to mention that I had already checked this option "wait for network before starting Kodi", after parsing forum's threads. But it hasn't fixed the smb issue.

  • What is the PC - a Windows PC, or a Linux PC? If Windows, is it up to date with all the latest security fixes from Microsoft that disable SMB1, or are you still relying on SMB1 support in the Windows PC? If Linux, have you enabled SMB2/SMB3 support (not normally enabled by default on most current Linux PC installations)?

    LibreELEC 9 doesn't support SMB1 out of the box and this insecure protocol needs to be enabled manually in LibreELEC (SMB1 is strongly not recommended).

    If the Zidoo is working, have you applied the same SMB Client settings from Kodi > Settings > Services > SMB Client, to the RPi4?

  • It's a PC Windows 10. Win 10 is up to date, no forced SMB1.

    Settings are the same as on zidoo : min smb2, max smb3.

  • Sorry for the delay, forgot about this thread.

    SMB2/SMB3 should be working out of the box with Windows 7+ (including Windows 10), there's actually no need to tweak or change any settings, and in fact it is working for pretty much everyone else so I can't really think of a good reason why it's not working for you.

    At the moment I can only think there's something you've done (in terms of configuration) which you've forgotten to mention, or there is some other issue with your network (firewall, perhaps?)

  • Does it work if you go that route:

    Videos -> Files -> Add videos -> add network location -> Windows (SMB) and fill out the dialog with username and PW?

  • I can't seem to get this to work any more. My network is all Windows 10 computers. Since they dropped NetBT and adopted WSD, I can't see any of my Libreelec players and my Libreelec draws a blank when it browses the Windows (SMB). Is there any way to get WSD running on Libreelec?

  • my Libreelec draws a blank when it browses the Windows (SMB).

    Microsoft relegated SMBv1 for obvious reasons. For SMBv2+, you require a Windows user account with a password. Also network browsing was disabled. Use Kodi's "Add network location..." for creating a source, enter all credentials and stuff should work (tm).