RPI4 - HDMI-CEC not working

  • Hey,

    it worked for me the first time I booted the pi 4, but after turning the samsung off and back on a little later, not working anymore.

    I think samsung cec and/or the cec library are just not that sturdy. I had tried messing with some libcec stuff a while ago and gave up.

    It might just some intermittent thing that eventually works if you unplug the cable or reboot enough times, sorry people that bought new cables.

    Try different combinations of power cycling (really unplugging) your tv and the pi.


    has anyone tried `hdmi_force_hotplug=1` in config.txt?


    edit:

    I've been having better luck now with `hdmi_force_hotplug=1`

    But I need to test having the TV off for a few hours then turning it on again

  • I have three TV's - old Sony, 4k Samsung (kind of old too) and non-smart small Samsung TV.


    I have two RPi3 with libreelect and TV remote controls work like a charm. I Wanted an upgrade and now I have three RPI4 with fresh libreelec and TV remote is not working at all. I have tried everything that is suggested on the forums, bug reports manuals and mail list to no avail. Invludin "turn of the TV for hour" - which obviously sound stupid but having multiple devices and TV you can afford to keep a pair out of power :)


    I have read that the same issue is present also on some ubuntu installs and also somewhere that CEC is broken in linuks kernel and is known issue but I have never found the report for this.

    Anyway before i start buying different cables is there anyone who ever managed to get HDMI-CEC working with RPI4 and LibreELEC-RPi4.arm-9.2.0.img.gz ?

  • On my Panasonic TV 32DS500 and Raspberry Pi 4 CEC works but not full with Libreelec 9.2.1 and older.

    Media keys Play,Pause,Stop and 0-9 don´t work

    On Raspberry Pi 3 i have sometimes Problems with CEC Media Play,Pause but 0-9 working always