RPI4 - HDMI-CEC not working

  • I've figured it out!

    At least for my situation - it was the damn microHDMI adapter - tried with a microHDMI cable and it works fine!

    Maybe try a different cable...

    TV Panasonic TX55CS620E

    RP 4GB

    Good idea, I've ordered the cable, lets see if it works.


    cheers

  • I managed to get a few cables and can conclude my issue was with a years old cable I had since 2010ish.

    So I have an assortment of regular micro HDMI to HDMI, little adapters that convert to just normal HDMI to HDMI. They all seem to work.

    Something else to look at is testing all the HDMI ports in your TV.

    I had one set to Game Mode on my samsung, which was the main port I was using. The other ports which didn't have game mode set connected to the CEC without an issue.

    I would recommend trying to reset your TV to factory defaults and just testing ports and settings.

    I am using an old Samsung Series 5 LED TV.

  • I am using brand new cables, infact tried 4 different ones didn't resolve the issue. Game mode is off so that doesnt effect in my situation. Have already reset to factory default so I guess its just not going to work for on rpi4 :(

  • Hello, I have the same problem. HDMI-SEC don’t work with Samsung TV. But I also have RPI2 and all is working fine.

  • Only thing I can think of is trying to fresh reinstall on another sd card, even try OpenElec or newer/older Libreelec builds.

    The goal ATM is to find out if it works at all with anything to eliminate hardware fault.

    So you need to;

    * Test different Operating Systems(With CEC)
    * Test different TV's
    * Test different cables(already done)

    What's the model number of the TV, probably worth looking up whether someone somewhere else has had issues with that TV. Also I remember ages ago updating firmware on my TV.

    I've been testing on a wide number of TV's(mine, friends and families) and have only had the problem with the cable in use.

    There is also settings for CEC in your System -> Input -> Peripherals.

    Make sure it's not turned off or on some weird setting, eventhough I trust you didn't change the settings from install. It doesn't hurt to double and triple check these things.


  • What's been said has been done already.


    What we need is the developers to take a look and see if they can fix this!

  • What other operating systems have been tried using the Raspberry Pi 4 with a Samsung TV ?


    I searched the Kodi Forums and couldn't find any threads with this issue. I did find a thread in the raspberrypi.org forum but it's not that clear. Here's a link: raspberrypi.org forum


    I recommend asking for help there

  • What other operating systems have been tried using the Raspberry Pi 4 with a Samsung TV ?


    I searched the Kodi Forums and couldn't find any threads with this issue. I did find a thread in the raspberrypi.org forum but it's not that clear. Here's a link: raspberrypi.org forum


    I recommend asking for help there

    After trying evereything I gave up and returned pi4 - I can confirm HDMI-CEC doesnt work on libreelec rpi-4.


    rpi3-b is working fine for me.

  • What other operating systems have been tried using the Raspberry Pi 4 with a Samsung TV ?


    I searched the Kodi Forums and couldn't find any threads with this issue. I did find a thread in the raspberrypi.org forum but it's not that clear. Here's a link: raspberrypi.org forum


    I recommend asking for help there

    I'm having same issue with Raspbian on my Samsung TV...

    And it was my very first experience with a Raspberry... what a nightmare for me to understand what was happening and managing to install everything without screen and understanding if the issua was with the device, with the SD card or the cable or whatever...

    Only when I turned of and on the TV I saw for a split second the desktop image and confirmed that the issue really was with the communication between TV and Raspberry. Then, with an old, small, "crappy", lcd TV it worked with no problems... so, really is an issue between TV and Pi4

  • Hi Everyone,


    I've tried combination cable, on/off, visa versa hdmi port. rpi4 hdmi cec not working on my Tv even rpi3 working as well. We have to wait for new release to solve the problem.

  • I've just installed the latest Public Alpha Release (not a nightly) and my Pi4B CEC works fine from a Sony XF9005 and Denon AVR X2400H if I start the Pi whilst the TV and AVR are both routed to the Pi. TV Remote controls Pi, Pi controls Denon volume.


    However if I switch away from the Pi 4 routed through my AVR to another HDMI input on my TV (not my AVR) - where my TV will automatically switch the Denon AVR to ARC Audio - and then switch back to the AVR HDMI input (and the AVR switches back to the Pi 4B input on the AVR), the CEC control from the TV has stopped working, but the CEC control of the Pi4B to the AVR continues to work.

  • Also with my Sony Bravia I have troubles with CEC pulse eight, RB pi4 and Kodi 18.4 Leia.

    It seems that remote control works just after a fresh install of LibreELEC-RPi4.arm-9.1.501.img, but then, after switchin off and on again, it stopped doing its work... Also downgrading to LibreELEC-RPi4.arm-9.1.002.img does the same (working at first run, then stopping).

    TV and remote perfectly working with RB pi2 and 3 and OpenElec, Kodi 16.1 Jarvis.

    Bravia Sync (settings for CEC) sometimes does not see RB pi 4 and sometimes sees it (but also in this case, remote control not working).

    Any hint?

    Thanks a lot

    :-)

  • I am having the same or similar problems. Massive HDMI problems: TV LG 55UH950V, Raspberry 4B 4GB, LibreELEC-RPi4.arm-9.1.501.img.


    CEC works only sometimes and sporatic on one of the three TV HDMI inputs. I couldn't find any pattern yet.


    Further: HDMI on TV is only active if TV is already running with RP HDMI selected and RP is switched on after. If RP is already running and TV is switched on later a black picture appears only.

  • My problem was a Micro HDMI plug to HDMI-A socket converter, to convert the pi4 new video interface to fix the cable i had for the old pi3 that runs through my ceiling. Bought this converter off ebay and CEC did not work:-

    Micro HDMI To HDMI Adapter Convertor Cable For Amazon Kindle Fire HD 7 8 9 | eBay


    So bought this converter from Amazon and CEC now does work:-

    UGREEN Micro HDMI to HDMI Adapter, Support 4K, 3D with: Amazon.co.uk: Electronics


    So you need a quality MicroHDMI to HDMI converter or CEC might not work.

  • Its funny, my PI3b+ was automatically updated last night to the latest version and now HDMI-CEC doesnt work on it either.


    I am currently rolling it back to 9.0, will see if that makes a difference

  • For me it's still not working with latest LibreELEC Beta on Pi4 + Yamaha AV-Receiver + LG TV and the Micro HDMI adapter by Pimoroni. Absolutely nothing recognized while working with the same constellation on a Pi2.


    Ordered a AmazonBasics Micro HDMI cable (instead of an adapter) now to check if that helps.


    UPDATE: Plugged in the Amazon cable and it was running immediately. The Pimoroni adapter was guilty in my case.

    Edited once, last by Waldgirgl ().