[7.0.3.3d] LibreELEC 7.0 for S805


  • My branch might not compile for RPi3 as I've never focused to keep other projects compiling. If you look carefully, you will see that my 2016-12-01 branch is based on official LE master. You need almost all commits from my branch to build properly for MK808. I have no experience at all in compiling Dolphin-Emu, I can't help you. CEC will be looked into as soon as my buildserver goes back to life. ;)


    Been trying compiling LibreELEC-7.0 branch for RPi2. Finally succeeded in compiling and boots up OK. Unfortunately, I can't seem to attach the two patches. First is a patch to kodi-001-jarvis-rbp-backports.patch in projects/RPi2/patches/kodi, the "ffmpeg: test: increase number of threads" patch in commit f69190f fails, and consequently compilation of kodi fails. Second is patch to config/arch.arm, which is a revert of "[arm] go thumb!" commit f52e282, otherwise LibreELEC compiles but there is a kernel panic on boot. Pardon my possibly silly question, but what does the "go thumb!" supposed to do? I don't think it is in the main LibreELEC branch. With these 2 patches, all my 3 devices (RPi2, MK808B+ and x86_64) compile and boot up into LibreELEC OK.


    I have not tried the krypton branches - CEC not working on my MK808B+ is too much of a problem for me. I might try compiling when the CEC issue is resolved. I don't think it is resolved yet?


    As for dolphin-emu, I now have it compiling for both the LibreELEC-7.0 and krypton branches for x86_64, but have not tested it properly yet. Ultimately, I would like to have it running on my Intel i3 HTPC.


    Once again, thank you for your fantastic work!

  • smoothquark CEC issue with Krypton has been solved but I have not published a fixed build yet. I'm now working on getting media_build drivers to work and I'll post a build when it's done. Meanwhile you can get a fixed libcec patch from LibreELEC.tv/libcec-00-amlogic-support.patch at master · LibreELEC/LibreELEC.tv · GitHub


    "Go Thumb" patch makes the code compile by default in Thumb mode which makes it a bit smaller and maybe a bit faster. I know that it doesn't work for the RPi but I don't compile for the Pi. :angel:

  • kszaq - is there a reason 7.0.3.1 isn't listed Here? There doesn't seem to be a lot of discussion about it around here. Maybe everyone just binned their 805 boxes?

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

  • Hm, I forgot to update the index post, thanks for noticing.


    Actually more people are using my S805 builds than S905 builds. Hardly no new posts here because S805 is a more stable platform. :)

  • It's rock-stable, I'd say :)


    If it could output multichannel PCM audio and play 10bit x265 files, I wouldn't have bothered to update to S905.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • Also the 7.0.3.1 downloads are not in the normal place. Or is that because it is beta?

    LibreELEC running on MK808B Plus from NAND

  • any ideas about implementing the media_build drivers (latest ones)? or are they already in?


    i think my T230 will work on your builds if this is in.


    with CvH build - the device looks like it's going to work (on x86 and pi3) but get insane continuity errors, when enable the media_build drivers button, it works.
    with your build i get the continuity errors, so i assume it just needs the latest media_build drivers installing?

    Edited once, last by snailboy1 ().

  • The latest media_build drivers are already included, I have one patch scheduled that might help discontinuity errors. On the other hand I would not expect wonders from the old kernel we have to use.


  • The latest media_build drivers are already included, I have one patch scheduled that might help discontinuity errors. On the other hand I would not expect wonders from the old kernel we have to use.


    thanks.


    are they the same as in CvH build? (in which you have to select the option - media_build latest kernel)


    otherwise i'm not sure what the issue is. Happens with both wintv dualhd (as a single tuner) and T230.


    -


    anybody else got usb dvb adapters working?


  • I will be gradually moving all S805 builds to the new server. :)


    Just thought I'd mention the build number is wrong on the project page.

    Running:
    S805 - MXQ.arm 7.0.3.1 from Nand on all black MXQ, board number: 'AM_MXQ_A 20150825'

  • im having a couple more issues, and id appreciate any help.
    firstly i cant get the remote to work. ive added the remote.conf file, and ive tried more than one. ive also tried changing the amremote package and compiling.


    secondly ssh isnt working either. i compiled with everything ssh enabled, and i have the ssh bin file and everything. it just wont start.


    im running an S805 mxq all black.


  • im having a couple more issues, and id appreciate any help.
    firstly i cant get the remote to work. ive added the remote.conf file, and ive tried more than one. ive also tried changing the amremote package and compiling.


    secondly ssh isnt working either. i compiled with everything ssh enabled, and i have the ssh bin file and everything. it just wont start.


    im running an S805 mxq all black.


    I also have an S805 MXQ black (still might not be the same :-/) but...


    Why are you compiling anything? The releases 7.0.2.7 and 7.0.3.1 both should work fine. Work those out first before you resort to any patching/compiling.


    Where are you installing the remote.conf file? Are you enabling SSH in the GUI on the First Boot Wizard?

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

  • A new build with some fixes to media_build drivers. Those of you who don't use USB tuners don't need to update:
    7.0.3.2 7.0.3.2


    Commits from 7.0.3.1 to 7.0.3.2: Comparing 7.0.3.1...7.0.3.2 · kszaq/LibreELEC.tv · GitHub
    Kernel commits from 7.0.3.1 to 7.0.3.2: Comparing 263a24f...fb5b898 · kszaq/linux · GitHub


    Changelog:

    • reverted USB driver patch that broke some DVB tuners
    • added some kernel backports to fix missing symbols in some media_build drivers
    • re-added thumbnail speedup patch from SPMC
    • added some memory leak fixes from SPMC Jarvis
  • Thanks for the update. It works flawlesly on my MXQ and MK808B. I don´t know what should repair that USB patch in 7.0.3.2, but my USB DVB-T dongle with Realtek RTL2832 doesn´t work. It says that there is no free tuner. Revert to 7.0.2.2 where DVB tuner works perfect.

  • Hello kszaq


    Your latest m201d build is working perfectly on my box but my remote is not working. I have used the remote.conf from my android box but it still isn't working. Can you please help me?
    I've attached the remote.conf file here.

    Files