opensubtitles subtitles not working

  • Hello I'm having this issue with libreelec for a couple days now where opensubtitles suddenly stopped working, when I try to load subtitles theres an error prompt asking me to check the log. Can I fix it or do I need to reset libreelec? Any help is appreciated.


    raspberry pi 3 model b


    armv7 rev4 bcm2709


    libreelec 7.0.2


    03:10:04 76.489456 T:1706816416 ERROR: GetDirectory - Error getting plugin://service.subtitles.opensubtitles/?action=search&languages=English%2cSpanish%2cSpanish%20(Argentina)%2cSpanish%20(Mexico)&preferredlanguage=Spanish%20(Mexico)
    03:10:05 76.862770 T:1395356576 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <type 'exceptions.UnicodeDecodeError'>
    Error Contents: 'ascii' codec can't decode byte 0xc3 in position 42: ordinal not in range(128)
    Traceback (most recent call last):
    File "/storage/.kodi/addons/service.subtitles.opensubtitles/service.py", line 26, in <module>
    shutil.rmtree(__temp__)
    File "/home/chewitt/LibreELEC.70-official/build.LibreELEC-RPi2.arm-7.0.2/Python-2.7.11/.install_pkg/usr/lib/python2.7/shutil.py", line 241, in rmtree
    File "/home/chewitt/LibreELEC.70-official/build.LibreELEC-RPi2.arm-7.0.2/Python-2.7.11/.install_pkg/usr/lib/python2.7/posixpath.py", line 71, in join
    UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 42: ordinal not in range(128)
    -->End of Python script error report<--

  • Have the same problem on a Cubox. Same error subs from Specto or SALTS show up fine, but subtile from Opensub or other sub services fail. Running latest Krypton alpha.

  • Just wanted to answer my own question, this problem is fixed by deleting the temp folder here \\LIBREELEC\Userdata\addon_data\service.subtitles.opensubtitles

  • Just wanted to answer my own question, this problem is fixed by deleting the temp folder here \\LIBREELEC\Userdata\addon_data\service.subtitles.opensubtitles

    Nice persistence after almost two years! Thanks for the tip!

    Bqeel M9C Max [S905X/2G/16G]: LibreELEC always the latest community version

  • Unfortunately, the '\\LIBREELEC\Userdata\addon_data\service.subtitles.opensubtitles' folder is not a TEMP folder.

    It's where the settings for the OpenSubtitles are being stored.