Posts by Petes

    I find it hard to believe that your ISP blocked NTP - I would call them up, as I find that unacceptable.


    It's not Kodi nor LE that is using NTP it's the underlying Linux software that uses NTP.


    Why do you think NTP is blocked?

    Yeah, I know because one day (april 30th) all my computers stopped syncing the time, I have tried accessing NTP with my computers and my phone in airplane mode through Internet and I have an app to test NTP servers so I'm pretty sure the blocked it, that or some firmware update in my router.


    Having no NTP access is more noticeable with libreelec because my RPI has no battery and many addons break without the right time. I talked to my ISP and after 3 days of insisting they decided to actually investigate, they told me that yes there is a problem that is also affecting other services (no idea what it means) but I'm still waiting for it to get solved, I don't have many hopes for a prompt fix though.

    So, my ISP blocked NTP servers and I'm trying to find alternatives so I installed an NTP server in my Android phone but there seem to be limitations within Android and it can't use port 123 so I tried using port 1233 but when I try to configure Libreelec it won't let me enter a port number next to the IP Adress field.


    So I want to suggest a feature for Libreelec to allow inputing port numbers for NTP time servers.


    Thank you.<3

    My zip file virtual.rpi-tools-9.0.105.RPi2.zip contains gpiozero 1.5.0 which should not needed setuptools from Python. But it needs colorzero package (which is included in addon).


    Uninstalling addon virtual.rpi-tools and install my version from ZIP should also work. Or just installing. So many options :|

    Thank you, I'm no sure what the problem was but it works now!

    Under closer inspection, I believe that gpiozero may be badly installed? All I did was to move the gpiozero 1.5.0 folder inside "/storage/.kodi/addons/virtual.rpi-tools/lib", considering that the error seems to be very similar to the one from 1.4.1 may I suggest that gpiozero is not installed as it should in LE 9.0? Or some compatibility issue with python 2?

    Ok, I made it, I installed gpiozero 1.5 but now I get this error:


    LibreELEC:~ # python shutdown-press-simple.py

    Traceback (most recent call last):

    File "shutdown-press-simple.py", line 5, in <module>

    from gpiozero import Button

    File "/storage/.kodi/addons/virtual.rpi-tools/lib/gpiozero/__init__.py", line 97, in <module>

    from .output_devices import (

    File "/storage/.kodi/addons/virtual.rpi-tools/lib/gpiozero/output_devices.py", line 45, in <module>

    from colorzero import Color

    ImportError: No module named colorzero

    Seems gpiozero needs setuptools package which is not present on LE.

    Can you try this version with gpiozero 1.5.0? virtual.rpi-tools-9.0.105.rpi2.zip


    Code
    1. wget -O virtual.rpi-tools-9.0.105.RPi2.zip http://vpeter.libreelec.tv/RPi2/virtual.rpi-tools-9.0.105.RPi2.zip
    2. unzip virtual.rpi-tools-9.0.105.RPi2.zip -d /storage/.kodi/addons

    Yeah 9.0.105 is the same that already comes with the LE 9.0 repo but I ran the commands anyway, the result is the same, it still doesn't work, same error message from my first post.


    Edit:

    Sorry my bad, I'm still using gpiozero 1.4.1, I'll try to install 1.5.0 and post the result here but right now I have no idea on how to install it on LE

    So, I just wanted to update the issue, I installed the final 9.0 release and the problem seemed to be fixed since I pushed the button and libreelec shutdown successfully but it only worked one time, right after the installation but now gpiozero is not working again.


    Same error message as above.

    Yeah, I think that there's something that needs to be updated by the libreelec gods, hope it gets fixed for the final 9.0 release. Meanwhile I'll try the other method.

    Hello, can you help me? I have installed a hardware switch to my RPI to run the shutdown command, I am using gpiozero and it was all working perfectly until I installed the latest LEIA v8.95.1 beta, now if i try to run the command I get an error "ImportError: No module named pkg_resources".


    Here Is the command with the error:


    LibreELEC:~ # python /storage/shutdown-press-simple.py

    Traceback (most recent call last):

    File "/storage/shutdown-press-simple.py", line 5, in <module>

    from gpiozero import Button

    File "/storage/.kodi/addons/virtual.rpi-tools/lib/gpiozero/__init__.py", line 22, in <module>

    from .devices import (

    File "/storage/.kodi/addons/virtual.rpi-tools/lib/gpiozero/devices.py", line 19, in <module>

    import pkg_resources

    ImportError: No module named pkg_resources


    And in case you need it, this is my script:


    import sys

    sys.path.append('/storage/.kodi/addons/virtual.rpi-tools/lib')


    #!/usr/bin/env python3

    from gpiozero import Button

    import os

    Button(21).wait_for_press()

    os.system("shutdown now")

    Disabling deinterlace fixes it, Bob (half) is better, Bob is the worse (and I think that "Auto" selects this one), the two Advanced options also fix the issue.

    I tried audio_pwm_mode=2 and it didn't work, the "Resample Qualtiy" is medium but no matter what I set it to the problem is not solved.


    Something that I noticed is that if I change the "Audio output device" from "analogue" to "hdmi" or "analogue and hdmi" while playing a channel the audio gets distorted, it's like a low pitch so everything has a grave sound. The only way I know to fix the pitch issue is to reboot libreelec.

    Hello, I'm having this issue since I updated to the newest version 8.2.4 MR, the problem is that the audio has a crackling noise when I use tvheadend, I have the RPI 3 (not the new one), If I open the channel from the network with VLC I don't notice any crackling noise.


    I copied an image of the previous version and there is no noise but when I update to the new version (8.2.4 MR) the noise is back so I'm sure it's a problem with the newest update of Libreelec.


    I use the 3.5 jack with the analog "audio output device" setting.

    Nah, it's ok, I tried the clean install and the problem still was there so it isn't a configuration problem. I'll just wait and see what happens, maybe the channel owners are making some test and they'll change the video format to a more compatible one.