Nightly images for A64, H3, H5, H6 and R40 boards

  • sounds great ! once it's available in master - I'll provide feedback regarding testing suspend/resume on my T95max box - one question though, how about using HDMI CEC as well IR to wake up the box ? is that next ?

  • forart I have T95 box but H616 support is in very early stages, currently we are happy that mainline U-Boot and kernel boots and network work. However, I didn't manage to make HDMI to work. It will take some time before H616 becomes viable for LibreELEC.

    quovodis which image you're using for T95max? If you're using Tanix TX6 image, I'll have to disappoint you that it won't be supported at first due to a lack of power management chip. There was a talk about possible CEC wakeup source implementation but it won't come soon. Author of suspend functionality isn't really interested in that case and I'm working on other things...

  • Which board? In LE you add new board in scripts/uboot_config. If you mean how to add board to Linux (how to write DT file) then I'm afraid it's out of scope for this forum.

    It's an MXQ 4k pro-s 1GB/8GB Allwinner H3 should be pretty similar to the Beelink X2. Libreelec works actually but only with one out of 4 SD-cards I tried, and that one is a very old 2GB no name micro-sd card, it's disgustingly slow. I tried multiple cards including a SanDisk Ultra A1 32GB a sandisk class 4 card and a 2GB Kingston Card class 4 also. None of them work with libreelec, but the "triggering FEL" image on the linux-sunxi wiki works on all of them. Pretty damn strange, do you have a clue what the issue here could be?

  • No, not really. I remember there was similar issue with U-boot long time ago, but IIRC it was solved... Anyway, fixing TV box issues is hard due to missing board schematic. Some things may be deduced from fex file if you can extract it from Android update file.

    How do I extract that ? I have a firmware file but I didn't find any tools that support extracting H3 images.

  • There is awutils tool suite for handling Android images/updates. They are easy to use, so I think you can manage on your own. Note that TV boxes are not really supported here anyway because of their quirkiness and changes between different batches (same model can have different wifi modules among other things). Even Beelink X2 image has some strange issues with eMMC on some revisions...

  • I've been using the nightly H6 build for my Orange Pi 3 for a while. Every once in a while there's hiccups, but I like it quite a bit and it seems to work very well. I really only have one plugin, for MythTV. This is on a 4K TV.

    Over the holiday break, I upgraded from 20200917 to 20210102 and noticed that when viewing recordings from MythTV, the video and audio would pretty quickly get out of sync. I poked around and eventually found that deinterlacing was turned on by default. After turning it off, the video stays synchronized.

    I don't know if deinterlacing was turned on by default before, but if it was, it worked. If not, I would like to find where to turn it off for everything, but a search of where I thought it might be in the interface failed to yield a result.

    I don't know if the deinterlacing synchronization issue is a bug I should report somewhere?

  • The problem:
    orange pi lite 2 (H6) + samsung 32K5500 (1080/60) + Nightly images (any version from the last couple of weeks) = No signal HDMI
    Share the secret - how to make it work HDMI?
    orange pi one plus - a similar problem

  • I tried the latest for H6 on both Orange PI3 and Android box. The problems I encountered are the reboot or the block on launch of the Tvheadend client. Many times when the channel changes it restarts, on all 2 devices. , that I did not understand if there will be "the cure", the sleep of the devices if they are not used without the possibility of restarting them if not restarting. Thanks

  • Hello,

    I've been testing and compiling the master branch since found no builds that actually works in Pine64 legacy.

    The pine-plus images seems to do the deal, but either pine or pine-plugs fail to setup video.

    This is the best I can get. And it fails because video doesn't correspond with the display image... (I suppose that because when you start the libreelect you get a nice wizard I don't see there but I can hear the clicks when I use keyboard).

    The system is unresponsive and unusable. My build is LibreELEC-A64.arm-9.80-devel-20201206105444-edb090e-pine64-plus.img.gz

    And this is the Pine64 2Gb


  • Trying my MCE remote with H5 OrangePi PC2 and a recent nightly build for the first time, actually it's a Logitech Harmony configured as MCE which has always worked with LE. Not here, Kodi doesn't react. When I test it in the terminal I get for example:

    The sensor is working but there are no events generated it seems. According to Infra-Red Remotes - MCE is supposed to always work out of the box. What am I missing?

    Edit: Turned off CEC in settings, makes no difference.

    Edited once, last by hello_world.c (January 22, 2021 at 9:15 AM).

  • gaguilar I have never seen such issues on A64, either with Pine64 plus or OrangePi Win and I tested both boards recently (a couple of weeks ago). It seems to me like some GPU issue. Can you execute command pastekodi and provide a link produced?

    AjayDabas Read first post. installtointernal is (was?) amlogic specific.

    hello_world.c I worked with IR just this month but there were no remotes pre-configured. I had to add mce mapping.