Nightly images for A64, H3, H5, H6 and R40 boards

    • Official Post

    Please test latest OrangePi PC2 (H5) image:


    If it is good enough, it will be merged into official LibreELEC git repository and nightly images will become available soon thereafter.

    I'm having trouble with logging in to the YouTube add-on:

    LoginExcepiton: [401] deleted_client ...

    The OAuth client was deleted

    What can I do to fix it?

    Only current solution for YT plugin is to create your own keys. Just follow Personal API Keys · jdf76/ Wiki · GitHub I think default keys were revoked by Google. Note: If you did that already some time ago, it's possible that you have to re-create them. My 2017 keys didn't work. Additionally, I had to update to 6.7.0-beta1 due to sign in issues.

  • Hello

    Unfortunately, my OrangePi is PC (H3) and not PC2 (H5)

    Creating a new API key and entering data into the add-on configuration did not change anything

    When logging in to YouTube, the same information still appears - although the site always reports correct login ... I will wait for the new version - maybe the problem will go away ...

    My board is OrangePC and system was installed yesterday from GitHub (2020 03 07)

    Maybe I can install the image you propose on my board?

    • Official Post

    Maybe I can install the image you propose on my board?

    no, it won't work. You have right image already. Part above quote was target to OrangePi PC2 owners in general. I guess I should make two separate posts, sorry for the confusion. YT addon is pain to set up currently, I spend few hours yesterday. Just try python3 6.7.0 beta1 from here: Release 6.7.0-dev · jdf76/ · GitHub

  • Decided to give the nightlys another go after 6 months on my OPI3. All hardware seems to work nice, however most videos have a shudder, like they're going at maybe 15fps.. Is there current problems with video decoding on the OPI3?

    • Official Post

    Is there current problems with video decoding on the OPI3?

    No. Press "o" during playback and check which codec it is and if it is HW or SW decoded. Chances are that you're using unsupported codec and it's decoded in software. That can happen with YouTube plugin now that more and more video streams are VP9 coded. While H6 technically supports HW decoding VP9, it will take a while before it becomes implemented.

  • Yes, I wired rx and tx crossed over looking at the label on the pin. Anyways, I switched the rx tx over and it works! I guess it is either the label on my usb serial is wrong or I was just too tired after coming back from work.

    Ok, attached is the log from serial log from Orange Pi One. I compared the log from the one that fails to boot and the one that boots (the image from dejan_).

    jernej It seems like in both cases uboot managed to reach "starting kernel ...". There seems to be not enough info for this from the serial console log I collected. Will removing "quiet" from extlinux.conf make it more verbose?

    jernej This is continuation of the Nano Pi (and Orange Pi One) failed to boot unless u-boot: update to v2020.01 is reverted reported by dejan_ and natumbri . I have tried to capture the output from serial console using usb serial with "quiet" removed from extlinux.conf to get more verbose info. However, it seems like removing "quiet" produces no extra info. It still stops at "starting kernel". Do you have a suggestion on how to proceed next to investigate this issue?

  • jernej Do you think an Opi Lite 2 image is possible now that the Opi 3 and One Plus are supported? The only differences I can think of are the different WiFi chip (AP6255 vs. AP6256 on the Opi 3) and only one USB 3 port (without hub chip, I think).

    I'm sure those differences can be solved using DT bindings, but I have no idea on how to use those on the LibreELEC compilation stack (I would also be thankful if someone could lead me to a wiki or give me advice on that).

  • Hi,

    as far as i understood, the tanix-tx6 image should work with the Eachlink H6 Mini regarding to my resarch here and elsewhere.

    Is this supposed to work ootb or are there any tweaks necessary to get it work? I simply flashed my SD-Card with the image and fed it to my Eachlink H6 Mini, but i get nothing on HDMI. The device isn't reachable via network, too.

    If i misread it and the Eachlink still needs some work, i will probably try to implement it...

    Thanks for any hints :)



  • Dear Jernej,

    Many thanks for your work! I am new here, so hello everyone! :);)

    I would like to test your build on my Orange Pi Plus 2E. I have installed it fine but I were unable to find any suitable PVR IPTV Simple Client neither in repository, nor from the Web. I have tried to install lots of different versions from ZIP files (3.8, 4, 4.1.1 etc.) but the Kodi just said there were problems and the Add-on hasn't been installed.

    Perhaps, you could provide me a working IPTV Simple Client, so I was able to test the video acceleration on my board? Any help would be highly appreciated!!!

  • Hi, I’m using an image for my “orange pi one-plus”.


    The board is connected via HDMI to the TV, the OS boots, but there is no image.

    The TV writes “there is no signal at the input”, BUT in the TV speakers, through the crackle, the sound of moving through the menu items is heard. (I press enter on the keyboard)

    With Other images from the site orange (all sorts of armbian) normally output the image and sound ...

    what could be wrong?

    BOOT Serial OUTPUT

    U-Boot SPL 2020.01 (Mar 11 2020 - 08:25:31 -0400)

    DRAM: 1024 MiB

    Trying to boot from MMC1

    NOTICE: BL31: v2.2(release):9.0.0-3023-g097260ac30

    NOTICE: BL31: Built : 07:29:24, Mar 11 2020

    NOTICE: BL31: Detected Allwinner H6 SoC (1728)

    NOTICE: BL31: Found U-Boot DTB at 0xc07a8b0, model: OrangePi One Plus

    NOTICE: PMIC: Probing AXP805

    NOTICE: PMIC: AXP805 detected

    U-Boot 2020.01 (Mar 11 2020 - 08:25:31 -0400) Allwinner Technology, Build: jenki ns-H6-195

    CPU: Allwinner H6 (SUN50I)

    Model: OrangePi One Plus

    DRAM: 1 GiB

    MMC: mmc@4020000: 0

    Loading Environment from FAT... *** Warning - bad CRC, using default environment

    In: serial@5000000

    Out: serial@5000000

    Err: serial@5000000

    Net: No ethernet found.

    starting USB...

    No working controllers found

    Hit any key to stop autoboot: 0

    switch to partitions #0, OK

    mmc0 is current device

    Scanning mmc 0:1...

    Found /extlinux/extlinux.conf

    Retrieving file: /extlinux/extlinux.conf

    187 bytes read in 9 ms (19.5 KiB/s)

    1: LibreELEC

    Retrieving file: /KERNEL

    18520072 bytes read in 1862 ms (9.5 MiB/s)

    append: boot=UUID=1103-2410 disk=UUID=cdbb4d0e-d433-4856-87ed-5b2e0bc7c274 quiet console=ttyS0,115200 console=tty1

    Retrieving file: /sun50i-h6-orangepi-one-plus.dtb

    20797 bytes read in 9 ms (2.2 MiB/s)

    ## Flattened Device Tree blob at 4fa00000

    Booting using the fdt blob at 0x4fa00000

    Loading Device Tree to 0000000049ff7000, end 0000000049fff13c ... OK

    Starting kernel ...

    [ 0.284168] sun50i-de2-bus 1000000.bus: Error couldn't map SRAM to device

    [ 0.284744] sun4i-usb-phy 5100400.phy: Couldn't request ID GPIO

    [ 0.449507] sun4i-usb-phy 5100400.phy: Couldn't request ID GPIO

  • rellla Please check with serial console what's going on, note that you should remove "quiet" kernel argument from extlinux.conf. Eachlink H6 is known to have issues with mainline U-Boot and Linux - with DRAM initialization and with HDMI plug in detection. There are workarounds available as described on Armbian forum, but it would be good to know which one of these two issues you experience (or both).

  • So those come from armbian and mainline kernel, as I expected. As far as I understand I could fetch the commits from that pull request, do I need to also make an specific "target" for the Orange Pi Lite 2? Where are the target files for the supported devices located in the git repo?