Nightly images for A20, A64, H3, H5 and H6 boards

  • jernej: Ok, hdmi setting is enough, to get it up. And this is the keymap for Eachlink H6 Mini remote control:


    But i still have the problem, that the box doesn't come up after a reboot anymore... And i don't know how to debug it without UART....

  • Hi,

    with my cubietruck I still see the black screen after boot messages using the latest nightly LibreELEC-A20.arm-9.80-nightly-20200321-ae22e11-cubietruck.

    When I try image LibreELEC-A20.arm-9.80-nightly-20200321-ae22e11-cubieboard2 on my cubieboard2 using same peripherals it is working fine and I can set up and use Kodi.


    In the dmesg output attached I can not see very big differences. Only the page fault at the end. Can I provide anything else to help?


    On the cubietruck I had set mem=1G as parameter.


    Regards,

    Dirk

  • jernej: I created a branch for the Eachlink H6 Mini here: GitHub - rellla/LibreELEC.tv at eachlink-h6mini


    Libreelec builds, i will check, if it works tonight.


    [Edit]The image works. It starts, resizes flash and starts again. Kodi works fine - but sadly it doesn't come up again as soon as i did a shutdown or disconnect. I get signal on HDMI. It's kind of a console ... i can see my inputs with keyboard and remote, but thats it. No network, just black screen.

    Would i get kernel messages, if i drop the “quiet“ option?[/EDIT]


    Btw, is it possible to set LibreELEC.tv/options at eachlink-h6mini · rellla/LibreELEC.tv · GitHub depending on the device?


    rellla

    Edited once, last by rellla ().

  • And this is the keymap for Eachlink H6 Mini remote control:

    Maybe you can send it upstream?


    Kodi works fine - but sadly it doesn't come up again as soon as i did a shutdown or disconnect. I get signal on HDMI. It's kind of a console ... i can see my inputs with keyboard and remote, but thats it. No network, just black screen.

    Would i get kernel messages, if i drop the “quiet“ option?

    What do you do after shutdown? After shutdown you can only power cycle the board to turn it on again. You can of course try with removing "quiet". I suggest you add "ignore_loglevel" to get even more output.

    Btw, is it possible to set LibreELEC.tv/options at eachlink-h6mini · rellla/LibreELEC.tv · GitHub depending on the device?

    By device you mean board? Devices in Allwinner project are actually SoCs. There is no way to set board specific kernel options. However, you can make SoC specific options. Just move that line in options file in appropriate device subfolder.

  • Maybe you can send it upstream?

    I guess we should bring the board itself upstream first? Or do you mean upstream libreelec?

    What do you do after shutdown? After shutdown you can only power cycle the board to turn it on again. You can of course try with removing "quiet". I suggest you add "ignore_loglevel" to get even more output.

    I just do a shutdown in kodi and then disconnect the board from power supply. Then i reconnect it again. I still have to do some investigations, because on the HDMI input of my Samsung TV i get the black screen - but today i tried the same Box on a simple HDMI monitor and get Kodi screen again.


    [EDIT]Update: After 3 hard power disconnects, the box goes to black screen even with the monitor. This smells like some random issue... I'll try it later agein. It's strange anyway.... [/EDIT]


    [EDIT2]After disconnecting the board from power for ~10min, it boots again into kodi... Maybe this is a 2GB/3GB mem issue or thermal issue after all?


    Btw, this happens with GitHub - rellla/LibreELEC.tv at eachlink_working, which is simply the Tanix Image with kernel parameter fix and the remote added...

    With the other branches, i don't get networking up. But therefore I have to look into the dts for the differences.

    By device you mean board? Devices in Allwinner project are actually SoCs. There is no way to set board specific kernel options. However, you can make SoC specific options. Just move that line in options file in appropriate device subfolder.

    Yes, board. Thanks for your answer. So best would be to find a way, how this could be fixed within the driver?

    Edited once, last by rellla ().

  • That's because Orange Pi 2 uses an USB HUB to provide 4 ports, you should be able to use OTG port however. I'm not sure if the following workaround apply also to libreelec, but to make work an Armbian image for Orange Pi Lite on Orange Pi 2 I had to specify the right fdt file in armbianEnv.txt

  • Hi. I'm using this build: LibreELEC-H3.arm-9.80-devel-20200314102408-6c08564-orangepi-pc.img.gz, OrangePi PC, TBS 5520se, but don't recognize (tv headend/adapters don't show/empty). Where I find tbs drivers?



    lsusb show TBS...


    service or program addons don't show drivers to choose (tbs, crazycat, etc)..

    Edited 2 times, last by frankviana ().

  • Dear Jernej,


    I have encountered few more serious problems with current images.


    First is that the image turns off so there is just black screen but with the working system (can hear sounds) and I have to restart (sometimes few times) from my mobile app to get the image back on again.

    And the second issue is just complete freeze during TV watching. The video stops and the sound too (some millisecond of the same sound is repeating all the time) and the only way is to do a hard restart (power off and back on again).


    I watch TV for the half of the day currently and both of these problems happen about 2-3 times every day always.

  • Hi Jernej.


    I noticed a problem with HDMI-CEC and my Samsung TV UE55ES7000 in nightly 2020-03-24, previous one I tried is not affected (2020-03-04). CEC service connects at startup, but after one or two action via TV remote, TV warns that Anynet device has disconnected and CEC does not work anymore until board reboot. After reboot behaviour is the same, only one or two actions are possible. Board is an Orange Pi 2 mini (same as Orange Pi 2 but without integrated wifi).

    Please let me know if you need further info on this.

    Thanks for the great work.


    BR

    Christian

  • Jernej, I always wondered if the current build Kodi is able to download and install any updates itself, or would I have to compile it on my own each time and update manually from file?

  • I guess we should bring the board itself upstream first? Or do you mean upstream libreelec?

    No, I mean upstream kernel. well, I don't think it matters. But mainlining board would be great too.

    With the other branches, i don't get networking up. But therefore I have to look into the dts for the differences.

    You mean other board images? Only Tanix TX6 image have enabled 100mbit ethernet.


    Anyway, this board is peculiar from many different perspectives. It would be nice to know why. If you have time to investigate, that would be great.

    So best would be to find a way, how this could be fixed within the driver?

    Yes.

  • service or program addons don't show drivers to choose (tbs, crazycat, etc)..

    Allwinner images don't support those driver addons as they could interfere with Cedrus driver (replaced it with other version).

  • syao Sorry, but I can't help you with CEC. There are no changes in Allwinner project regarding CEC since 3rd March. Maybe you can do a bisection? I don't have much time for LE ATM, except responding on the forum.


    Hi, how i can install the image in a Beelink GS1?

    Burn image on SD card?


    Jernej, I always wondered if the current build Kodi is able to download and install any updates itself, or would I have to compile it on my own each time and update manually from file?

    Nightly and dev images don't do autoupdates IIRC. However, you can always update using update file. Try updating with nightly update.

  • Nightly and dev images don't do autoupdates IIRC. However, you can always update using update file. Try updating with nightly update.

    So, I have to recompile the image in Linux every time and then get only the update file to update manually from Kodi, right?


    Code
    1. git clone https://github.com/LibreELEC/LibreELEC.tv.git

    This git LibreELEC build system has the nightly images, hasn't it? Sorry for stupid questions, but I am really noob here...

  • Hi!

    I'm completely new here and also a complete beginner. So I beg your leniency.

    I have an OrangePi Lite 2 (Allwinner H6) board. Because I didn't find an image for this board, I used an image for OPi One Plus.

    I can say: It works !

    Additional boards can be supported if requested, but only if they are supported by mainline kernel.

    So I have a request:

    Can you create a version for OPi Lite 2 too?

    This would surely welcome more users.

    Otherwise, this very nice board can not be fully used: onboard WiFi and Bluetooth does not work and USB3 port does not work.


    EDIT: Please don't use formatting which suggest screaming.

    Edited once, last by jernej ().

  • I've built an image for OrangePi Lite 2, based on prabuselva's work for PR#3691 (commit 5d209c), which I locally merged with yesterdays master (commit be02e12). No other modifications. In case anyone has that board and wants to avoid building it from scratch ( daviddgm), I've put the image on my google drive. Be reminded that this build is not official and probably entirely unsupported (at least I can give neither support nor any warranty - if this kills your board or cat, or burns down your house, well,... that's bad luck). All I did was the equivalent of grabbing some instant noodles, adding water and letting it boil according to the manual ;-)


    I tested WiFi, BT (stutters in combination with 2.4GHz WiFi), Composite App plays h264/h265 (Plex app doesn't work due to some 'compat' python module not being found - but I think that's something to debug once the board is supported upstream). The board dislikes my LG soundbar (no video when passing HDMI through it; it's probably the boards fault, not LE) and gets quite warm (I only have a small heatsink - I wouldn't use that board without one!). Infrared, 10 bit HEVC, 4k should be working as well, but I didn't try.


    Oh, yeah: Until the board is included in the official images, I wouldn't bother with any board-specific bug reports (except if the image breaks your board).

    This works almost ok, Plex is not working.

    But Wi-Fi is ok, and playback is ok.