Problems installing LibreELEC 7.0.0

  • My first installation of LibreELEC.
    I'm using a RPi3 hardware, wired and wifi are connected to the internet.
    LibreELEC release 7.0.0, RPi2 and RPi3 (combined) build.
    ssh enabled


    Problem:
    1) I can ssh to LibreELEC. But when adding MPG2 codec, I cannot save the file ( nano /flash/config.txt)
    2) I cann't add file source > error "Unable to connect" Couldn't retrieve directory information. This could be due to the network not being connected. Would you like to add it anyway?


    It seems that the MicroSD card is writeprotected?


    I rebooted the system already.


    Hopefully some one can help me out here?


    Rob

  • Only the 1st aka system partition is set to readonly, so you need to undo that first. Use SSH to log into your LibreELEC box and type:

    Code
    mount /flash -o rw,remount


    Edit and save your config.txt using 'nano' and reboot.


    On the "Unable to connect" I have no clue as of now. Just try and enable the "Wait for network" option in the LibreELEC Settings addon (and reboot).

    Edited once, last by Klojum ().

  • Hi Klojum,


    Thanks for your quick reply! And help on the first part.
    Your answer on the first part worked! My Codec code is inside the config.txt file (also after reboot).


    I'm still getting the same error when trying adding source file.


    Hopefully some one can help on this part?

  • What I try to do, with Libreelec:

    • Go to the Kodi File Manager
    • Add a new source pointing to
      Code
      http://www.rieter.net/install


      and name it Retrospect Installation
      >>>> Error > "Unable to connect" Couldn't retrieve directory information. This could be due to the network not being connected. Would you like to add it any way? <<<<<<<


    • Go back to the home screen and navigate to the Kodi Add-on manager under Settings, Add-ons
    • Select Install from zip file
    • In the listing you will see the Retrospect Installation source. Select it and select the .zip file that is present there called net.rieter.xot.repository-<version>.zip
    • Kodi will now install the Retrospect repository
    • After the installation is complete go to Get Addons and select the Retrospect Add-ons. There you will find “Retrospect” under Video Add-ons.
    • Select it and then click Install. This will download Retrospect and install it.


    If all went well, Retrospect should appear under the System -> Addons -> Enabled Addons -> Video Add-ons. It will show up within Kodi under Videos -> Video Add-ons.


    This error ocurs also with other sources.
    My internet connection is working correct.


    Please advice?

  • Tried your rieter.net link in firefox:

    Quote


    Not Found The requested URL /net.rieter.xot.www/net.rieter.xot.repository-1.0.5.zip was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    So it's not going to work in LE.

  • Hi Troggy,


    I tried other sources even a direct zip. It is not working with LE.


    any sugestion?
    [hr]
    It looks like LE 7.0.0 is blocking internet connection.


    I can ssh to my RPi 3 and connect via FileZilla. In my router I see the Ip adress of the fixed and Wifi internet connection.
    Yes, my internet connection is working correctly.


    I also downloaded the zip file of Awesome streams and copied the zip file (with FileZilla) to the download folder op my LE/ RPi3 and tried to install that. Error internet connection
    [hr]
    It seems to be the following problem.
    I made a cable internet connection + activated Wifi on my RPi3/ LE.


    When I unplug the cable internet connection LE is operating perfectly (not problem adding sources and watching from these sources).
    But combined it is not working.


    I Hope this will help fixing LE. I would like to be flexible to operate both wired and Wifi connction with LE.


    Hopefully this helps

    Edited once, last by RobB ().

  • Hi Klojum,


    Thank you for your feedback but the isue has nothing to do with these streams (it is just an expample).


    As I mentioned it is an isue:
    It seems to be the following problem.
    I made a cable internet connection + activated Wifi on my RPi3/ LE.


    When I unplug the cable internet connection LE is operating perfectly (not problem adding sources and watching from these sources).
    But combined it is not working.


    I Hope this will help fixing LE. I would like to be flexible to operate both wired and Wifi connction with LE.


    Hopefully this helps

  • Don't believe you can have both wired and wifi active on same network.


    Maybe wrong on this, but usually it's one or the other.