How do I make an Libreelec sd card using ubuntu os?

  • Forgive me if this has been asked before and just point me in the right direction with a link but i changed to ubuntu os and now I cant update her sd card I need step by step instruction guys I tried the offical instructions but it didnt works

    cheers everyone Im new to forums but I didtried to search this and tried the instructions for about an hour

    in windows it was a couple of point and clicks ubuntu is so much hassle but thats part of the enjoyment realy hahah

    Edited once, last by asboharry ().

  • To create a fresh setup on a SD card, use our already (in)famous LibreELEC USB-SD Creator tool.

    FYI: This is NOT for updating an existing & running LibreELEC setup.

    I use Ubuntu 15.10 and downloaded the Creator tool and added the x-flag. I accidentally used it without sudo first, got the info, clicked ok and got the creator. As the information says, I cannot write to the SD card.

    Now I tried it with sudo and nothing happens. I don't get any information in the syslog, ... nothing. What do I miss?

    • Official Post

    Please tell us how you have written the command to start the tool.

    Beside the tool you are also able to download the file manually, unpack itand then use 'dd' to write the file to the stick.

    for example:

    sudo dd if=</path/to/file.img> of=</path/to/device> bs=4M

    /path/to/device should be changed to something like: /dev/sdb

    depends on how the device is mounted. check 'dmesg' for the correct path to the device. be carefull to select the correct one. the drive will be wiped completely.

    but normally the tool should work. so please try using that again.

    • Official Post

    I use the creator on Ubuntu 14.04 without issues.

    Are you sure you have the correct file (32bit vs 64 bit)?

    # cd <Directory where it is installed>
    # sudo ./LibreELEC.USB-SD.Creator.Linux-64bit
    (And a gui should pop up)

  • With using --debug parameter application writes some info to console. Useful in such cases.

    sudo ./LibreELEC.USB-SD.Creator.Linux-64bit --debug