[S812] MIII Plus 2Gb\16Gb eMMC

  • Can you please update to Leia 18 final version.. waiting since Nov. 2018.

    I'm working on it, but it's not fast. Kernel 3.10 is very outdated and the main work is to add support to the main kernel.

  • Hi Balbes,


    Can you please update to Leia 18 final version.. waiting since Nov. 2018.


    Thanks in advance.

    Not to take away from the good work that Balbes has done, but have you tried going back to the pure android version?


    The biggest reason I started using LE was that the pure android version of Kodi 17.6 had horrible jidder problems when it tried to play a movie at 24FPS and it couldn't change refresh rate of the TV away from 60FPS.


    Just a few weeks ago I decided to give Kodi 18.1 a shot because of the fact that S812 has a kernel issue, being stuck at 3.10, which is making it difficult for the developers here to create a 9.0.1 version.


    I was stunned to see little or no jidder. There was a tinny amount when the movie started. Then I cranked up "Enable HQ scalers to 90%" and that disappeared.


    So now I am happy just running the standard android distro and now I can use android again if I wish.

  • I'm working on it, but it's not fast. Kernel 3.10 is very outdated and the main work is to add support to the main kernel.

    Thanks Balbes, I will wait until you release the new version.


    Thanks Roel, But I have never used AlexELEC. I used Balbes builds since Belbes started to release here - one of the earliest adopter of Belbes releases.


    Thanks Kingsombra - I will test android build too but I prefer LibreELEC more compared to Android environment. Lot easy and fast and reliable.

  • Test version of LE-10 (KODI-19) with the 5.10 kernel from Martin. :)

    Versions for s8xx are located in directories with the s8xx extension


    LIBREELEC — Yandex.Disk


    KODI works well, the interface is fast even when starting the system from USB media. I didn't get the sound through either HDMI or analog 3.5, but I have a USB sound card for$ 2, with it the sound works fine (no video brakes). HW video does not work yet (this is understandable), but even in SW mode, the system works smoothly with 720p video and USB sound.

    Great job Martin. :)

  • balbes150

    great news, should it work on the wetek core also? If not, is the sourcecode available on github, so we can build it ourselves?

  • It's a s812. I asked because this thread is for MIII-plus. So the dtb should match. Or can we select the appropriate dtb?

  • Just test it on my M8S. Boots fine with the mxIII-plus dtb, but not with the M8S dtb.

    Could test further as it seems I got a overload on the usb ports and now the usb doesn't work anymore. I hope there is some kind of overcurrent protection on this box, so when it's cooled down, it works again.


    Regarding the wetek core. It seems there is no dtb for the wetek core in mainline.


    Edit: My usb-ports don't work anymore...

    Edited once, last by roel ().

  • Current plan for WeTek Core support is to find one on eBay somewhere in the EU and ship it to Martin. I also have a box, but 3.10 device trees are so radically different from what I'm used to (device tree was a very new invention back then) that I honestly don't quite know where to start :)

  • If I could help I would, but I don't understand a thing about making device trees. I once started reading the documentation, but I have zero background, so it's all chinese to me.

    If I find another wetek core, I will contact you regarding Martin's adress.

  • Martin found one earlier .. and he will purchase (and we will refund the cost). It will still need some detectivework so I wouldn't expect quick results; the older Amlogic boards have more variance between devices than current boards which are usually a quick copy/paste exercise.

  • Purchase is done. Martin is rather amazingly persistent with Meson8 support. I'd liken the reverse engineering effort to working a crime scene where you already know whodunit but there are few clues. The older BSP kernels are full of magic values so there's a lot of detective work involved.