Plex Media Server on LibreELEC

  • Solved the "plex-update.sh: not found" error and got it to work!


    Looks like it's a problem with how Windows saves documents (I thought I was being careful by using Notepad++).


    These commands should fix the files:


    dos2unix /storage/scripts/plex-update.sh

    dos2unix /storage/.config/plex.conf

    dos2unix /storage/.config/system.d/plex.service


    And then run: bash /storage/scripts/plex-update.sh to execute the script.


    I also removed the \x20's from the plex.service file and replaced them with spaces, but I'm not really sure if that did anything significant. Also, I changed the file permission for all three files to 777.


    When I run: systemctl enable plex; systemctl start plex


    Nothing seems to happen, nothing in the logs. I'll have to figure this out later.


    Update:

    So I had to add back in the \x20 for it to start. It says it's running when I run top - i but doesn't show up as an installed addon. I'm not really sure where the server database is either. Is it in the .cache/plex.app folder or somewhere else? Trying to migrate it from the docker set up.


    If I go to http://192.168.1.80:32400/ it shows me an xml file without any styling.


    Update:

    If I do systemctl status plex


    I get this:

    Update:


    Just had to add /web like so: http://<local.ip>:32400/web


    Found the database folder here: /storage/.config/Plex Media Server

    Don't now why I didn't see it there before.


    If anyone has trouble finding the docker Plex Media Server folder, it's here:

    /storage/.kodi/userdata/addon_data/docker.linuxserver.plex/Library/Application Support/Plex Media Server

    Edited 9 times, last by Morawake ().

  • It was working fine until one day the server went down and wouldn't come back up. I tried fixing it by rerunning bash plex-update.sh but I got this:



    /storage/scripts$ bash plex-update.sh

    Plex directory does not exist, installing.

    mv: can't rename 'usr/lib/plexmediaserver': No such file or directory

    plex-update.sh: line 30: can't create /storage/.cache/app.plex/.plex_version: nonexistent directory

    bash: =: argument expected

    Plex up to date.


    Anyone else have this problem?


    app.plex got renamed to app.plex.old but it wasn't replaced with anything.