Plex Media Server on LibreELEC

  • Just wanted to check to see if anyone else had an issue updating the latest PMS release. I had been successfully using this script for the past 18 months, when it failed when trying to update to version 1.15.1.791.


    I found that data.tar.gz file contained in the .deb file had changed to data.tar.xz. A quick change in the script, and everything worked as expected.

    Code
    tar -xvf data.tar.xz
  • Has anyone else started to experience memory leaks with Plex Media Server since the 1.15 release (released March 2019)? I have found that my system had become quite unstable since upgrading. This week, I downgraded to 1.14.1.548, and my system has been much more stable ever since.

  • If you add my repository inside it has the plex media server addon updated for both x86_64 and arm


    Tnds82 - Repository


    it does NOT work on Raspberry Pi 4B ( 4Gb), please fix it.


    ● service.plexmediaserver.service - Plex Media Server

    Loaded: loaded (/storage/.kodi/addons/service.plexmediaserver/system.d/service.plexmediaserver.service; enabled; vendor preset: disabled)

    Active: failed (Result: exit-code) since Wed 2019-07-03 14:40:54 CEST; 13min ago

    Process: 489 ExecStart=/bin/sh -c exec sh /storage/.kodi/addons/service.plexmediaserver/bin/pms.start (code=exited, status=134)

    Main PID: 489 (code=exited, status=134)


    Jul 03 14:40:54 LibreELEC systemd[1]: service.plexmediaserver.service: Service RestartSec=5s expired, scheduling restart.

    Jul 03 14:40:54 LibreELEC systemd[1]: service.plexmediaserver.service: Scheduled restart job, restart counter is at 3.

    Jul 03 14:40:54 LibreELEC systemd[1]: Stopped Plex Media Server.

    Jul 03 14:40:54 LibreELEC systemd[1]: service.plexmediaserver.service: Start request repeated too quickly.

    Jul 03 14:40:54 LibreELEC systemd[1]: service.plexmediaserver.service: Failed with result 'exit-code'.

    Jul 03 14:40:54 LibreELEC systemd[1]: Failed to start Plex Media Server.

    Edited 2 times, last by ercopico ().

  • Rpi4 same problem:

    Jul 08 22:01:39 LibreELEC4 systemd[1]: Started Plex Media Server.

    Jul 08 22:02:39 LibreELEC4 sh[3249]: chmod: /storage/.kodi/addons/service.plexmediaserver/lib/Resources/Plex*: No such file or directory

    Jul 08 22:02:40 LibreELEC4 systemd[1]: service.plexmediaserver.service: Main process exited, code=exited, status=134/n/a

    Jul 08 22:02:40 LibreELEC4 systemd[1]: service.plexmediaserver.service: Failed with result 'exit-code'.

    Jul 08 22:02:45 LibreELEC4 systemd[1]: service.plexmediaserver.service: Service RestartSec=5s expired, scheduling restart.

    Jul 08 22:02:45 LibreELEC4 systemd[1]: service.plexmediaserver.service: Scheduled restart job, restart counter is at 8.

    Jul 08 22:02:45 LibreELEC4 systemd[1]: Stopped Plex Media Server.

  • Install tnds82 repository to my libreelec 18.3 with Orange Pi 3 and cant connect to repository. This poject dead?

    Board: Orange PI 3 H6 Quad-core 64-bit 1.8GHZ ARM Cortex-A53

    TV: TELEFUNKEN TF-LED65S75T2SU

  • If you add my repository inside it has the plex media server addon updated for both x86_64 and arm


    Tnds82 - Repository

    First of all thanks for ur release, got it working fine on an odroid C2 running libreelec 9.0.2.

    Will u keep this project updated to latest PMS version? Just 'cause i may consider moving on a different OS to get newer releases.

  • Install tnds82 repository to my libreelec 18.3 with Orange Pi 3 and cant connect to repository. This poject dead?

    I had the same problem. Just check if u correctly wrote the repository address, if so try deleting the repository and adding it as a second istance, since i got it working Yesterday It should work for u too.

  • Rpi4 4Gb , plex media server log :


    terminate called after throwing an instance of 'std::runtime_error'

    what(): locale::facet::_S_create_c_locale name not valid

    Aborted




    please I need help, I think it's a language problem

  • I'm running Plex 1.16.4 no issues. The Plex binaries are self contained and linked libraries are included. Although it's not supported by the Plex team, LE runs it perfectly.

  • I'm running Plex 1.16.4 no issues. The Plex binaries are self contained and linked libraries are included. Although it's not supported by the Plex team, LE runs it perfectly.

    It runs well, until it doesn't. I ran into an issue earlier this week where after I upgraded, the service was crashing upon startup. I went to the Plex Forums for support, and I could not receive assistance because I was not running on one of their support platforms.


    So yes. I had been running PMS on OpenELEC and then LibreELEC just fine for 5 years (perhaps more) without any major issues. But then I encountered an issue that required additional support, and I was unable to get it. Not to mention the ongoing memory leak issues that were introduced into the 1.15.x release and still exists, and the EPG issue that has been introduced into the 1.16.x release. I try to provide troubleshooting information to help diagnose the problems. Once they look at the logs and see the LE directory structure in use, I get the 'Not Supported' line.


    So I was left to perform a fresh install, and within a few hours, i was back up and running, perhaps a little better without the last few years worth of upgrade artifacts.

  • Haven't had a problem running this script which I keep manually updated through a similar method to Plex Media Server on LibreELEC however when upgrading to LibreELEC-RPi2.arm-9.1.002.img.gz I can't seem to get PMS running again. Reinstalling doesn't work either. Downgrading back to 9.0.2 instantly makes it run again. Anyone else?

    Yes. Had the exact same problem. Couldn't figure it out, and the folks over at Plex told me "It's unsupported". Unfortunately, I was left to perform a clean install on 9.1.002. Took all of 30 minutes. Sorry for the bad news. Wish I could have provided a more helpful answer.

  • Yes. Had the exact same problem. Couldn't figure it out, and the folks over at Plex told me "It's unsupported". Unfortunately, I was left to perform a clean install on 9.1.002. Took all of 30 minutes. Sorry for the bad news. Wish I could have provided a more helpful answer.

    Do you mean instead of running the upgrade for LibreElec you ran a clean install of 9.1.002? Or a clean install of PMS after upgrading LE?