[8.95.3 Wetek Core] Missing multichannel audio output

  • As soon as I update my Wetek Core from 8.2.5 to 8.95.3 the available audio devices change:

    Going to settings/system/audio - audio ouput device

    8.2.5 shows ALSA: (Default) AML-M8AUDIO S/PDIF

    8.95.3 shows ALSA: (Default) AMl-M8AUDIO Analog

    As a result there is now way to output 5.1 sound to my Onkyo AVR, which is connected via HDMI cable. Especially passthrough is not working.

    I tested this issue also with a fresh installation of 8.2.5 without any addons or major changes in settings and then update to 8.95.3. It is still the same.

    Attached you can find the logfiles from both libreelec versions.

    Looking at the kodi.log file of 8.95.3 the audio device is specified as: "No passthrough capabilities"

  • It's a known Amlogic issue unfortunately fertigp, and something that won't be fixed until probably 9.2 or 10, so your choices are to stick with 8.2.5 or switch to CoreELEC.

  • One of the first things CE did was drop support for 3.10 kernel devices like the WeTek Core, so that's not a valid recommendation.

  • Thanks a lot for your advice.

    Just for fun, I tested also LE 9 and as expected it shows the same behavior.

    My decision is to switch to a Raspi.

    The Wetek Core has never been a good choice, if you want to run new LE versions very early. :)

  • One of the first things CE did was drop support for 3.10 kernel devices like the WeTek Core, so that's not a valid recommendation.

    CE never did any releases for devices using the 3.10 kernel in the first place to be able to drop them...

    I think you need to get your facts straight rather than spreading misleading fud 👊

  • Bringing this back to life to find out if there are any plans to address this issue in the newer versions ... For all of the WeTek Core users out there, we would all really appreciate the digital audio as otherwise the new 9.x build works flawlessly! Without the audio feature we're stuck on 8.2.5 with no Netflix support :(

  • Yesterday I try to install the last official LibreELEC version on my Wetek Core. All it works... except multichannel audio. In the list of audio device the SPDIF option is still missing. I had only three devices : (Default) AMl-M8AUDIO Analog, AMl-M8AUDIO Analog and Pulse. So the "Pass-through" section in the lower part of the Audio option pane is still empty.

    AFAIK it seems that the issue is still not solved in LibreELEC 9.2.1. I try to install the old 8.2.5.

    I don't know if is related to the audio issue (the Core is connected to a non-HDMI enabled AVR through optical cable), but some movies are not shown correctly (they freeze..), while obviously the ones that are played, send only stereo audio to the AVR....

  • 8.2.5 installed, and the multi-channel audio issue is solved. The SPDIF device audio magically appears, and now I'm able to hear 5.1 audio stream from my AVR.