Status of NanoPC-T4 (RK3399)

  • Hey Mario.D so here is a link where you can download some test content (if needed) Link.


    So i did some tests last night. when i play a 4K movie file, i hit the information widow and see that Kodi is stating that the resolution is [email protected]0Hz. so this means that Kodi is actually downscaling 4K content to 1920x1080p.

    When i go to Settings - Display i can set the GUI limit to "unlimited" and then is still only see the display resolution maxing out 2 1920x1080p.


    So my real question here is where under the bonnet can i set the resolution to more than 1920x1080p?



  • hey JerryPenguin ,


    Can i please ask you to test my problems listed above? what is your device connected to? Directly to 4k tv/display? Do you see 3840 x 2160 pixels in the display options or when playing a 4k file (system info when playing 4k file)?

  • so i just tail the kodi logs and saw this..


    019-03-22 14:00:14.988 T:4070645776 NOTICE: initialize done

    2019-03-22 14:00:14.988 T:4070645776 NOTICE: Running the application...

    2019-03-22 14:00:14.995 T:4070645776 NOTICE: starting zeroconf publishing

    2019-03-22 14:00:14.996 T:4070645776 NOTICE: CWebServer[8080]: Started

    2019-03-22 14:00:14.998 T:3743404912 NOTICE: ES: Starting UDP Event server on port 9777

    2019-03-22 14:00:14.998 T:3743404912 NOTICE: UDP: Listening on port 9777 (ipv6 : true)

    2019-03-22 14:00:16.230 T:3822801776 NOTICE: Register - new cec device registered on cec->Linux: CEC Adapter (0000:0000)

    2019-03-22 14:00:17.419 T:3770676080 NOTICE: CZeroconfAvahi::groupCallback: Service name collision. Renamed to: Kodi (LibreELEC) #2

    2019-03-22 14:01:48.612 T:4070645776 NOTICE: Previous line repeats 3 times.

    2019-03-22 14:01:48.612 T:4070645776 NOTICE: NFS is idle. Closing the remaining connections.

    LibreELEC:~ # tail /storage/.kodi/temp/kodi.log

    2019-03-22 14:44:12.049 T:3913282416 NOTICE: Opening stream: 1 source: 256

    2019-03-22 14:44:12.050 T:3913282416 NOTICE: Finding audio codec for: 86060

    2019-03-22 14:44:12.050 T:3913282416 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder truehd

    2019-03-22 14:44:12.050 T:3913282416 NOTICE: Creating audio thread

    2019-03-22 14:44:12.050 T:3618632560 NOTICE: running thread: CVideoPlayerAudio::Process()

    2019-03-22 14:44:12.051 T:3913282416 NOTICE: Opening stream: 2 source: 256

    2019-03-22 14:44:12.061 T:3618632560 NOTICE: Creating audio stream (codec id: 86060, channels: 8, sample rate: 48000, no pass-through)

    2019-03-22 14:44:12.135 T:4070645776 NOTICE: CVideoLayerBridgeRockchip::Configure - format=842088782 is10bit=true width=3840 height=2160 colorspace=0 color_primaries=9 color_trc=16 color_range=0 eotf=2 blob_id=95

    2019-03-22 14:44:12.203 T:4070645776 NOTICE: Whitelist search for: width: 3840, height: 2160, fps: 23.976, 3D: false

    2019-03-22 14:44:12.203 T:4070645776 NOTICE: Display resolution ADJUST : 1920x1080 @ 60.000000 Hz (18) (wight: 0.000)

  • Do you have any 4k entries in your kodi 'whitelist'??


    Go to settings, display and see if you have any whitelist entries. If not, click on whitelist and activate the 3840 entries and try again. I thought that you did not need these entries to play 4k, but it's worth a go. Just activate all resolutions that you need (usually the 1920x1080 and 3840x2160 ones)

  • Do you have any 4k entries in your kodi 'whitelist'??


    Go to settings, display and see if you have any whitelist entries. If not, click on whitelist and activate the 3840 entries and try again. I thought that you did not need these entries to play 4k, but it's worth a go. Just activate all resolutions that you need (usually the 1920x1080 and 3840x2160 ones)

    No i do not have any 3840 entries in the whitelist.. this is my problem... i think Libreelec is not configured at an OS level to use 3840 res.

  • When I did my tests there was nothing above 1920x1080 to select. So yes this is likely a LibreELEC limitation? It did not exist in Kodi either. Maybe this board is not really 4K although it can play 4K it's not a true 4K?

  • No i do not have any 3840 entries in the whitelist.. this is my problem... i think Libreelec is not configured at an OS level to use 3840 res.

    It is most likely that 4K output is disabled in your dts file for the NanoPC-T4.

    Check vob big little entries and compare with other RK3399 devices.

  • How do you update the existing LibreELEC to the new version without losing everything already installed? I'm still new and want to update but don't want to install everything again.


    Thank you.

  • How do you update the existing LibreELEC to the new version without losing everything already installed? I'm still new and want to update but don't want to install everything again.


    Thank you.

    Copy the TAR file not the IMG.GZ file to the updates folder..


    to access the folder, open up the share - \\xxx.xxx.xxx.xxx\ you should see the "Update" folder there.. just drop the new TAR file in there and reboot the device..

  • How do you update the existing LibreELEC to the new version without losing everything already installed? I'm still new and want to update but don't want to install everything again.


    Thank you.

    Hi, Mario,


    because I only use two plugins I have always reinstalled LE. When installing EMBY for my EMBY server on the NAS and the TVHeadend client I only need the entry of the IP addresses and my login data. The rest of the configuration is on the EMBY and TVHeadend server in my network.


    Sorry that I can't help you here

  • Hello MrTiptop,


    I will try your tip with the update during the next update from balbes150. Thank you very much.


    To your 4K topic:


    1.

    The whitelisting does not allow 4K.

    2.

    In my opinion the problem is the DTB file I use and the link I posted. Under /sys/class/drm/card0/card0-HDMI-A-1/modes the resolutions allowed by the system are shown. There 4K is missing, although the NanoPC-T4 can do 4K.

    Therefore I / we have to wait for a new DTB file.

    3.

    I downloaded the 4K clip you linked and played it locally, you can find the pictures in the attachments.

    I don't need 4K at the moment, because I play my BDs directly on the 4K TV and a BD player.

    The movies I have on my EMBY server are mostly TV recordings via TVHeadend and have a maximum resolution of FullHD.


    Sorry



  • Hello,


    I am now using a new DTB file:


    rk3399-nanopc-t4.dtb.


    I extracted the DTB from the current image and renamed it. Unfortunately this does not solve the 4K problem of MrTiptop yet.


    Thanks to Team Recalbox on GitHub.


    To my problem with the automatic reconnect of WiFi I built with the following script "restartwlan.sh":


    Shell-Script
    1. #!/bin/sh
    2. ip link set dev wlan0 down
    3. ip link set dev wlan0 up
    4. iwconfig wlan0 essid myESSID


    and call it in the autostart.sh with


    Code
    1. nohup restartwlan.sh &



    Now my NanoPC-T4 starts without any problem and connects immediately to my ESSID.

  • Greetings to all,


    I hope you are all enjoying your Nano Pi's. Here is an update on my hardware. Nothing more has changed from my past post except that instead of a 40mm 12v fan, I ordered a 45mm 5v fan. This draws the temps out a tab better. I also ordered 2.6mm aluminum spacers to raise the top to allow the hot air escape. Great little setup! Have a great evening!


  • Well I figure out how to get it installed. It's part of the install of the Netflix. Yeay I have Netflix now working!


    For everyone else, here is my NanoPi M4...

    How did you install InputStream_Adaptive? I'm using the latest Nightly, but whenever I try to install it keeps saying Installation failed instantly. I need InputStream_Adaptive for YouTube for DASH because of a lot of video play in 360p quality and it sucks badly lol


    chewitt   Kwiboo

    Any info on this matter.


    Edit 1: After many reboots and shutdowns, I got it to install, but it's very glitchy. Many video from YT which are 4k/8k with 60fps shows black screen and audio only and then the whole Kodi will glitches out that you have to reboot (or hard reboot) to get it fixed.


    I also noticed the any changes Add-on's Settings won't work until you reboot Kodi.

    Edited 4 times, last by Aciel ().

  • Anyone having Broken Video Orientation problem of videos taken in portrait mode (like from smartphones)? Videos plays 90° CCW, but stretched vertically.