how to compile for wetek ?

  • just wondering if this will be availible and how to if so
    i am going to try out this new LibreELEC on a windows system spec
    but if it does what i want it to i will be looking to also stick it on my wetek
    to will this be possible , also hisilcon chipsets im also interested to se eif these can be compiled
    for to (think i have right chipset)

  • Code
    1. git clone https://github.com/LibreELEC/LibreELEC.tv LibreELEC.tv
    2. cd LibreELEC.tv
    3. PROJECT=WeTek_Play ARCH=arm make image


    ^^ something like that will do it

  • many thanx compiling now ::)
    would this also be the same compile for hi-silicon chips ? (hi3719cv100 )
    for example the type of chips used by mars se HD stb ?


    hit this error though :(




    using ubuntu 12.04 laptop to compile via putty on win7 system



    Many Thanx In Advance

    Edited once, last by H0nch0 ().

  • Code
    1. sudo apt-get install libxml-parser-perl


    ^^ that should get things going. Hi-Silicon stuff is not supported (and not even remotely on anyone's radar).

  • Many thanks again ::)
    ok @ Hi-Silicon knew it was a longshot it would also
    be supported ::) just another quick question when the compile
    if finished do i need to convert image to anything else to be able run it of MsD ? or am i only Nand install ?

  • updated after a few hrs trying to compile i keep getting error 2 ,
    any ideas ? can be at diff times in build sometimes after 5 mins
    furthest i got was a hr odds into the build

  • retried to complie it and heres the log keep getting error2


  • Code
    1. powerpc.o: file not recognized: File truncated


    Not enough disk space maybe?

    Done giving support here because of last events.

  • Code
    1. powerpc.o: file not recognized: File truncated


    Not enough disk space maybe?


    nah cant be that i check disk anilizer and 158gig total with 29gig used , kinda perplexed i am :)

  • so update 4 hrs later in this error2 again code below


  • anyone ? got any idea's ?
    dont wanna have to install linux onto a backup pc
    to see if its a hardware fail on laptop i use ubuntu on :(
    sorry to be a pain in ass i just wanna build a wetek system to be able to
    share in contrabut to the growth of libre and join the band :)


  • I just cloned LibreELEC on to my Linux Mint PC. And I just input the wetek make command. I'll let you know how it all goes after i get back home tonight. Compiling on my Hp Amd Laptop running Linux Mint 17.3 will take a few hours. So far I've compiled a few builds on it. Just recently an OpenELEC update tar for the Amlogic MX2 G-Box with Kodi 16 Jarvis, and a couple of OpenELEC Generic Builds...


    Sent from my SM-G900T using Tapatalk

    Edited once, last by Nemsis72 ().

  • thanx , i think my ubuntu system needs checked for failing HDD
    furthest i could get in compile was 4 in half hours then it would error2

  • UPDATE :



    so ive installed to Msd to play with :) Many thnx again Nemsis72  
    Tvhead works ok still to test VDR yet , so i notice that libreelec has the same issue on wetek
    as Openeelc does on latest with saving the Custom GUI screens you want to use instead of
    factory ones IE pictures for sections yeah , does anyone know if and when a update or a work around
    for this is it just the location the files are stored ? ie if i was to replace certian from within teh skin itself
    or save them into storage/.kodi/blah blah instead of just storage/blah blah ?


    apart from the screen saves it seems to run ok no lagging or reboot loops ect ect
    did not like my backup from O/E 6.0.3 offical gave some mad transparancey issues
    for most of teh screen ie could not see the stop or fast forward overlays when hit ok during live tv or video plugins
    but it did how every keep the custom screens , strange though as if you build from scratch they dont save after reboot
    but with the O/E backup installed they did but like i say the transparent issue made it unworkable anyways , just found it strange
    that with backup installed they would show after rebooting but not from scratch :)

  • H0nch0


    May I suggest to update your system to at least 14.4. I've seen similar issues with a guy trying to compile OE one month back with Ubuntu 12.4


  • H0nch0


    May I suggest to update your system to at least 14.4. I've seen similar issues with a guy trying to compile OE one month back with Ubuntu 12.4


    thanx for info i will try update before i reinstall a new system on new HDD

  • thanx for info i will try update before i reinstall a new system on new HDD



    Make sure you have the proper tools installed on your Linux PC..


    Follow instructions on this image along with:


    sudo apt-get install build-essential


    sudo apt-get install git






    Sent from my SM-G900T using Tapatalk