Wetek Play 1: After upgrade to Alpha 006 (from LE 8) no upgrade/downgrade possible

  • Hi,


    some weeks ago I upgraded my Wetek Play 1 from LE 8 to v8.90.006 ALPHA. Due to some bugs I tried to switch back to LE 8 but this failed for some reason I did not see. (I am using the analogue output of the Wetek on an old CRT TV. During the update step the Wetek does not supply a proper signal on the analogue output. The TV just shows garbage.)


    Two day ago I tried to upgrade to the latest alpha (8.90.008) and realized that this also did not work. I then connected a LCD and saw that the upgrade script (packages/sysutils/busybox/scripts/init I assume) failed with "Missing (target) kernel.img or SYSTEM!". That made sense, because there was no kernel.img in /flash. There was just a /flash/KERNEL (and as far as I can remember has always been). I then created an empty /flash/kernel.img file and the upgrade finally succeed (but the upgrader copied the new kernel into /flash/kernel.img).


    I looked into projects/WeTek_Play/options and saw that KERNEL_NAME="kernel.img" is set there. Is this a mistake?

  • KERNEL.bak is the renamed KERNEL file from Alpha 006 and KERNEL the renamed kernel.img from Alpha 008. (I renamed the KERNEL files.)

    Edited once, last by benni0815 ().

  • Yes this is an old install which initially shipped with some OpenELEC version which I updated from release to release.


    I could remove KERNEL.bak but this should not change anything I guess? Removing the KERNEL file would result in an unbootable system, wouldn't it?


    But I tried something else with the new alpha 009 (LibreELEC-WeTek_Play.arm-8.90.009.tar).

    First I just copied it into /storage/.update without changing anything else. Which again brought the "Missing (target) kernel.img or SYSTEM!" error as before:


    But I found out that after mounting the /flash partition the init script tries to execute /flash/post-flash.sh if it exists.

    So I created a script with that name and the following content:

    Bash
    #!/bin/sh
    
    export IMAGE_KERNEL="KERNEL"

    The next update attempt then worked!


    So again my question: Do you accidentially set the wrong kernel file for Wetek Play 1 in projects/WeTek_Play/options?

    Line 138 (as of 6db1ac5f83):

    Code
    KERNEL_NAME="kernel.img"
  • Btw: This is how my /flash directory looks like after the update:

    So the kernel was also updated correctly.

  • i dont know if i am here on the right place, but i thnk i have the same problem.

    I used my Wetek play 1 (openelec box) for a long time now for netflix with Coreelec (compiled trunk) + Libreelec. Only the initial/first flash coming from LE8 to LE9 is working.

    Any upgrade within LE9 versions is only possible if you do it manually. The message is always "system or kernel" not found - as far as i remember

    a.)

    LibreELEC-WeTek_Play.arm-8.90.009.img.gz into .update will lead to:

    Missing (target) kernel.img or SYSTEM!

    b.)

    LibreELEC-WeTek_Play.arm-8.90.009.tar into .update will lead to:

    Missing (target) kernel.img or SYSTEM!


    My manual upgrade steps are like following:

    1.) cp system + kernel to rw mounted /flash

    => no space left message

    2.) reboot and in minimal linux which is starting

    cp system + kernel again from USB stsick to rw mounted /flash

    => after a reboot everything is now working


    Code
    mount -o remount,rw /flash
    cp KERNEL /flash/KERNEL
    cp SYSTEM /flash/KERNEL


    I have also reinstalled my Wetek Play1 with the latest LibreELEC-WeTek_Play.arm-8.2.5.zip, but the size of /flash will remain.

    Is there any possibility to resize nand flash to a bigger size?

    my size is also like this:

    Code
    Filesystem                Size      Used Available Use% Mounted on
    devtmpfs                426.0M         0    426.0M   0% /dev
    /dev/ubi0_0             200.5M    117.2M     78.6M  60% /flash
    /dev/loop0              116.5M    116.5M         0 100% /
    ....

    many thanks for your help - if possible :)

    Later on i will try it with bennis workaround


    ##### Edit

    benni0815

    your Workaround is fully working and it seems that you are right

    i have created now like you described this post-flash.sh file and then the upgrade went fine with the tar file.


    Edited 2 times, last by twerty ().

  • twerty: Good to hear that I'm not the only one with that problem and that my workaround also works for you.


    CvH: Yes, I can try. Should I do that with or without the /flash/post-flash.sh script in place?

  • I can confirm the issue identified by benni0815.


    I updated a WeTek Play 1 to 8.95.001. After that, I was not able to downgrade again to 8.2.5, with the same "Missing (target) kernel.img or SYSTEM!" error reported as documented by benni0815.


    After applying benni0815's workaround, I was able to downgrade again without any problems.

  • Issue still persists when trying to update from 8.95.001 to 8.95.002.


    However, once more, with benni0815's workaround, I'm able to update.


    I apologize. My bad! First think, then think again, and then post (maybe):


    I want to report, that *after* flashing 8.95.002, this issue seems to be gone. Once I flashed 8.95.002, I can e.g. downgrade and upgrade again without any issues.

    Edited once, last by Sepp ().

  • Hi. But I hawe same problem. I can't upgrade from LibreELEC 8.95.001 (WeTek_Play.arm) to 8.99.001. I trying form librelec menue and I put tar file in .upgrade folder after restart something is installed but still is 8.95.001 wersion.