Intel true 10bits/HEVC/HDR support... ?

  • I haven't noticed any color inaccuracies as described by smp

    Try this test.

    All bars (66-120) should look grey. But when using the EGL render method - bars 68-88 look green.

    They look correct with direct to plane method (github.com/lrusak/xbmc/commits/drmprime-vaapi-hdr branch).

  • localdemoda

    LibreELEC-Generic.x86_64-10.0-devel-20210427181309-090e00d.img.gz


    On my AMD Athlon 200GE (Vega 3) HDR does not work. - just a black screen.

    Hello, there is something that I do not understand and that is that in my ryzen 5 3550h vega 8 and the beta2 version of LE if HDR works perfectly for me, the only thing is that the hdr icon does not appear on the samsung tv.


    And I don't understand why in the version you gave me the image looks black.

  • Hello, there is something that I do not understand and that is that in my ryzen 5 3550h vega 8 and the beta2 version of LE if HDR works perfectly for me, the only thing is that the hdr icon does not appear on the samsung tv.


    And I don't understand why in the version you gave me the image looks black.

    There is no HDR support in the official beta

  • And I don't understand why in the version you gave me the image looks black.

    It's a work in progress code that is known to work on some Intel hardware. It does not seem to work on AMD yet.

  • It's a work in progress code that is known to work on some Intel hardware. It does not seem to work on AMD yet.

    I haven't tested it in a while but my branch did work fine on my Vega M.

  • thanks to both of you.


    Can you put the links to the branches that are there to be testing in my AMD please?


    Sorry for my English, I'm Spanish and I use google translator.

  • Try this test.

    All bars (66-120) should look grey. But when using the EGL render method - bars 68-88 look green.

    They look correct with direct to plane method (github.com/lrusak/xbmc/commits/drmprime-vaapi-hdr branch).

    I haven't been able to notice the green on my TV (Sony AH8). Although I can't get the tv to pickup full range. Kodi is set to full but the tv is picking up the signal as limited. If I force full on the TV if washes out the picture. Are you still forcing full range in your builds ?

  • Are you still forcing full range in your builds ?

    Yes. I also tested with limited range and it doesn't make any difference.

    That's how it looks with a build from drmprime-2img-no-ffmpeg-bump branch (EGL render method):

    EGL.jpg


    That's how it looks with a build from an older drmprime-vaapi-hdr branch (direct to plane render method)"

    DTP.jpg

  • I don't force full range for the builds I post here.


    Yes - I think limited range is what the bulk of people will want to use - particularly those who use AVRs with other sources (most of which will be limited range - which is also what almost all content is mastered in)

  • Finally got around to grabbing my dad's NUC8i3 .. the latest build on here seems to be working flawlessly. I got HDR10 to work and also passthrough audio seems to be perfect so far too. WOOHOO!!!


    EDIT: Watching 3rd movie on the build, audio has been perfect.

    What are the limitations again on this .. subs don't work and 4kHDR @ 60fps don't work .. correct?

    Edited once, last by pletopia ().