LibreELEC 9.0 - video signal problem through AV receiver (UPDATE)

  • Hi, I'm testing Alpha 8.90.005 on my Wetek Play2, running LibreELEC on a microSD card.

    The player is connected through HDMI cable to my Marantz NR 1607 AV receiver (then another HDMI cable connect the AV to my Sony smart TV). This setup works perfectly with LibreELEC 8.2.5 based on Kodi 17 Krypton.

    With this version, instead, after some seconds the video signal is turned off (black screen on TV). If I turn off the receiver (using it only as passthrough), the video turns on . Sometimes happens vice-versa. The video signal goes down, and when I turn on the receiver, goes up. It seems to be something relating to HDMI handshaking.


    Attached to the receiver I have also a UltraHD player and other two devices, but no problems with them (and no problems with previous stable LibreELEC versions....)

  • I'm seeing this too, RPi 3b, Denon AVR-X2000 .. i downgraded to 8.2.5, but the problem persists..

  • I replace the microSD with Alpha 8.90.005 with the old one with 8.2.5 and all now it works (same player, same HDMI cable, same AVR, same TV)

    Hope it'd be only a temporary problem...

    Tonight I'll try to create a LOG with DebugLog if it could help...

  • Here's my log.

    I worked some minutes without problems, but at a given point the system lose the video connection throug HDMI (LibreELEC->AVR->TV), The UI appears for some seconds, then black screen, then appears...and so on....

    Switching back to the old 8.2.5 version (made already yesterday but only to be sure about that...) , it works perfectly without this problem


    hastebin


    Hope it helps!

    Andrea

  • I had (have) this issue also with the Play 2, the video was set to 4k/60Hz, when I set it to 4k/30HZ the video problem went away.

  • Soapy Smith , when you say "video was set to..", you refer to the LibreELEC UI resolution (Settings->System->Display->Resolution) ? Is it a behaviour experimented only with this Alpha or also with the official past versions?

  • Soapy Smith , when you say "video was set to..", you refer to the LibreELEC UI resolution (Settings->System->Display->Resolution) ? Is it a behaviour experimented only with this Alpha or also with the official past versions?

    Yes, the LibreElec UI resolution/freq was changed to 4k/30Hz and the video signal quit cutting out after that.


    This behavior started with the Alpha, the previous 8.x version ran fine at 4k/60Hz

  • OK, I've made some tests during the weekend, setting UI resolution to 4K/30HZ as suggested. I used the system for more or less half an hour (playing a movie stored on my NAS), but at the end the video signal starts to cut every 15-20 secs (the "black screen" period is around 3-4 seconds...).

    I tested also the system with the last CoreELEC Alpha release (based on Leia Beta2), but after one hour I've got the same results. Switching back to official LibreELEC 8.2.5 no more video signal cutting at all....


    What can i do? I already upload my log (see above).

    Klojum : should I post it on the Kodi Forum ? In which section? Let me know if it makes sense...

    Many thanks

    Andrea

  • I found out that when it starts happening I can fix it if I - switch to a different input on my TV and then switch back. After I switch back everything is OK until the next time.

  • I had the same experience. For example turning on ( or off) the AV receiver, allows the video signal to come up... until the next “black screen”. The AV is obviously set with pass-through on, allowing to pass the video signal also when off. The same seitching to another source ( TV directly or my UHD player) and then switch back to the lLibreEkwc pkayer..

  • mancio61

    Changed the title of the thread from “LibreELEC Leia Alpha 8.90.005 - video signal problem through AV receiver (HDMI )” to “LibreELEC Leia Alpha 8.90.009 - video signal problem through AV receiver (UPDATE)”.
  • Hi guys,

    Yesterday I've made some tests updating my sdCard from Alpha 8.90.005 to Alpha 8.90.009.

    The system is correctly updated in few minutes, the library too (all the movies in the library are catched by Universal Movie Scraper).

    All seems to work well : UI is very fluid , HDMI-CEC working, playback with no video or audio issues (test also some 4K video with DTS-MA audio track).

    The problem is that after few minutes, the "black screen" issue appears! In concrete the video signal is lost, on the TV screen appears the message "no signal from this source". Moving to the digital TV channels (or to another AV source) and then switching back to the player, the UI appears... to disappear after some minutes. It seems to be something related to HDMI handshaking (I'm not sure about that...).

    The player is the Wetek Play2, connected with high quality HDMI cable to a Marantz NR 1608 receiver, and then to a Sony 4K XD8009 TV.

    Obviously the old LibreELEC 8.2.5 version based on Krypton 17 works well, using the same hw setup....


    It's also difficult to create a log file, because once the UI disappears, is not possible to upload the file o take note of its id ....any suggestion about how to proceed to supply more technical information about?


    thanks!!!

    Andrea

  • Hi guys, I made a system update to the official LE 9.0 (skipping all the intermediate Alpha and Beta versions, hoping the problem had been fixed..). Today, after few minutes of movie playing... "no signal" message arises another time....

    Very frustrated, because in these last weeks, as before, I had no issue of this kind using the official LE 8.2.5


    My setup is:

    • TV : Sony 43XD8099 4K
    • Media Player: Wetek Play2
    • AVR: Marantz NR1607


    CEC-HDMI enabled

    Connections using HDMI cables, adopting standard connection schema : Media Player -> AVR -> TV


    Anybody have the same issue?

    Thanks!

    Andrea

  • I am having similar issues with my setup. Works great on Libreelec version 8.2.5 but any of the 9.0x builds i have issues with video. My issue is the screen over scans, i adjust the using the kodi video calibration tool but the settings don't stay. I was able to get the settings to stay if i reboot after the TV and AVR are powered on. I typically leave the laptop on all the time but power off the AVR and TV, every time i turn the avr and tv back on i have to calibrate the video. Like i said seems to be working great in the older builds. So for now i'm going to keep using 8.2.5


    My Setup is:

    TV:Samsung LCD 46"

    MediaPlayer = inspirion 15 Laptop loaded with genericx64 LibreElec

    AVR Yamaha rx-v571