Early community images for H3, H6 and A64

  • I can upload new updates today, but except Kodi update, 4K H264 decoding and maybe HDMI CEC fix, nothing else would be new. I'm still struggling with some problematic H264 and HEVC videos.


    If you think that's ok, then I can do it.

    For me that would be helpful. So far I didn't run into troubles with any movies.

  • New update files are uploaded for A64 and H3, along with updated addon repository (needed due to Kodi bump).


    What's new:

    - Kodi 18.1

    - Linux 5.0-rc8

    - 4K H264 decoding supported

    - fixed 4K downscaling (watching 4K videos on 1080p screen)

    - minor decoding speed improvements

    - H264 memory optimizations (*might* help for OPi Lite & One, but I'm not sure)

    - HDMI CEC fix


    Known issues:

    - some H264 and HEVC videos are still not correctly decoded, investigation is ongoing.

    - Kodi screen calibration is not stored (fix in Kodi 18.2)

  • jernej

    I'm trying an A20 olimex-lime2 image build from your repo, but if I do

    Code
    1. PROJECT=Allwinner DEVICE=A20 UBOOT_SYSTEM="olimex_lime2" ARCH=arm make image

    then u-boot fails to compile with


    it's going on using the u-boot CONFIG_SYS_LONGHELP=y


    if I don't pass the BOOT_SYSTEM="olimex_lime2" then the image is empty


    in script/uboot_helper to Allwinner I added the entry


    Code
    1. 'A20' : {
    2. 'olimex_lime2' : { 'dtb' : 'sun7i-a20-olinuxino-lime2.dtb', 'config' : 'A20-OLinuXino-Lime2_defconfig' },
    3. 'olimex_lime2_emmc' : { 'dtb' : 'sun7i-a20-olinuxino-lime2-emmc.dtb', 'config' : 'A20-OLinuXino-Lime2-eMMC_defconfig' },
    4. },



    the other options where taken from H3 board example and the kernel config was completed with a tested working config, beside other kernel patches do I miss something ? I don't see other patches for A20 missing on u-boot, as the board is fully supported


    Thanks

  • I am this (my finger and my thumb are practically touching) close to punching my Beelink X2 into oblivion. I used The LibreELEC USB-SD Creator and used some micro SD cards I already had, but my beelink just refused to go beyond the red light and wake up with an SD card inside it. I did see one glimpse of LibreElec on my tv before the Beelink shut off and DIDN'T didn't wake up again until I removed the SD card.


    So I went and bought a new SD card, 16GB Class 10. I put the image on with The LibreELEC USB-SD Creator again. But again, nothing happens. The Beelink just refuses to start up with the SD card inserted. Does it matter what system is on the Beelink before it boots from the SD?


    Is there any other way to get it working? Can I just jam the system onto the Beelink with brute force? Because if this doesn't work soon I'm still determined to use brute force but in a different manner.


    Good news for someone who is smarter than me is: if you can't help me to get it working, I'll give it to you. So...wait then you have incentive to NOT help me. But still, any help appreciated.


    Dearest regards,


    Hallur Örn

  • lucize I don't own any A20 board so I can't help you much with U-Boot issues. Maybe removing projects/Allwinner/patches/u-boot folder will help?


    Even if you manage to build image, video playback won't work unless you disable HW acceleration. For HW acceleration you would need at least 5.1 kernel (RC version will be available in two weeks) and additional ffmpeg patches, which are currently in the work.


    ruslakall Can you connect serial console to it? Serial output would be very useful in diagnosing the issue. What is your TV native resolution? Can you connect it to any other display? 1080p computer monitor would be best.

  • removing projects/Allwinner/patches/u-boot folder will help?

    a20 lime has by default DFU enabled and it depends on USB that was disabled by 002-disable-usb.patch


    I know it will not work by default but we have start from somewhere


    Regards

  • a20 lime has by default DFU enabled and it depends on USB that was disabled by 002-disable-usb.patch

    I need to rethink that part. Probably only USB keyboards should be disabled.

  • Is this something that may be looked at later for main stream LE ?

    Just now I'm uploading first preview version for PineH64, which has H6, same as OrangePi 3. Hopefully I'll get board sample and then I can prepare an image for it. At this point it's just a matter of DT file.

  • I don't know what a serial console is. That is way above my "paygrade." And to think I was proud of making an AppleScript back in the day that posed an asinine question and restarted your computer no matter what you answered.


    The TV's native resolution is 720p, it's a cheap TV in the guest room where I was going to use the Beelink X2. (I've got two glorious Nvidia Shields in the living room and bedroom.) Could it be outputting something in the wrong resolution without changing the front color from the red? I'll hook it up to my monitor tomorrow.


    Thank you again for a hasty response.

  • I don't know what a serial console is. That is way above my "paygrade." And to think I was proud of making an AppleScript back in the day that posed an asinine question and restarted your computer no matter what you answered.


    The TV's native resolution is 720p, it's a cheap TV in the guest room where I was going to use the Beelink X2. (I've got two glorious Nvidia Shields in the living room and bedroom.) Could it be outputting something in the wrong resolution without changing the front color from the red? I'll hook it up to my monitor tomorrow.


    Thank you again for a hasty response.

    My x2 is at my parents place, else I would have tried it on my worst monitor. On my old samsung 1080 TV from around 2012 it's working like a charm, same on parents crappy Philips Android TV, also 1080 resolution.

  • Anybody tried the last versions on an OrangePI One?

    It seems to be very unstable, properly related to the low memory of 512mb?

  • jernej

    docker working on this image?
    I have some error:

  • docker working on this image?

    Which image exactly? I rebuild all addons to be compatible with latest update (few days back).


    Besides, I didn't test any addon and I don't use docker at all (on LibreELEC or PC) so I can't really help you with that.