LibreELEC 8.x images for additional dvb drivers


  • usb 2-1: dvb_usb_v2: found a 'DVBSky S960/S860' in warm state
    kernel thinks card is here and everything is okay


    start LE, disable tvheadend, wait some sec, activate tvheadend - card should be there i think ?!
    if so activate wait for dvb card in the tvh addon settings


    i have 2 dvb usb
    1- Bus 001 Device 003: ID 13d0:2282 Techsan Electronics Co., Ltd. TechniSat DVB-PC TV Star 2 = not working
    2- Bus 002 Device 002: ID 0572:6831 Conexant Systems (Rockwell), Inc. DVBSky S960 DVB-S2 tuner = working


    so i need help for TechniSat DVB-PC card


  • Is it possible to install latest unestable version of tvheadend? Just to know if I have to wait for a new build also if I want to update tvheadend


    build.mycvh.de - last tvh versions have some problem with sat>ip server (instant crash)


    so i need help for TechniSat DVB-PC card


    I will check

  • updated to 1.63


    updates:
    - ljalves-cc to latest
    - tbs-oss to latest
    - dddvb changed to crazycat fork <- setting has to be reset in tha addon for this (no idea if this works well or not - feedback welcome)

  • Thanks for the update, I'll test it when I get home. Just a short question, that bothers me somehow. What#s the best way to get e.g. a Gameboy- or SNES-Emulator up and running with your special builds?


  • Tried crazycat drivers and they work excellent!


    The only issue is that if you use kodi GUI (change between menus or something like that when having a tv channel tunned) it get a little stucked, tv fps reduce and kodi gui moves really slow, my raspberry shows an average of 15% of cpu use for 4 cores and also a 15% of ram used, could be something wrong?

  • Hi, newbie here so please forgive if I ask a stupid question!


    I originally installed the latest krypton build and discovered my tuner was not recognised. Having installed version 1.63 here of the Jarvis version and selecting the official TBS driver everything is working great...I would now like to switch back to Krypton though, is this possible or would the driver for my tuner be wiped out on upgrading?


    Thanks for this build by the way :)


  • [...]
    The only issue is that if you use kodi GUI (change between menus or something like that when having a tv channel tunned) it get a little stucked, tv fps reduce and kodi gui moves really slow, my raspberry shows an average of 15% of cpu use for 4 cores and also a 15% of ram used, could be something wrong?


    Hello,


    as far as i know on the pi there is an fps-lock for gui rendering while playback.
    i am experiencing the same with my pi 2, but on my HTPC (Haswell based) anything is smooth.


    @topic: first, thank you for your work.
    Digital Devices Cine C/T v6 is working with your build, but on some channels i got playback problems.
    i already know that the cable connection is not the best here, mybe the crazycat drivers are not yet handling "bad signal situations" as good as the dd-drivers?
    we will check the connection with special equipment and maybe i will blame my provider.


  • Good point, could it be possible to release that fps lock?


  • Digital Devices Cine C/T v6 is working with your build, but on some channels i got playback problems.
    i already know that the cable connection is not the best here, mybe the crazycat drivers are not yet handling "bad signal situations" as good as the dd-drivers?
    we will check the connection with special equipment and maybe i will blame my provider.


    In my dddvb repo changes only for satellite demod drivers stv090x, stv0910, mxl5xx. No any changes for ter/cable DD devices.

  • hi guys. i am new here. i am building the unofficial build for my wetek core right now. i hope it will work thanks for that. i hope it will finally work and i can run tvheadend on the core


    just a question (maybe its been asked already but 18 pages were too much): is it possible to add the drivers through an addon? i am just curios because on new libreelec release i need to build a new image with the drivers?


    edit:


    like in expected. my build failed with the following error:
    [code=php]
    In file included from include/linux/scatterlist.h:10:0, from include/linux/dma-mapping.h:9, from /home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/tbs-oss-2016-07-27/media_build/v4l/compat.h:1339, from <command-line>:0:/home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/linux-amlogic-3.10-c8d5b2f/arch/arm/include/asm/io.h:297:0: note: this is the location of the previous definition #define writel_relaxed(v,c) __raw_writel((__force u32) cpu_to_le32(v),c) ^Makefile:1238: recipe for target '_module_/home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/tbs-oss-2016-07-27/media_build/v4l' failedmake[3]: *** [_module_/home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/tbs-oss-2016-07-27/media_build/v4l] Error 2make[3]: Leaving directory '/home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/linux-amlogic-3.10-c8d5b2f'Makefile:51: recipe for target 'default' failedmake[2]: *** [default] Error 2make[2]: Leaving directory '/home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/tbs-oss-2016-07-27/media_build/v4l'Makefile:26: recipe for target 'all' failedmake[1]: *** [all] Error 2make[1]: Leaving directory '/home/chris/LibreELEC.tv/build.LibreELEC-WeTek_Core.arm-7.0.2-dvbdrivers/tbs-oss-2016-07-27/media_build'Makefile:12: recipe for target 'image' failedmake: *** [image] Error 2
    [/php]


    any ideas whats this?! :(

    Edited once, last by keKs ().


  • Just checked:
    Settings -> Video -> Accerleration -> Limit GUI Updates during Playback


    Excelent!! It works great now!!


    Now it just reduces a pair of fps of playback when using the GUI, but GUI itself runs smooth, it should be a RPI limitation