[Solved] WIFI "invalid argument"

  • Good morning

    I installed LibreELEC (Leia) v8.90.003 ALPHA on my raspberry pi 3 B I have the problem of the wifi connection "invalid argument" when I enter the password formed by 31 numbers and capital letters. the same problem I had with v8.25. I read various discusions but I did not solve it.

    I tried the raspberry with other firmware and it works fine.


    Many thanks


  • Code
    connmanctl
    agent on
    scan wifi
    services
    connect wpa_blahblahblah_psk

    connect via ethernet and SSH into the device, then enter the user/pass when prompted


    if this works, it's something in our settings addon that's not correctly trapping a response from dbus


    if it doesn't work, it's something else .. and I have no idea :)

  • Can you try with a shorter password < 10 and see if that works.

    Quote


    I tried the raspberry with other firmware and it works fine.

    Which firmware was this?


    If I remember I'll have a look tomorrow on my RPi3. BTW is it a RPi3B or the newer RPi3B+?

  • The problem found on this version and the previous version is that libreelec menu is not able to connect to the wifi network "Invalid argument", I made several attempts, I managed to connect to the wifi network only via ssh with the commands provided kindly to chewitt.

    In my opinion it could be the maximum accepted length of the wifi password on the libreelec menu.

  • AFAIK the limits on SSID and passphrase length are 63 characters. Are you using the native/onboard wifi or an external USB device? .. if external, what device?

  • password section does not even load for me goes straight for "invalid argument"



    when can you add the option to exit kodi so we can do ssh when network is not working ...

    spent a month to get wifi device running because wired LAN was not working now I hit this password issue

  • There are no plans to unhide "exit Kodi" in the GUI because LE is not a "Desktop" OS and exiting Kodi doesn't drop you back to a working desktop or console prompt (which is what I guess you're looking for). If Ethernet works you can SSH in and run connmanctl (as above).

  • Sorry to bother you with the same problem.


    I tried to connect LibreElec V8.90.006 Alpa (installed at RasPi 3B+) via WiFi (FB7490) and I receive the same error message "invalid arguments".


    Using an ethernet cable, connection via SSH works fine; I even can re-connect to the same SSID. But error message "invalid arguments" appear again if I want to connect to a different SSID.


    Any clue how I can connect the RasPi via WiFi without need of ethernet connection and SSH?

  • I think this thread should be marked "unresolved."

    I am still having this issue, as are others -or so it would seem.


    I am running the most recent version of LibreElec on Raspberry Pi 3.

    My wifi connection was working properly. Two days I logged on and libreelec could not connect to my wifi network.

    The kodi/settings/libreelec/connections section shows "failure" for my default wifi connection.


    When I try to manually reconnect I get the "network error / invalid arguments" popup immediately.

    This is likely not a "password character length" issue as some have suggested. In fact, I get the error and never even get to the password entry field.


    So, thinking it might be a config file or a cached file settings issue I created a new wifi name & password on my router and tried to connect to it. Again I get the immediate "network error / invalid arguments" popup without ever getting the chance to enter a password.


    Net, I created an unsecured connection on my router and was able to connect to it through kodi/settings/libreelec/connections.

    So... that was good, except that I didn't want to leave an unsecured connection open.


    So I rebooted my raspberry pi device and immediately I had no connection on boot up and the same network error / invalid arguments popup.


    since I can't get to a command prompt except through ssh, I don't know how to give more specific debug info, but will be happy to if directed.


    Someone on another thread suggested a dbus issue?

  • After a quick search on google, this was the first link google presented. Hope I'm not punished too harshly for the mild necropost. [Scroll to bottom for solution]


    So the resolution for me, was much simpler and was sourced by my inherent laziness. It didn't require me getting out of bed to connect to a wired connection to run commands from SSH or changing my WiFi password to something less than 10 chars even though I was completely willing to do both. [See aforementioned laziness]


    All I needed was the TV's remote.


    So confirm that the issue described in this thread matches your issue. I rebooted multiple times. Tried to connect to each of the 3 WiFi networks I set up on my router. I couldn't even get to the password prompt for the networks. All efforts generated the 'network error / invalid arguments' prompt almost immediately.


    So, I decided I was going to try to disable the LibreElec add-on. Of course, that can't be done since LibreElec is hard-wired to 'enabled' with no option to disable. But the thinking was sound. Instead, I disabled both the wired AND wireless network interfaces. There is no visual feedback to confirm your settings were saved but as best as I could tell they were, so I immediately exited LibreElec add-on and rebooted Kodi. I also have shortcuts setup in my Kodi build for 'Shutdown' and 'Reboot'. I mention this because I think its important to not lose the changes to the settings you've just made. Simply removing power from your Kodi device by power-cycling your TV, if your TV is your Kodi device's power source, should probably be avoided. When Kodi was back up, I re-enabled the wireless network interface, I attempted to connect to my wireless network and was prompted for a password. Once I got the password sorted, I was connected. Even after a reboot. I suspect the Wifi password that LibreElec stores for wifi networks, somehow got corrupted. But there doesn't appear to be a mechanism for LibreElec to communicate this to you and offer you a chance to change/re-enter the correct password. Anyhow, I hope this is helpful.


    Solution: Disable Wired & Wireless network interfaces in LibreElec addon. Reboot kodi device [not just restart Kodi]. Once Kodi is back up, re-enable wireless Interface in LibreElec. Connect to disired Wifi Network. Enter 'correct' password for given network. Profit.

  • Im getting this error too with a RPi B+ looking at other threads it seems this bug has been around for a while and it's quite a major one. I'm discovering so many bugs in the LE settings add-on 😑

  • UPDATE:

    So I've discovered there is an addon causing this behaviour for me:

    service.bluetooth-audio

    disabling this works. Re-enabling also works until I reboot then the issue is present again.


    I've tried enabling debug logging but I can only see this of any relevance:

    Code
    T:1481663344 ERROR: ## LibreELEC Addon ## connman::dbus_error_handler ## ERROR: (Invalid arguments)
    T:1481663344 ERROR: None