LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ]

  • You don’t want to back up your statements that’s fine, I didn’t expect anything else. Go ahead and download my build if you want to know how I deal with things. Taking my users for fools, wow.... well they can laugh all the way to my download area and enjoy today.

  • You don’t want to back up your statements that’s fine, I didn’t expect anything else. Go ahead and download my build if you want to know how I deal with things. Taking my users for fools, wow.... well they can laugh all the way to my download area and enjoy today.

    Well I've read your post that basically proves everything I stated RetroELEC (Generic/RPi/XU4) Emulationstation/RetroArch/Kodi


    "There seems to be great concern about PCSX2, well I actually am the one who brought PCSX2 to LibreELEC for the first time, and my docker container is in fact used (or copied) to other projects offering it as well. PCSX2 runs fine in Xwayland which can easily be added (I'll probably add options for it so people can build themselves). Doesn't really add that much to the image, and you don't need to run a full X server, so it's still a win. Oh, and beetle-psx actually have a Vulkan backend, so that only leaves Flycast which benefits from OpenGL for it's "OIT" engine, which isn't all that. It's an OK compromise for now. NVIDIA can support Wayland through EGLStreams, although I don't have such hardware for testing and frankly it's not the best pick for open source gaming these days."

    - you need XWayland on top as I said - doesn't matter if it "Doesn't really add that much to the image"

    - you can't run beetle-psx with OpenGL anymore as I said - and not all GPUs support Vulkan
    - Flycast will lose OIT - "Flycast which benefits from OpenGL for it's "OIT" engine, which isn't all that" well I've posted a link and the benefits are huge

    - afaik it's not Wayland but the compositor & I already posted a patch set for Weston which wasn't merged to master probably for reasons
    - "The wayland build is Intel only for now." well ehrm :/:angel::rolleyes:/shrug


    So basically you have proven all my points and avoided to mentions others. So personally I don't care if some users laughes on the way to your download area because it's probably Intel only. /shrug

    Well in the end you've got your attention... and I guess this makes you happy now. :S:thumbup:

  • Yes. It does launch from the default skin., However I have had it setup like this in the past.. probably the initial build.. and worked through updating as well..




    http://ix.io/1xux


    http://ix.io/1xua

  • - So users absolutely wanting PCSX2 and Flycast OIT can run Xwayland, so what?

    - Have you even tried the GL backend of beetle-psx? It's absolute crap, and any CPU from the last 15 years will handle PSX in software, which is the best choice these days. I have Vulkan support, but still use software for PSX.

    - Don't know why you're going on about Weston, I use Sway/wlroots as mentioned. This will be ported to the XU4 as well, as soon as Panfrost is ready.

    - AMD support is simply a matter of compiling it in. Coming later.


    No idea what "points" you are trying to prove, I'm here because you stated that I don't care about the average LE user and posted misinformation about Wayland. Craving attention my ass... I'm not the one with a "Reborn Remix" build trying to be me, and actively trying to misguide users. Stay in your lane son and you won't be embarrased again.


    Oh well, off to do some actual gaming. On Wayland of course, I'll post some videos for you later so you can see how it looks.

  • - XWayland is quite lean isn't it Arch Linux - xorg-server-xwayland 1.20.5-2 (x86_64) ? Oh wait basically the dependencies look like Arch Linux - xorg-server 1.20.5-2 (x86_64)

    - I hardly doubt that but how should you know... :/ Dynamic recompiler [$895] [BOUNTY] · Issue #214 · libretro/beetle-psx-libretro · GitHub

    - I'm aware of that because you used i3 for tests and moved to Sway/wlroots probably for setting modes - well magic! But maybe I point to Weston because there is a EGLStreams patchset /shrug while for Sway well... Why/when is/will the nvidia proprietary driver not/be supported? · Issue #490 · swaywm/sway · GitHub

    - it's not about AMD which just uses Mesa 3D as well it's about Nvidia users :/


    You're here because you try to avoid users questioning the benefits of Wayland and that's all. Everything I've stated was proven by links I posted while you try to sweep the flaws under the carpet. Where did I state that you don't care? It's interesting that you feel addressed by my statement that was quite general. But I guess you just miss the attention, don't you?


    Even if you add XWayland and build OpenGL then what's the benefit after all? Having even more dependencies? Impressiv! If you want to show off then do your homework first. I mean you should be aware of the Arch Linux dependencies since it's the place where most of your "inspiration" comes from.:/


    I'm really curious about Wayland gaming porn. I guess games look so much better. Oh wait it's GLES 2.0 /shrug Especially since most emulators are libretro cores which Retroarch can run without any displayserver so wayland will be super important. /shrug Ah I guess you're maybe refering to the RPCS3 pop-up menus which you see once in a lifetime of a game when you start a new game? Maybe they aren't shown in fullscreen anymore? Well I guess I have switch to Wayland too then! =O

    So have fun while you actually do some gaming. :angel:

  • gonna go out of the limb Escalade, your users are likely primarily PC Users (reguardless the manufacture,) so if thats what users want for x86_64 generic platforms, fine let em choose which they want. but 5schatten builds target not just the average PC but various SBC's as well, if he so called had to switch to full wayland (and do honestly correct me if im wrong on this), thats shooting out a likely large chunk of those who choose to use his builds. Personally i perfeer RR on my Pi 2 3 and 3B+ while i use Magicseb's for the 4 untill everything eventually smooths out for the 4.


    just my two cents *shrug*

  • Have you had a look at this topic? LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ] - V. Kodi Themes & Custom Skins


    Normally I never use any other skin so I don't have any experience with them. I changed the command in frontend-emulationstation.py#l3 because I've added systemd service files for each of the frontends.

    So what you could try to do is to create a python file e.g. emulationstation.py with this content and try to start it:

    Code
    1. #!/usr/bin/python
    2. import subprocess
    3. subprocess.call("systemd-run /usr/bin/emulationstation.start", shell=True)
  • Cael


    I also support the XU4, which is my main motivation for implementing Wayland support (no matter what this delusional idiot may think) as there's currently no way to switch modes on the fly without X11. Sway takes care of that nicely, although I haven't gotten it running on that yet because libmali is broken and soon(ish) is to be replaced by panfrost. Also X.org development has stalled to nearly a halt the last years and everybody is moving to Wayland, so might as well start getting things in shape. My tree will let you choose between them at build time, I am not here advocating one over the other the wayland builds are simply test beds for my current work. I am simply sick of this guy constantly spreading p0ison, so came to drop my two cents on what he's been saying.

  • Better to do this in PM or something like that.

    Mud throwing like this isn't going to help isn't it?

    Well let's say if everyone takes care of his own thread and if everyone keeps to the facts there would be no pointless discussion. /shrug

  • Have you had a look at this topic? LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ] - V. Kodi Themes & Custom Skins


    Normally I never use any other skin so I don't have any experience with them. I changed the command in frontend-emulationstation.py#l3 because I've added systemd service files for each of the frontends.

    So what you could try to do is to create a python file e.g. emulationstation.py with this content and try to start it:

    Code
    1. #!/usr/bin/python
    2. import subprocess
    3. subprocess.call("systemd-run /usr/bin/emulationstation.start", shell=True)I wi

    I wll check out that Link, I did try to create my own emulationstation.py... same results, blank screen for a moment. and kodi reloads...


    I'm not too concerned, i don't believe my PC can emulate PS3 anyways.. so, if you'd be so kind could you tell me what was the last .TAR file before you made the changes to the command? i believe i have all the update TAR's.


    Also.. one other thing... since the last 2 update TAR,s i notices i have a "SED Write Error" at boot.. Not that it concerns me because i will be rolling back,, just thought you might like to know.


    my PC is an much older Intel i7 -2700 with Nvidia 740 4gig.


    PS thanks again for your help.. and your fantastic builds.

  • Well reboot your system and try to run ES or else & then grab the complete logiles.zip stored in the logiles smb share. The newest file should be suitable because it contains all information... Kodi logs, dmesg, journal etc.


    I made a clean install on a 64GB usb pen drive and I don't have any "SED Write Error" messages or else. I've installed the skin Transparency! | Kodi | Open Source Home Theater Software for some tests so how did you add the custom launch command? The only problem I have found is that the python scripts lack the executable bit which prevents directly running them. So I'll add this and can reupload an image, maybe your skin choked on that? You can however run python python-script.py and so I guess Kodi had no problems with the missing bit.


    What I also had in mind... have you considered a somewhat screwed/faulty filesystem or hdd, ssd, usb-drive?


    I made the changes here emulationstation: added systemd service config · 5schatten/[email protected] · GitHub so everything older than 19 days should be fine if it's related to that.


    EDIT:

    can you try to run the pegasus-frontend.py? If that one works with your changes then it's probably the exec bit... all scripts exept ES & RA had them.

  • Sorry for late response... (3 kids, and I'm on Afternoon shift this week).... anyways,


    First I'll answer your questions, then tell ya a bit more about this system.


    1. Yes. /usr/bin/frontend-pegasus-fe.py. does launch! <--- I did NOT make any changes. just ran the command from the way i describe below.

    2. for Transparency! Settings/interface/skin settings/ Menu tab/ Add-ons- Submenu - <--- from there Application 1-5 if you enable them you can add a command, and a label for the home screen. That's how I've had it

    3. my rig.. well.. ya it's possible its a messed up HDD, (which is going to get formatted once we're done here with the new info)


    So. this Pc, has 2 Hard drives, RR Libreelec on one... Windows 10 on the other.. by default Libreelec loads... If i want windows 10, I just hit the boot menu and boot from that drive...

    95% of the time its running your RR libreelec, I only flip over to windows 10 for my kids to play stream games etc...

    my display is a POS Samsung smart 50in.. 4k

  • Build RR-20191009-d00f027 | uploaded for Generic | Index of /nightly/

    • updated to latest LE 9.80 / master branch
    • updated Generic Linux kernel to 5.3.5
    • updated to mesa 19.2.1
    • updated vulkan to 1.1.124
    • updated Pegasus frontend to Alpha 13
    • updated dosbox-sdl2 to 0.74-3 / r4250
    • added missing execeutable bit for ES & RA python scripts
    • updated several libretro-cores
    • updated Retroarch ressources (core-info, gamepad config etc.)
    • updated Citra, Dolphin & RPCS3
  • Test the latest update. Hopefully this fixes the startup problems.

  • I just installed the latest 905 version RR-20190326-8c1b004 and the libreelec addon repository is broken.


    It took some insane amount of fiddling for something as trivial, but it seems that the libreelec addon server was wiped of all the 905 addons ...


    ... and what do we 905 people do now??


    Without the TVHeadend Backend from the repository I can't watch TV. That's like the primary function of this tv box.


    Just now I tricked the box to use the TVHeaded Backend from the 9.0 Khadas VIM addon repository, but that's no good it doesn't even start. RPi doesn't work either .. both are missing libraries albeit it's for the exact same LibreELEC version...


    So what options does that leave? Compile the build from scratch? Trying to get luckshots with different verisons? And I would like to have other plugins from the LibreELEC repository too.


    It seems so crazy to me that there is no "sane" way to overcome this petty issue! It's just a missing download link for Christ's sake!


    Can someone shed some light on this? I am baffled.