Geniatech Mygica HDStar DVB-S2 USB HD not working

  • As requested here's the relevant dmesg from my working setup, there's an Xbox tuner in there as well

  • I managed to download the media-build source code off bitbucket and compile it against the most recent Ubuntu 16.04 kernel (4.15.0-45). My DVB-S2 device is now working correctly on an Intel Atom Media PC, which is great. Thanks very much to crazycat,@CvH and anyone else who helped get the device working.

    Just for the sake of completeness, I double checked the LibreELEC build I reported on in my last post. The build seems to match the one uploaded to Index of /test/ds3103b/. The kernel log also confirmed modules were being added from the 'kernel-overlays/driver.dvb.crazycat' folder. As before, I couldn't get the device to load.

  • hello, first of all thank all those who with your knowledge help to which we have no idea.

    Say that the image worked, but I tried to install an addon and it gave me an error so I had to format it and reinstall it and there it started in the problem because the TVheadend HTSP Client gives me a dependency error and it does not let me install it, the TVheadend server without problem.

    what can be done? Can another version be installed?

  • from what I see, we have to wait until they get a new image. :(

    Could you install the Drivers with the latest version?

  • Softlander should do it ootb

    But those ir shipped at the dvb devices are always an mess.

    If you mean by ootb "out of the box" then it didn't work for me. Although it works on windows. By the way when I installed the latest driver from the installer was titled "Terratec S2 USB HD" and the Lirc software that came with it was titled "TeviiRC". It is silly how they can't come with their own software until now :D.

    Also before facing the dependency error on TVheadend HTSP Client like asaber I was playing with channels and I have noticed that any EPG data that is not in English is not displayed correctly although I have installed its addon, also youtube titles have the same problem. Any idea about that?