Geniatech Mygica HDStar DVB-S2 USB HD not working

  • Sorry for my interrupt but I've got the same problem with an other setup.

    I have a TVHeadend server on a Arch Linux distribution with a Terratec Cinergy S2 PCIe dual reciever card in it.

    This card identidies itself as two USB adapters and uses the dw2102 driver with the dvb-fe-ds3103.fw firmware.

    I installed the Crazycat media_build because that is the only build where some people reported to have succes with.

    That build create the adapters and can be found in TVHeadend but they don't work.

    dmesg |egrep "firmware|dvb|frontend" gives exactly the same output as Devegoo mentioned under post #102.

    I think that if the solution is found here I can use that as well.

  • Hi,

    Newbie here.... I just got a Terratec Cinergy S2 USB box, which turns out to be a Rev. 4, so no luck with the LE 9.0. Is there any way to get this box working, and / or can I help? I have several PC's and Pi2/Pi3 devices to run tests on..

    Thanks in advance!

  • I managed to download the media-build source code off bitbucket and compile it against the most recent Ubuntu 16.04 kernel (4.15.0-45). My DVB-S2 device is now working correctly on an Intel Atom Media PC, which is great. Thanks very much to crazycat,@CvH and anyone else who helped get the device working.

    Just for the sake of completeness, I double checked the LibreELEC build I reported on in my last post. The build seems to match the one uploaded to Index of /test/ds3103b/. The kernel log also confirmed modules were being added from the 'kernel-overlays/driver.dvb.crazycat' folder. As before, I couldn't get the device to load.

    After reading your rather promising post, I tried it myself to get my S4600 from 2014 running again. It used to work, until last week before a kernel update.

    So I set out and compiled the media-build source into my Ubuntu 16.04 kernel 4.15.0-45 but with no success.

    Interesting part is, Chip ID is declared unknown. Before I applied the patches from crazycat, the Chip ID was 23, but it still would not work.

    I'm about to try to revert back to a really old kernel, just to see if I can get this dang Technotrend USB box going again.

    Original without patch:

    1. [ 5.015268] m88ds3103 0-0068: Unknown device. Chip_id=23
    2. [ 5.015288] dvb-usb: no frontend was attached by 'TechnoTrend TT-connect S2-4600'

    With crazycat patch: (but still not working)

    Edited 3 times, last by Scummer ().

  • Hi Scummer,

    If your device is from 2014 then it will be using an earlier version of the 'M88DS3103 demodulator' chip so it won't be exactly the same issue. If you have still got access to kernel 4.15.0-45 with the CrazyCat drivers installed I'd try enabling the ds3k module's debug option (i.e. create a conf file in the '/etc/modprobe.d' directory with the line 'options ds3k debug=1'). It won't fix the issue, but it may provide a few more details. If you can find out when the device stopped working you may be able to work out what changes broke support for your device. I'd also try the most recent stable Linux kernel version without Crazycat's drivers installed (i.e. deb packages available from here).

    I sometimes get the 'dw2102: i2c transfer failed.' message. I think it has something to do with the USB connection being subject to a high load. Anyway, I'd try the following, if you haven't already:

    - Double check the device isn't plugged into a USB 1 port (you can use the 'lsusb -t' command if you are unsure).

    - Try not to plug the device into an external USB hub (at least until you've got it working correctly).

    - Reset the S4600 device before starting the computer (i.e. unplug the power cable, wait a few seconds and then plug the power it back in).




    You'd also probably get more attention if you started a new thread, since it is a different issue.

  • LibreELEC (official): 9.0.2 (RPi2.arm) with crazycat latest build drivers addon.

    Need help. I tried everything. Nothing works. On a pc with Debian 9 I compiled and worked correctly despite some bugs.

  • look like this official V4L media_tree drivers, only old HDStar supported (with ts2020/ds300x chips).

    Thanks for answering. :thumbup:

    Would it be difficult to solve this problem?

    Another question, what better version of the kernel to use this device? I have a Debian (4.9.0-9-amd64) and a Rasp 3B. In Debian can get it to work, but it shows some bugs in tvheadend as wrong signal strength and problems with EIT epg grabber. In Rasp I compiled on Raspbian (4.14) and Ubuntu Server (4.15), none of them worked.

  • First issue related to ds3k tuner/demod. Troubles with Rasp and 4.14+ kernels related to usb host on this platform (or usb host driver issues with usb 2.0 compatibility) - need kernel logs.

  • crazycat

    I had a problem with my micro sd card reader. So buy another, post here. Do you want the Libreelec and Ubuntu kernel logs? Or is one just enough? Then I wanted your help on the bugs I noticed on tvheadend.

    I know that Geniatech does not provide good support, I bought this product just to learn a little more about dvb in linux.

    Thank you in advance.

  • crazycat Running on Ubuntu and probably on Raspbian. I just deleted the old drivers (I noticed it's in the script).

    1. [ 5.419590] dvb_core: disagrees about version of symbol vb2_vmalloc_memops
    2. [ 5.419592] dvb_core: Unknown symbol vb2_vmalloc_memops (err -22)
    3. Usually that means that the drivers (modules) were built for a different linux kernel.
    4. ->>>> sudo rm -rf /lib/modules/$(uname -r)/kernel/drivers/media/*

    I think we can focus on the bugs. What should I do?

    (Signal differences from the same source between hd star and android box with 2 tuners)



    EPG Grab errors:

  • Couple of snapshots to demonstrate how well the geniatech hdstar Hardware revision 3 works here.

    I don't use crazycat's tree here, but when i first got the hdstar device working in linux, using the m88ds3103 demod,

    instead of the older ds3000 module, I noticed it was working MUCH better than the ds 3000 module ever did.

    I sent my patches to crazycat, and he graciously modified it so as to attach the m88ds3103 / ts2022 chip a little more gracefully than what I was doing... his way autodetects the demod chip id and loads the appropriate module (ds3000 old vs m888ds3103 new), whereas my way was kinda brute force to make it work just for me.

    Anyhow we then implemented his version in to UDL's tree, located here. That was a few years ago...but to this day still works like a champ.

    v4l-updatelee · GitLab

    for the hdstar:

    First of all, to determine whether you have the SU3000 hw V3 or not, see the photo of the PCB that I uploaded to the linuxtv wiki,

    around the time we first got this device to function properly in linux.


    If yours doesn't say SU3000 V3.0 silkscreened on the PCB then it's probably an older hardware version with the older ds3000 / ts2020 chips.

    If it does say SU3000 V3.0 on the PCB, then look closer at the chips, they should be m88ds3103 demod / ts2022 tuner, like mine in that photo.

    That would be a good thing...

    The hardware IS different, but both old and new have the same USB Vid/Pid which is why ya have to use the detection of the demod chip id via i2c to determine which module should be loaded. That's the trick crazycat implemented, and we have included in UDL's tree.

    I would enable the real stats in your tvheadend configuration to display the signal stats in dBm for strength, and dB for Quality.

    The percentages ur looking at for comparison are useless... If you notice in my screenshots, the strength dBm and Quality dB are identical to

    the updateDVB program I am using.

    If interested, Since then I had noticed the empty Coax connector pads there in the rear of the PCB, and installed a new 75 ohm coax jack there, and modified the code a little bit in the TS2020 module to enable the Loop Thru (IF Loop) on that previously empty coax path. I then use that to feed my dvbsky S960 at times. IF Loop path is only active when the hdstar is active however.



    Edited 4 times, last by majortom ().

  • If using the raspberrypi, IMO, the best way to get that device working properly is to use the raspberrypi tree, that darksky an I maintain....

    that has UDL's drivers merged in, located here.


    If anyone uses arch linux, or archlinuxarm, there are package builds u can download, to make compiling/installing easier.

    No, we don't contribute to aur, so you won't find it there. I can compile install the pi kernel in about 20 mins

    on an old laptop here with the pkgbuild, crosscompiling (see makepkg-arm).

    v4l-updatelee pkgbuild for x86_64:

    rpi 32bit pkgbuild

    rpi aarch64 pkgbuild

    The raspberrypi tree was just updated the other day, and also has the ts2020 Loop Thru mod in it,

    in case ur bored and wanna install the missing Coax jack on your hdstar's PCB.

    Edited 5 times, last by majortom ().