LE 8.2.5 with UHD 630 / Coffee Lake / Gemini Lake support and luks

  • Hi 5schatten. Thanks a lot for your reply.
    My model is S952v3.

    Today i revert to back to version
    LibreELEC-Generic.x86_64-9.0-Milhouse-20180320003906-#0320-gc2a0368.img.gz
    that S952v3 was recognized successful

    And it was not reconized too. :( :(

    Very strange...
    I remove the S952v3 from my MOBO and looked to PCB of DVBSKY and detected defective electronic components. I don't know how it happens.

    I was sent is back to amazon today.
    So i will need more 2 or 3 days to have one new piece. And keep testing.
    5schatten You think S952v3 is good or recommend some other similar?

    Thanks for all.


  • psycmos


    Well after about 10 years of using Linux based HTPCs I would only recommend DVB cards that are supported by kernel drivers. I have no experiences with this particular card but in the past I thought about buying one. Since I got a cheap ITX board & case I ended up with USB TT-S23600 devices that work very well.


    Before you buy a different card check here https://linuxtv.org/wiki/index.php/dvb-s2_devices if it is supported.


    So if your card worked well in the past I don't see any reasons to choose another one.

  • @5schatten the tip to fix tvheadend helped me to see the problem and i have build a new version with old libva too. Yes i need to use git. Sorry so far there are only my patches which apply agains git version ov LE 8.2.5 and they are here HiDrive


    new version 8.2.5-6.42.1 with kernel 4.16.9

    - most updates are from the git repo of @Sschatten GitHub - 5schatten/LibreELEC.tv: A bit more OS for KODI

    - update iwlwifi-firmware from Sschatten git

    - update intel-ucode from Sschatten git

    - new package cc-dvb from Sschatten git as media_build replacement, so dvb drivers should be fine again

    - created a new package libva1 to fix tvheadend42, so old 1.7.3 libva (as in original LE 8.2.5) version exists too

    - kernel 4.16.9

    - carefull i just builded it and did no testing at all (so far)


    @psycmos try my new version 8.2.5-6.42.1-kernel-4.16.9 from here HiDrive and you should not need the suggested workaround from Sschatte (which gave me the hint for probably solving it)

  • Updateted the testing version 8.2.5-6.42.1-kernel-4.17-rc5 with all the changes from 8.2.5-6.42.1-kernel-4.16.9. Not tested on any box, just build was done.


    You find it under the normal download link (1st post) in the directories suiffixed by _testing

    Edited once, last by sky42 ().

  • Thanks a lot for your 8.2.5-6.42.1-kernel-4.16.9.
    In J4105M, sometimes it not boot. Stay in ASROCK logo. Maybe some UEFI BUG, i don't know.
    But i think that it happens to me 1 time with one of your older version too.
    I haven't tested other versions to see if happens too, because i bought it last week and just tested your builds.

    BUGS:
    -Audio Over HDMI have some artifacts.
    -HDMI CEC on Simplink LG, ( No Peripherals at System -> Input Devices)


    Tested with TVH4.2 :
    -DVB drivers are ok, replace my tuner S952v3 untill received new one, it load my (astrometa stick MN88473).
    -Transcoding are working for 1 FullHD channel webtv-h264-aac-matroska

    I will do more tests...

    It can help people for that have one tuner Astrometa MN88473
    BUG
    Using DVB-C, from astrometa stick MN88473 in THV:
    1)First star ok, tuned recognized
    2)I tune it for, DVB-T/ DVB-C
    3)Appear all ok.
    4)After reboot it take many time to start TVH service and after 3-5 minutes, THV starts and all tuners goes to disabled waiting for select tuner again.
    5)I set DVB-C again selecting at this time, just this tuner.
    6)Reboot again and all tuners are enabled again!!!!! (Greencolor), but i just enabled one!!!
    7)After reboot again, it can happens again, and sometimes i need to repeat this process from step 4)

    5schatten sky42 Can give me you paypal for buy one beer?!

    ASRock-j4105-M, 128SSD , 4Gb DDR4 | DVBSKY S952v3 | DVBSKY T330 USB | ODROID C2 | Thanks for all contributors

    Edited 2 times, last by psycmos ().

  • -HDMI CEC works fine but i use pulse-eight hdm adapter on the

    samsung tv 8000 led test it on j5005 en the j4105 and 8.2.5-6.42.1-kernel-4.16.9. inside:)

    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn

    Edited once, last by tomtomclub ().

  • Thanks for your reply.
    i'm planning buy one :)

    ASRock-j4105-M, 128SSD , 4Gb DDR4 | DVBSKY S952v3 | DVBSKY T330 USB | ODROID C2 | Thanks for all contributors

  • With version 8.2.5-6.42.1-kernel-4.16.9 on my NUC7PJYH I finally got Bluetooth to work. It didn't work with version 8.2.5-6.42.1-kernel-4.17-rc5 before.

    And there's progress on the "No Signal" bug. Someone tested a workaround by modifying Ubuntu kernel sources and solved the issue.


    So hopefully there'll be a LibreELEC version with this patch out soon, because with this bug the NUC is almost unusable for me.

  • some updates ... what was done:


    8.2.5-3.42.1-kernel-4.14.41

    - added CrasyCat dvb driver from 5schatten git as media_build replacement

    - kernel-firmware update to git 2a9b2cf5 from date 2018-05-18

    - iwlwifi-firmware from 5schatten git

    - intel-ucode from 5schatten git


    8.2.5-5.42.1-kernel-4.14.41

    - all update from 8.2.5-3.42.1-kernel-4.14.41

    - Mesa 3D 18.0.4

    - libdrm 2.4.92

    - xf86-video-amdgpu 18.0.1

    - xf86-video-nvidia 390.59

    - created/added xorg-server-1.19.6-sync_pci_ids_1.20.0.patch

    - created/added libva1 for compatibility, so that tvheadend42 should work


    8.2.5-6.42.1-kernel-4.16.9 and in testing 4.17-rc5

    - all update from 8.2.5-5.42.1-kernel-4.14.41


    8.2.5-7.42.0-kernel-4.16.9 and 4.17-rc5

    - this is for testing only

    - all update from 8.2.5-6.42.1-kernel-4.16.9

    - LLVM 6.0.0 for Mesa 3D 18.1.0 compile

    - Mesa 3D 18.1.0

    - this is a attempt to get AMDGPU Raven Ridge running (not working so far)


    @eightball70 you did catch my latest 8.2.5-6.42.1-kernel-4.16.9 and i was not done with the 4.17-rc5. The testing 8.2.5-6.42.1-kernel-4.17-rc now should work too with your bluetooth. When you get me or point me to the "No Signal" patch i will build a version with that patch.



    here are the versions that are new the last 2 days (if you downloaded before you should do it again) HiDrive

    ./3.42/Generic/LibreELEC-Generic.x86_64-8.2.5-3.42.1-kernel-4.14.41.img.gz

    ./3.42/Generic/LibreELEC-Generic.x86_64-8.2.5-3.42.1-kernel-4.14.41.tar

    ./3.42/RPi2/LibreELEC-RPi2.arm-8.2.5-3.42.1-kernel-4.14.41.img.gz

    ./3.42/RPi2/LibreELEC-RPi2.arm-8.2.5-3.42.1-kernel-4.14.41.tar

    ./5.42/Generic/LibreELEC-Generic.x86_64-8.2.5-5.42.1-kernel-4.14.41.img.gz

    ./5.42/Generic/LibreELEC-Generic.x86_64-8.2.5-5.42.1-kernel-4.14.41.tar

    ./6.42/Generic/LibreELEC-Generic.x86_64-8.2.5-6.42.1-kernel-4.16.9.img.gz

    ./6.42/Generic/LibreELEC-Generic.x86_64-8.2.5-6.42.1-kernel-4.16.9.tar

    ./6.42/Generic_testing/LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201119-kernel-4.17-rc5.img.gz

    ./6.42/Generic_testing/LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201119-kernel-4.17-rc5.tar

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805191444-kernel-4.17-rc5.img.gz

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805191444-kernel-4.17-rc5.tar

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805192229-kernel-4.16.9.img.gz

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805192229-kernel-4.16.9.tar

    Edited once, last by sky42 ().

  • eightball70 i follow the bug 105887 but i did see there is already a workaround


    So for all Gemini Lake user: I have build some LE version with the 1st workaround for Bug 105887.

    I think your best bed is a 6.42 or 7.42 version, but 5.42 and probably 3.42 should work too.


    Edit: First try LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201701-kernel-4.16.9, because for eightball70 / dkhait this one works and dkhait had some problems with other versions ( see this post #50 )


    download here HiDrive one of

    ./3.42/LibreELEC-Generic.x86_64-8.2.5-3.42.1-201805201731-kernel-4.14.41-bug-105887-workaround.img.gz

    ./3.42/LibreELEC-Generic.x86_64-8.2.5-3.42.1-201805201731-kernel-4.14.41-bug-105887-workaround.tar

    ./5.42/LibreELEC-Generic.x86_64-8.2.5-5.42.1-201805201657-kernel-4.14.41-bug-105887-workaround.img.gz

    ./5.42/LibreELEC-Generic.x86_64-8.2.5-5.42.1-201805201657-kernel-4.14.41-bug-105887-workaround.tar

    ./6.42/LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201653-kernel-4.17-rc5-bug-105887-workaround.img.gz

    ./6.42/LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201653-kernel-4.17-rc5-bug-105887-workaround.tar

    ./6.42/LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201701-kernel-4.16.9-bug-105887-workaround.img.gz

    ./6.42/LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201701-kernel-4.16.9-bug-105887-workaround.tar

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805201705-kernel-4.16.9-bug-105887-workaround.img.gz

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805201705-kernel-4.16.9-bug-105887-workaround.tar

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805201708-kernel-4.17-rc5-bug-105887-workaround.img.gz

    ./7.42/LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805201708-kernel-4.17-rc5-bug-105887-workaround.tar

    Edited 4 times, last by sky42 ().

  • LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201701-kernel-4.16.9-bug-105887-workaround.img.gz

    Just did a quick test and I can confirm the bug is gone. Everything is working ok so far. Thanks again for your great work.

  • Sky42, thanks for the hard work, i can confirm on my NUC7CJYH bug is gone. i did get a new one, i have to press remote twice for anything to happen. any and every action require pressing the same button twice. i reverted back to LibreELEC-Generic.x86_64-8.2.5-5.42-kernel-4.14.39.tar and remote works as usual.


    i tested:

    LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805201708-kernel-4.17-rc5-bug-105887-workaround.tar

    LibreELEC-Generic.x86_64-8.2.5-7.42.0-201805201705-kernel-4.16.9-bug-105887-workaround.tar

    LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201653-kernel-4.17-rc5-bug-105887-workaround.tar

    LibreELEC-Generic.x86_64-8.2.5-5.42.1-201805201657-kernel-4.14.41-bug-105887-workaround.tar

  • @dkhait please try LibreELEC-Generic.x86_64-8.2.5-6.42.1-201805201701-kernel-4.16.9, that is the one eightball70 used. I could build you a version with older kernel-firmware (that would be my first guess for this problem), but the new firmware fixed bluetooth for eightball70 .


    eightball70 can you confirm the problems of dkhait ? You have also a Gemini Lake NUC.

  • dkhait

    I recommend using bluetooth for a remote or at least a FLIRC. Only for wake up using IR.


    I did start with IR RC6 on my Haswell NUC. That was painfull slow with my Harmony 650.


    The i moved on to FLIRC with Harmony FLIRC HTPC profile, that was much faster. A FLIRC acts as a keyboard and works all the time without OS software support. But you need a windows to make firmware updates. I did an update only once as it was new and use the preprogrammed factory profiles.


    Now i use a Harmony Elite with bluetooth. This is faster then my eyes, when it is scrolling.

  • xorg 1.20 released, to build for AMD use kernel from here ~agd5f/linux - Unnamed repository; edit this file 'description' to name the repository.

    also for vegam you need to add firmwares from here ;)


    Index of /~agd5f/radeon_ucode/vegam


    PS. don't forget In kernel config turn on DCN, DC, for AMD and vegaM have separate option for turn ON

    and best use LE9 source for testing this, there is more changes for radeonsi - to use VAAPI


    allow using vaapi with r600 and radeonsi by lrusak · Pull Request #2403 · LibreELEC/LibreELEC.tv · GitHub



    :P