@balbes150 LE images with Kodi-19 for S9xxx

  • OK,


    Downloaded Armbian_5.44_S9xxx_Ubuntu_xenial_3.14.29_mate_20180515.img.


    1. It booted without manually changing any dtb.img.

    2. Booted without any wifi and ethernet again non-responsive

    3. "fw_printenv" command again listed "aml_dt=gxm_q201_unsupport"


    4. manually moved "gxm_q200_3g.dtb" to root as "dtb.img"

    5. No Boot (black screen after T95Z Logo)


    6. manually moved "gxm_q201_3g.dtb" to root as "dtb.img"

    7. Booted but again no wifi, no ethernet


    What should I try next?

  • Not much you can do or try. I had the same problem and gave up on Armbian for that reason.


    The core of the problem lies in q200 and q201 dtb images. Old q200 board came with 1gb ethernet, and old q201 came with 100mb ethernet ports. New q201 boards come with 1gb ethernet, but nobody made special dtb images for them...


    If you have a new q201 board with 1gb ethernet none of those dtb images work; with q200 my X92 does not boot, and with q201 it boots, but no ethernet...


    I had my original Android q201_dtb.img from Android 7.1.2 adapted by a fellow on CoreElec forum. Now I have a special q201 dtb.img with 1gb ethernet which works with CoreElec versions 8.90.1 and 8.90.2. (Latest CE 8.90.3 needs again new dtb.img)


    Did not try it this new dtb.img with Armbian. If you want I can upload it so you can try it out...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Now I have a special q201 dtb.img with 1gb ethernet which works with CoreElec versions 8.90.1 and 8.90.2. (Latest CE 8.90.3 needs again new dtb.img)


    Did not try it this new dtb.img with Armbian. If you want I can upload it so you can try it out...

    Please upload it and at least I can try it with either this or Wrxtasy's 8.2.4.1 LibreElec.


    Thanks a million!


    P.S.: How does one go aout developing new device trees? (q201 w. 1gb ethernet)

  • Here is the LINK to gxm_q201 dtb images. They are for mentioned CoreElec versions and I don't think they will work on @wrextasy bulds

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Here is the LINK to gxm_q201 dtb images. They are for mentioned CoreElec versions and I don't think they will work on @wrextasy bulds


    I used the above linked "gxm_q201_3g_gbit.dtb" as follows:


    1. Armbian (kernel 3.14): Boots successfully but no wifi or ethernet


    2. LibreELEC-S912.arm-18.0_20180601.img (this thread): no boot (black screen)


    3. CoreElec (CoreELEC-S912.arm-8.90.2) : Boots, Wifi Works, Ethernet appears but only gets an IP address outside of my network (169.254.25.133, when my IP range is 192.168.1.x) and is useless.


    Any further advice would be much appreciated. As you can see, I am willing to test anything and report!!


    Thanks for all help so far!

  • I never use DHCP pool for my devices, always set static IP addresses, so cannot offer advice.

    Try turning DHCP off on your box and give it static addresses for IPv4, Gateway and DNS servers. Make sure that the router has free static addresses outside of DHCP pool.


    This are my ethernet adapter settings on my box:

    (Router DHCP pool -> 192.168.1.100 - 192.168.1.200; ie all adresses outside of this pool are free)


    DHCP -> Off


    IPv4 -> 192.168.1.25

    Subnet mask -> 255.255.255.0

    Gateway -> 192.168.1.1


    DNS Server 1 -> 192.168.1.1

    DNS Server 2 -> 8.8.8.8

    DNS Server 3 -> 1.1.1.1


    With such settings everything works fine over ethernet on all my devices...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Small problem trying out
    LibreELEC-Odroid_C2.arm-9.0-nightly-20180608-8a0bf6c

    When viewing video less than HD say 480 content with device resolution of 1080 the resolution is switched down to 480 due to whitelist.

    When this occurs using view mode of 'stretch 16:9' black bars appear above and below the image where it makes no sense for them to be present. There are no bars in the video content itself.

    You can work around it by switching from stretch 16:9 in the video menu to something else and then back to stretch 16:9 then problem goes away and video content appears correctly as expected yet the same problem creeps up and requires correction every time a video is viewed.

    You can also work around it by disabling whitelist so resolution is not switched down to 480 in the first place or by setting the device resolution to 480 so no res change occurs when viewing content.

  • In all tests so far, I have had my dd-wrt router assign a static IP to the device outside of the DHCP pool. I have tried the T95Z Plus with either dhcp and manual settings. No dice.



    Interestingly: When I used your dtb as above it changed the MAC address of ethernet port. That dtb might be very specific to your device.


    I am about to pull the dtb.img from my Android ROM which works perfectly.

  • I cannot use my original Android dtb.img with any os on SD/USB. It just works with Android, so don't expect much. You can just use this original image to make a special version for Libre/CoreElec.


    On CoreElec forum a fellow made the one I linked. If you go there and contact bumerc (who made mine) or @TheCoolest and send them your android dtb.img, I am shure they will manage to make an apropriate image for your box.


    Btw, I just got a new dtb.img for my S912 q201 box which works only with with new CoreElec v.8.90.3. It works OK on my X92 q201 box,

    so now you can try if it works for you with new CoreElec version. It should work with all S912_q201 1gb_lan boxes.

    Link  

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

    Edited 2 times, last by Sholander ().

  • Hello all


    Took the image for a spin. Here's how it went down on my box
    Booted up. Couldn't read the top ( off the screen) Somethng about I don't know what your are doing. and didnt' want to load the kernel modules.



    dmesg.log




    kodi.log



    Thanks for you work

    Cheers

    Gary

  • Hi,Balbes150,


    I tried "

    Test variants of Libreelec KODI-18 (Leia) images for s812.


    "


    Hardware is S812, 1G ram, 100M lan.


    I followed procedure to burn the img to TF card, but the system reboot all the time. I don't know what happened.

  • Code
    Hi ... the latest version of Leia from 06.13 does not run through a toothpick ... when the first version was launched .... what could be ???
    Mini MX 1/8
  • Update version 20180621.


    Pay attention. When run first the configuration wizard, it may take a long time to poll existing networks (the more networks around, the longer the survey may take). You can wait until the survey is complete or go further and set up the network later.



    Took the image for a spin. Here's how it went down on my box
    Booted up. Couldn't read the top ( off the screen) Somethng about I don't know what your are doing. and didnt' want to load the kernel modules.

    Different settings are used for different systems. If the system works fine, do not pay attention to such errors.



    Test variants of Libreelec KODI-18 (Leia) images for s812.

    There is a separate theme for the s812 models. If multi-boot is enabled, you can try to delete the aml_autoscript script or use a USB drive.



    Hi ... the latest version of Leia from 06.13 does not run through a toothpick ... when the first version was launched .... what could be ???
    Mini MX 1/8

    Possible cause: you have not added the correct dtb.



    Does it work on Odroid C2 ? which dtb file should i use if i am coming from kszaq 8.2.3.1 ?

    I didn't check on the Odroid C2. In theory, it is possible that you want to add the "s905_autoscript" script line to "boot.ini".

  • Hello ...

    The version of LibreELEC-S905.arm-9.0-devel-20180621082211-5287365 is installed

    from LE I can not install PVRClient ..

    put versions v.2.4.14.1 / v.1.12.12 / v.4.0.3

    and no one is installed ... always says that no addition is found ...

    like this ... it's impossible to install ...

    ..... for the installation of PVR Client requires an add-on 5.2.1

    Edited once, last by sertem ().

  • Also tried a clean install with the build from test.libreelec.tv on Odroid-C2 with the build from 20th of June and got the same error. As far as I can tell the build from 24th won't bring anything that would change that.


    milhouse could it be that this is related to the old kernel, because the same change is working on RPi2? I saw something regarding this from you, but I don't know where and in which context anymore :D