@balbes150 LE images with Kodi-19 for S9xxx

  • balbes150 my apologies for posting here, everything is part because it is about development! Their DVB modules are also disabled.

    I build it: PROJECT = Amlogic DEVICE = AMLGX ARCH =

    My problem is when I try to build with active DVB modules. CvH

    LibreELEC.tv/options at master · LibreELEC/LibreELEC.tv · GitHub

    chewitt I get errors, Is it possible to align the modules with the kernel? or we still have a lot of work!

    Edited 2 times, last by erbas (July 11, 2020 at 10:14 PM).

  • I share your pain I have tried several times, using diff images, followed the steps as prescribed in this forum, yet am not able to install the latest in USB or SD Card, to the point that I have bricked two boxes in the process, but I was able to recovered them through manufacturer firmware, If you are able to get this working please share your experience and how. Presently I am on Coreelec but my preference is Libreelec

    I managed S912 T95 Zmax to boot with toothpick method and dtb qxm 201 using 9.8 armv8 aarch64

    But now I get the message

    FAILED TO START Configure eth0 mac address.

    Ethernet doesnt work.

    • Official Post

    GXM box devices normally come in three configurations with a low-end device having internal PHY ethernet and the mid/high-end device having extneral PHY ethernet. The Q201 device-tree is for internal PHY only so if that doesn't work try the Q200 which has external PHY. If neither of those work you'll need to try other GXM device-trees. TL/DR .. supporting "board" devices is simple, but "box" devices are always a lottery.

    NB: If the WiFi works, SSH in and share the URL from "dmesg | paste" .. maybe we can see more.

  • The network used to work fine back in the day when i used to install the old versions of libreelec and the same box boots with current coreelec dtb also. Any way to use the same dtb rather than reinvent the wheel ? Those didn't/ dont have a uenv file obviously. They just involve placing the dtb file in the system partition. Any hacks possible ?

  • The dtb files from Amlogic legacy/vendor kernels are not compatible with the mainline kernel (there are 3-5 years of evolution between them and many different drivers) .. but if you name the specific dtb that works we can see if anything stands out.

    compatible = "amlogic, bt-dev";

    the driver is included in the 3.14 kernel, is it included in the latest version(5.7.x kernel)?

    • Official Post

    honentan You can either a) provide the information that I asked for (the device-tree filename you are using), or b) provide unrequested info about a Bluetooth node that is present in 99% of Amlogic legacy device-trees that has nothing to do with Ethernet. It's entirely your call what you share (free speech and all that) but only one of the two results in me taking any further interest in the problem.

    NB: In legacy Amlogic devices 99.99% use a broadcom chip so we can use upstream and well supported brcmfmac WiFi and brcm BT drivers instead of the out-of-tree hackfest known as "dhd" that provides WiFi/BT in the legacy kernels. The mainline kernel does not use any of the drivers from legacy 3.14/4.9 kernels (which is a good thing).

  • The dtb files from Amlogic legacy/vendor kernels are not compatible with the mainline kernel (there are 3-5 years of evolution between them and many different drivers) .. but if you name the specific dtb that works we can see if anything stands out.

    I used to boot using kszaq's builds and the dtb used to be gxm201_1g_2GB

    • Official Post

    I can't find "gxm201_1g_2GB" in anyone's sources but both kszaq and CE kernels (3.14-nougat) show the same Ethernet config with Q201 devices using internal (rmii) PHY which is the same as the mainline kernel Q201 dtb. You'll need to share the "dmesg" output from the box for me to look any further into the problem. If the WiFi works you can probably get online to share logs from within the LE settings add-on (or CLI).

  • Can see the wifi networks but cant connect over wifi either. It gives a message Network Error: Input/output error

    EDIT: Never mind, of all the things that worked and never did seem to have been inverted :) Used wireless tethering to ssh into the box.

    output of dmesg here - hastebin

  • Code
    [ 8.232771] meson8b-dwmac c9410000.ethernet eth0: no phy at addr -1
    [ 8.232799] meson8b-dwmac c9410000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19)

    Can you repeat the Q201 test with LibreELEC-AMLGX.arm-9.80.0-box.img.gz

    Also check the Q200 device-tree, and see if any other GXM dtb files get further (VIM2, etc.). The same AP trick should work if no Ethernet.

    Q200 gives no mac address error and Vim2 didnt work too well either.

    With 201 now I cant connect hotspot, but wifi connects however still no ethernet but now I dont get the no mac address error.

    dmesg output = hastebin

  • Hi everyone,

    I have HK Odroid N2 4GB RAM and I'm testing LibreELEC but I got lot's of flickering on 1920x1080@60Hz TV, is it some well known issue or should I try to debug it somehow?

    IMG: LibreELEC-ARMv8.arm-9.80-devel-20200720091408-569f834-amlg12.img.gz

    with previous images it was the same.

  • Hi Finally, I was able to burn "LibreELEC-ARMv8.aarch64-9.80-devel-20200720113414-38e34a4-amlgx.img" into a SD card, however, the image can connect to wire networks, but not to the wifi ,my box image is "meson-gxbb-vega-s95-meta"

    Any suggestions to make the system connect at least I can get log report.


    Edited once, last by e123enitan1 (July 22, 2020 at 8:23 AM).

  • fri.K i've not seen issues with N2 in testing but see if LibreELEC-AMLG12.arm-9.80.0-odroid-n2.img.gz works better, this is using updated boot firmware (revised to support N2+) .. write image to SD card or eMMC and put the boot switch to the right - it will not boot with petitboot (switch to the left).

    chewitt unfortunately with this image device is not booting, always constant lighting red and blue LEDs. It doesn't matter if I try to start from SD card or USB pendrive. It worth mention that I installed balbes150 SPI boot 20191003/spiboot.img. Should I use different one SPI?