[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • even with your ssh command it still freezes like crazy .... so wierd when your other subtitle fix build worked flawlessly ... but would love to try the audio enhancements with this build hope you figure it out

  • Thanks.


    This definitely works:

    echo 1 > /sys/module/di/parameters/bypass_all


    I will settle for your 2nd suggestion though:

    echo 1 > /sys/module/di/parameters/bypass_hd


    Thanks wrxtasy!

    Solved that problem!

  • Ok cheers thx for the feedback everyone.


    I will put that bypass_hd option in Kodi settings in the next LE 8.2.4.x release.

  • Looking to be the ultimate 8.2.x version.


    Btw, any chance to solve "blocked merge" for the updated Mali drivers to r7p0 on CE?

    A number of CE team members tested these changes and found there was regressions with 4k video playback, the same subtitles fix can be achieved just by changing the dirtyregions in advancedsettings without the r7p0 mali blob but this setting is being phased out in Leia anyway.

  • A number of CE team members tested these changes and found there was regressions with 4k video playback, the same subtitles fix can be achieved just by changing the dirtyregions in advancedsettings without the r7p0 mali blob but this setting is being phased out in Leia anyway.


    Yes, I am aware of the problem with 4k video playback with r7p0...


    Since at the moment I am disabling all dirtyregions via advancesettings for subtitle fix, am I to understand that it is not necessary any more with latest CoreElec images?

  • If you don’t mind me asking, what kind of regression of 4K playback are we talking about?


    Take a look here: GPU AML - mali update to r7p0 - Subtitles fix - improve AML rendering by wrxtasy · Pull Request #1 · CoreELEC/CoreELEC · GitHub

  • A number of CE team members tested these changes and found there was regressions with 4k video playback, the same subtitles fix can be achieved just by changing the dirtyregions in advancedsettings without the r7p0 mali blob but this setting is being phased out in Leia anyway.

    Well I've also tested LE 8.2.4.1 on the S912 MINIX U9 with r7p0 AND Dirty Regions disabled and honestly I see NO so called "regressions" when CTRL-SHIFT-O is called into duty.


    I'm not seeing continual skipped frames or any visual upsets when playing a mixture high bitrate 23.976fps & 59.94 fps video.

    Is there a specific 4K video clip that I should be testing ?


    Are you sure this is not just a AMLogic CE Kodi Leia problem, it is Alpha software after all ?


    I will point out again this is r7p0 - S912 testing with Dirty regions disabled.


    I would like to also point out you cannot use Chroma 444,10bit at 4K 50 or 60Hz. It's outside of HDMI 2.0 specs.

    See the following chart:

    HDMI :: Manufacturer :: HDMI 2.0 :: FAQ for HDMI 2.0


  • I only briefly tested it so I'm not speaking from my own experience. I'm personally all for bumping packages to the latest versions as r5p0 or whatever it is we are using is over 2 years old now whilst r7p0 is much newer. I have a fully operational 4.x kernel that I have wanted to use for months now but it has no support for S905 (only S905X/W/912), Amlogic in their great wisdom decided to abandon the ailing chip in the latest Oreo updates.

    Anyway afl1 tested 4k with r7p0 changes and said there was regressions and we also collaborated with Sam from OSMC who had noticed regressions on the Vero4k, the OSMC builds are using 17.6 Krypton like yourself so I don't think it is related to Leia at all, I will try and poke afl1 for further clarification on what he meant though.

    Again this is not my experience it is just what I was told, I don't have a 4k tv (yet) so I'm not able to do the same level of testing that they did.

    On a side note the PR you made to CE was only blocked and not rejected, given it is quite a significant change I do believe it needs more testing as past experience has made me cautious with experimental changes due to the backlash I received when things go wrong so I'm interested to see the feedback it gets in your build, I'm very grateful for the PR and hope we can work closer in the future anyway.

  • Mhmm, I am compiling my own 8.2.x version with some personal patches. About 2 weeks ago I upgraded to r7p0 on 6 boxes (a mix of S905X and S912) and until now there were no issues/regressions (did also test Billy Lynn with 60Hz). Would be great to know which regressions exactly had been found.

  • Mhmm, I am compiling my own 8.2.x version with some personal patches. About 2 weeks ago I upgraded to r7p0 on 6 boxes (a mix of S905X and S912) and until now there were no issues/regressions (did also test Billy Lynn with 60Hz). Would be great to know which regressions exactly had been found.

    kindly share your work regarding s905x? Because I have also subtitle stuttering issue in s905x boxes. I m bit sensitive;(

  • I do not think this would be a good idea because I have some personal patches (Kodi related, especially for PVR manager) which only make sense in my personal environment and therefore might lead to misbehaviour of Kodi outside my personal environment. Sorry!

  • I’ve been using this build daily and I’m very happy with it there’s just one bug/issue I’ve found, if you fast forward for anything more than 1 minute the audio skips for about 10 seconds unless you pause then play again. It happens on every file I’ve tested (720p 1080p and 4k mostly mkv hevc)

    Not a major issue at all but it didn’t happen in your previous build before the pass through audio improvements were added

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • I do not think this would be a good idea because I have some personal patches (Kodi related, especially for PVR manager) which only make sense in my personal environment and therefore might lead to misbehaviour of Kodi outside my personal environment. Sorry!

    as you wish mate, Thanks for your immediate reply.

  • Question. I don't find the option color range limited (16-235) in the menus. Was it removed? At what range this build is outputting? I feel like it is (16-235) and not FULL. Colors look very washed out and my old Intel Nuc Libreelec didn't look this washed out on the same TV.

  • On a side note the PR you made to CE was only blocked and not rejected, given it is quite a significant change I do believe it needs more testing as past experience has made me cautious with experimental changes due to the backlash I received when things go wrong so I'm interested to see the feedback it gets in your build, I'm very grateful for the PR and hope we can work closer in the future anyway.

    The PR was only submitted to fix Subtitles on S912's anyway so it's no big deal if it gets rejected anyway. Makes for a bit of Dev discussion about various things which is always good. ;)

    It really is not needed for other Chipsets.


    When i get time I will amend the PR so it's specifically S912 only.

  • Question. I don't find the option color range limited (16-235) in the menus. Was it removed? At what range this build is outputting? I feel like it is (16-235) and not FULL. Colors look very washed out and my old Intel Nuc Libreelec didn't look this washed out on the same TV.

    You need to recalibrate / reset your TV's settings.

    AMLogic hardware by default outputs using YCbCr colorspace not RGB.

    There is no Limited or Full RGB settings for AML LE Kodi.