RPi 3b+ Fast Forward freeze

  • Hello,

    Sorry for my bad English.

    I´m Using Kodi for record TV. I had used a RPi 3 for a year. Without any issues. (Kodi 15.2 on Openelec)

    Now i have the new Raspberry Pi 3b+ and have made a clean Install.

    Now the FastForward not working properly. If i run FastForward the Picture Freezes. The time continues to run but if i press the Play Button the Video is at the Point where the Picture is frozen.

    When searching for the problem I have often read that skip is better than FastForward. It may be that it is suitable for advertising ... but if I want to watch Formula One in Fast Forward, that's not practical.

    I think I have a setting wrong. But which?

    - I look directly from the connected hard drive

    - I have an MPEG2 license key (is also enabled)


    I tried this while in the debug mode (after a reboot). The logs are in the Attachment. I cant find anything.


    I hope you can help me?


    Regards,


    Bismosa

  • Hello,


    no. Skipping is no option. I want to watch e.g. Formula1 in quick run. (not to miss anything)


    With Kodi 15.2. no issues.


    Regards

    Bismosa

  • Skipping is no option. I want to watch e.g. Formula1 in quick run. (not to miss anything)

    Then get yourself a proper htpc with more CPU horsepower. The RPI was designed for normal video play speeds, and not for having to do 60fps videos at 3-5 times the speed. Basically having to process a video with up to 300fps.

  • Hello,

    It may be that I do not understand it correctly ...

    If i have debug on and run Fast-Forward the CPU are only on about 30%. So i don't think that this is the problem.

    With my previous System (RPi 3 with Kodi 15.2) i had no issues with Fast-forward.


    Regards

    Bismosa

  • Hello,

    the examples are recordings from TVHeadend...but it also happens on other Video files. I did not use Live TV in KODI.


    Or on this File:


    So far I have not found a video file that works better.


    Regards

    Bismosa

  • Hello,


    just a update.

    After some tests i found out that:

    Disabling "Allow hardware acceleration - OMXPlayer" (This is the standard setting in LE)

    (See my Videos). It will not work smooth. It has a bad refresh rate.


    Enabling "Allow hardware acceleration - OMXPlayer"

    FastForward will not work. After a few seconds the Video freeze.


    Disabling "Allow hardware acceleration - MMAL"

    The CPU load increases highly. But my Raspberry has no Problem (even with HD Movies)

    FastForward will be work very good!


    I think there is a problem with hardware decoding.


    Regards

    Bismosa

  • I’m sure I’ve read this is summit to do with stream profiles in Tvheadend, it’s recommended to change the stream profile to mkv not htsp or pass. But Kodi will not work with mkv streams from Tvheadend.


    That’s why it doesn’t ( on my box ) have the issues when watching a mkv film.


    Matt

  • Poking older releases is nice, but you need to test with a current Leia build as that represents the current state of development and where anything can/might/would be fixed. Krypton is a dead codebase.