Posts by bismosa

    Hello,


    many thanks!
    There are Updates available i will test them:

    Bootloader EEPROM from 2019-07-15 to 2019-09-10

    VIA USB3 from 00013701 to 000137ad


    I think i have found my problem. I have a script running to monitor the system. There is this query included:

    Code
    1. hdparm -C /dev/sda

    if i disable this, everything works for hours without problems.


    It seems there is a bug with this query.


    Many thanks for the help!


    Regards

    Bismosa

    Hello,


    I am still setting up my Raspberry 4 with LibreELEC 9.2.1

    Every few hours my system is crashing. This only happens with a connected USB3 HDD. With a connected USB2 HDD everything works fine.

    I have tested with my RPi 4 (2GB) and my RPi 4 (4GB). Both are the same result.


    dmesg generates the following output:

    If i than try to read Data from the Drive i get

    Code
    1. [18066.706030] usb 2-2: reset SuperSpeed Gen 1 USB device number 2 using xhci_hcd
    2. [18066.724117] sd 0:0:0:0: [sda] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x03 driverbyte=0x00
    3. [18066.724128] sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x28 28 00 3a 38 57 80 00 00 08 00
    4. [18066.724135] print_req_error: I/O error, dev sda, sector 976770944

    Sometimes (but not always) i can reboot with the command:

    Code
    1. reboot -f


    I have found following tips that did not solve this problem:

    - Use another power adaptor. This problem is also when i use a powered USB2.0 hub.

    - From ( STICKY: If you have a Raspberry Pi 4 and are getting bad speeds transferring data to/from USB3.0 SSDs, read this - Raspberry Pi Forums)

    Add to cmdline.txt:

    Code
    1. usb-storage.quirks=XXXX:XXXX:u

    Add to config.txt

    Code
    1. force_turbo=1
    2. over_voltage=2

    But this problem still exists.


    What can i do to solve this?

    The HDD works on my PI3 without problems. Or is the HDD about to die?

    Regards

    Bismosa

    Hello,


    I am still setting up my Raspberry 4 with LibreELEC 9.2.1

    I've had it for the past two nights that the Raspberry has shut down in the evening. But I just don't find the reason why.

    The first evening i suspected that it was due to switching off the television and the CEC coupling.

    The setting was that the playback should be stopped when the tv is switched off.

    Now i have no TV connected. And yesterday at 22:00 the system turned off. Here is the section from the log:



    I cant find a setting, that the System should turn off. In the Settings-PVR energy Saving is off. The energy saving functions are also deactivated in the system settings.

    In the TVHeadend settings i find nothing about Energy Saving?


    Regards

    Bismosa

    Hello!


    Somehow I expected this answer ...i have read it multiple times.

    Fast Forward is important for me. Me and my Family (especially the children) can deal with it much better. We have tried it...but nobody was happy with it. I am faster with Fast Forward to find the end of commercials.

    Another example. I like to watch motorsport. If i don't have enough time, i like to watch in 4x or 8x. When the time for pit stops comes or interesting overtaking maneuvers i press Play and watch in Realtime. I can´t do it with skip.


    We only use skip if we e.g. want to jump to the middle of the film. Or the time to Fast Forward is to long.


    Regards

    Bismosa

    Hello!


    I don't think this should be about the best setting, what are the default settings, etc.

    I am aware that different hardware requires different settings. I've been trying to find this attitude for days and hours now. But I don't succeed.

    I currently only have 2 options:

    Setting on: Fast-Forward works, but i get only stereo sound

    Setting off: No Fast-Forward, but i get Sound on all my Speakers

    I am not happy with either variant.

    With my old Raspberry Pi with OE15 there is no problem. With a Fire TV Stick there is also no problem.


    I thought this area is for bug reports. I think there is a bug. Or I'm doing something wrong.


    Regards

    Bismosa

    Hello,


    Why would you want that?

    This option is by default turned off.

    it is recommended, because...?

    I have read many times that this option is "no longer needed". Audio must be transcoded and no passthrough with this option.

    And i cant get 4.1 Sound to my receiver with this option turned on. So for me it is not an option to use this setting?


    Sorry, but I have no clue why you would change settings that already make the RPi4 work properly.

    I think that the default settings should actually work? But unfortunately they don't. Or i made a mistake?


    Many thanks!

    Bismosa

    Hello!


    I have a new RPI4 (4GB) an have installed Libreelec 9.2.1

    The RPI is connected to my TV (Samsung KU6409) with HDMI.

    I have not activated/buyed any MPEG licenses.


    I had issues with Fast Forward.

    If i had the option "sync playback to Display" on, Fast Forward (up to 32x) work very well. The Screen is updating very fast.

    If i turn off this option, Fast Forward will not work correctly. For a short time it will work, but then the Video is Playing (a second or so) with normal Speed and than it Skips many Seconds. Than the Video is playing at normal speed...and so on.


    If I understand it correctly, it is actually recommended to have this setting switched off. Audio bypass will not work with this Option...and my Receiver (Marantz NR1506) only use Stereo (even if the number of channels is set correctly). I don't know if this is another Bug.


    I have made 2 logs:

    Sync playback to Display - on

    http://ix.io/2gd9

    Sync playback to Display - off

    http://ix.io/2gdd


    I don't know if it's a bug from Raspberry, Libreelec or Kodi. I hope I'm right here.


    I have also tested with an older 1.Gen Fire TV Stick. There is no issue with that.


    Many thanks!


    Bismosa

    Hello,


    just a update.

    After some tests i found out that:

    Disabling "Allow hardware acceleration - OMXPlayer" (This is the standard setting in LE)

    (See my Videos). It will not work smooth. It has a bad refresh rate.


    Enabling "Allow hardware acceleration - OMXPlayer"

    FastForward will not work. After a few seconds the Video freeze.


    Disabling "Allow hardware acceleration - MMAL"

    The CPU load increases highly. But my Raspberry has no Problem (even with HD Movies)

    FastForward will be work very good!


    I think there is a problem with hardware decoding.


    Regards

    Bismosa

    Hello,

    the examples are recordings from TVHeadend...but it also happens on other Video files. I did not use Live TV in KODI.


    Or on this File:


    So far I have not found a video file that works better.


    Regards

    Bismosa

    Hello,

    It may be that I do not understand it correctly ...

    If i have debug on and run Fast-Forward the CPU are only on about 30%. So i don't think that this is the problem.

    With my previous System (RPi 3 with Kodi 15.2) i had no issues with Fast-forward.


    Regards

    Bismosa

    Hello,

    Sorry for my bad English.

    I´m Using Kodi for record TV. I had used a RPi 3 for a year. Without any issues. (Kodi 15.2 on Openelec)

    Now i have the new Raspberry Pi 3b+ and have made a clean Install.

    Now the FastForward not working properly. If i run FastForward the Picture Freezes. The time continues to run but if i press the Play Button the Video is at the Point where the Picture is frozen.

    When searching for the problem I have often read that skip is better than FastForward. It may be that it is suitable for advertising ... but if I want to watch Formula One in Fast Forward, that's not practical.

    I think I have a setting wrong. But which?

    - I look directly from the connected hard drive

    - I have an MPEG2 license key (is also enabled)


    I tried this while in the debug mode (after a reboot). The logs are in the Attachment. I cant find anything.


    I hope you can help me?


    Regards,


    Bismosa