LibreELEC 9.0 / Kodi 18.X for Minix X8,X8H,X8H+

  • Yes with the "Stock" ROM it is ! Now - "minix_x8_x8plus_x8_h_newbootloader_FW9" - firmware will give you proper shutdown, Just be patient after flashing and starting it back up > it can take a long time to boot up android as it has to build all the cache files etc. so be patient.

    After that you will again have to hold the reset to break the bootlaoder again with the LibrElecec SD. :-)

    and btw dont freak out with a black screen during first startup Android, so be patient!

    Thank and Well noted.

    Downloaded 3 times of minix_x8_x8plus_x8_h_newbootloader_FW9 (Size#858,701KB)

    Downloaded 3 times X8H_PLUS_LOLLIPOP_RC2_NEWBOOT (Size#923,074KB)

    Try burning using LibreELEC.USB-SD.Creator.Win32 - received error as per screenshot.

    **Got some info from SD creator failing with Windows 10

    Try burning using Rufus = received error "Failed to scan image"

    Managed burning image (minix_x8_x8plus_x8_h_newbootloader_FW9) using Burn_Card_Maker_V2.0.3 without error.

    Boot the minix while holding reset switch for 5 -6 sec (the bootloader will be patched) (little hole on the back - paper-clip worx fine)

    Confirm TV connected to Minix just black screen without any picture or indication for 1 hours. Am i at the right track?

  • humantoz

    I always use the USB Burning Tool so with the Burn Card Maker I have no idea ......

    With the USB Burning Tool I use an old mini HP PC with windows 7 x32 / as windows 10 can be a pain to burn firmware !

    I had it once where it hung and I turned it off, removed the SD-card and booted it back up with the reset method to get to the screen where you can clear the: "WIPE CACHE PARTITION" from the bootmenu afterwards choose Reboot and all started up fine after that for me.

    USB Burning Tool never failed on me so I have no experience on the Card Maker method. I am sorry.

    Maybe someone here can help more on this subject.

  • Klaver7

    Spend two days to figure this, drove me crazy. Planning give myself a final shot before hammering the box. ;(

    1. I was successfully make Minix work on LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img. However, couldn't shutdown (it's known issues).

    Now, i am working shutdown solution, step performed as following

    Step 1. Downloaded minix_x8_x8plus_x8_h_newbootloader_FW9.img (Size#858,701KB)

    Step 2. Downloaded X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img (Size#923,074KB)

    Step 3. I was successfully burn minix_x8_x8plus_x8_h_newbootloader_FW9.img using USB Burning Tool.

    Step 4. Reboot and loaded into Minix welcome screen.

    Step 5. As per your expert advise, after that you will again have to hold the reset to break the bootlaoder again with the LibrElecec SD.

    Question: LibrElecec SD refer to using X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img? If yes, my issues is this file unable to burn into SD using LibreELEC USB-SD Creator! / Rukus / any other SD software available market in Win7 64bit.

    FYI, i have no issues burning LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img using USB Burning Tool as it's (.gz) format.

    Question: May i confirm file with extension (.gz) meant to burn into SD using LibreELEC USB-SD Creator!?

    Question:. May i confirm file with extension (.img) meant to use USB Burning Tool to flash direct to Minix?

    Question: Step 5. As per your expert advise, after that you will again have to hold the reset to break the bootlaoder again with the LibrElecec SD. Do i need to perform this step as well, browse the SD and rename "boot_autoscript" to "boot.scr"?

    Just test for fun

    Scenario 1:

    1. Burn minix_x8_x8plus_x8_h_newbootloader_FW9.img using USB Burning Tool.

    2. Reboot and loaded into Minix welcome screen.

    3. Burn X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img using USB Burning Tool.

    Result: Device not running at all - black screen, as expected.

    Scenario 2:

    1. Burn minix_x8_x8plus_x8_h_newbootloader_FW9.img using USB Burning Tool.

    2. Reboot and loaded into Minix welcome screen.

    3. Burn LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img LibreELEC USB-SD Creator!.

    Result: Successfully installed, Loaded Kodi 18.3 operate as usual after adjust refresh rate. Only shutdown issues only

    Literally, I am close to success, just stucked at creation of LibrElecec SD using X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img using LibreELEC USB-SD Creator! .

    Help! Help! Help!

  • This morning I flashed 'LibreELEC-MXIII_Plus.arm-LE9-Kodi_18.5.img.gz' on a sd-card and put that in my Minix X8H Plus.

    All seems to work quite well: LAN, WLAN, Add-ons, shutdown.

    Oh, my Minix 8h Plus runs on the Finless Lollipop ROM.

    To bad there's no tar-file, with which I could have updated my existing 8.2 sd-card.

    Thread: S802/S812-Libreelec images for 7/8/9

    Download: StackPath

  • I'm having trouble with the flashing of libreelec.

    I have updated the Lollipop firmware okay. "Burned" the libreelec image above for the h-plus version - renamed the file to boot.scr and press and hold recover + power on.

    I have tried 4 different SD cards of many brands (because it can be picky I think I read?)

    But every time all it does is take me to the android recovery menu (where I can update from SD/usb but it wont accept .img files).

  • do you have the receiver for the Neo A2/3 remote plugged in ? If yes, unplug it before switching on your Minix. For me that does the trick (btw, on every boot not just when flashing)

  • Hello

    I installed over a minix X8-H (with Finless Lollipop rom1.0 )
    It works GREAT , really surprised ! I hope you will not abandon H8 in Kodi 19 too !

    Before doing the upgrade I was ordering a Chuwi herobox because I was tired of continuos video and audio issues with android/kodi.
    Happy to see that I can continue to stay with a new X8-H life reborn ! THANK YOU


    Edited 2 times, last by graziano ().

  • Hello

    a minor issue ,

    if I try to add something from Le ADDon repository I receive this

    could not connect to repository

    below is my repository file for minix X8-H , is it correct ?

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>

    <addon id=""

    name="LibreELEC Add-ons"


    provider-name="Team LibreELEC">

    <extension point="xbmc.addon.repository"

    name="LibreELEC Add-ons">


    <checksum verify="sha256">…/arm/addons.xml.gz.sha256</checksum>

    <datadir zip="true"></datadir>


    <extension point="xbmc.addon.metadata">

    <summary>LibreELEC Add-ons</summary>

    <description>The LibreELEC add-on repository contains Kodi PVR Clients and Servers, Screensavers, Visualisations, and more. Add-ons in this repository are maintained and supported by LibreELEC staff and YOU the community. If you find a broken or non-working add-on please report it via the forums, or help by submitting fixes via GitHub.</description>




    Thank you

    Edited once, last by graziano ().

  • try this and it will work :

    change 9.0.2 by 9.0 in the url

    eg :…ek_Play/arm/addons.xml.gz =>

    meanwhile new images with kodi18.5 are on the way.

    status :

    • it builds
    • kodi18.5 not fully tested but seems ok
    • netflix tested ok
    • addons repo url revert to 9.0

    to do :

    • try to update and build addons
    • try to build dvb addons (crazycat, etc)


    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    now using Apple-TV 4k

  • Hi darth, I've located the xml in /usr/share/kodi/addons/, but I'm unable to modify the URL to change 9.0.2 by 9.0 since the filesystem is readonly. How can we modify this?

    One more question, would it be posible to upgrade to the new build with kodi 18.5 from 18.3 without losing the library and settings?

    Thanks for your great work!

  • Hello everyone, first of all many thanks to everyone who put their work into this project. I have an old Mini X x8h with LibreELEC-S82.arm-LE9-Kodi_18.5. Everything works very well after I set it to 50hz. Unfortunately I couldn't find a solution for the Libreelec Repo. No connection. anyone have a solution? Thank you. Sry for my Google Translter English :)

  • Hello

    I tried this

    change 9.0.2 by 9.0 in the url

    eg :…ek_Play/arm/addons.xml.gz =>

    I edited the file /storage/.kodi/addons/

    # nano /storage/.kodi/addons/

    but it does not work , same issue . Also if I point the browser to
    I receive a forbidden error page.

    BTW This is my current /storage/.kodi/addons/ file

  • Correction , I restarted Librelec and the Addon section now works perfectly ! I am using the Music Visualizators now , happy !

    I would ask too if it will be possible to upgrade to the new build with kodi 18.5 without losing Kodi settings , thank you.

    Edited 2 times, last by graziano ().