LibreELEC 9.0 / Kodi 18.X for Minix X8,X8H,X8H+

  • Hello jak455

    I also have try it to install Libreelec on my Minix 8h-Plus. (mine is under Lollipop android)-and didn't work. See here

    After you post it I try it with the USB stick and take out from Minix the A2 remote usb, same result -not working.

    Can you tell us which version of Android you have on your X8-Hplus? is it KItkat with the last firmware (011) or the 5.1 lollipop released by Ken from Minix?

    Also, could you please detail the steps of your installation? cause the Libreelec kodi (17.6 doesn't contained the very important file described in the first post of this thread : boot_autoscript

    Thank you

    Edited once, last by Macko ().

  • Hi Antjc,

    could you please tell me which version of Android you have on your X8-Hplus? is it KItkat (4.4.2) with the last firmware (011) or the 5.1 lollipop released by Ken from Minix?

    Also, could you please detail the steps of your installation? cause the Libreelec kodi (17.6) doesn't contained the very important file described in the first post of this thread : boot_autoscript

    I try it again with the LibreElec Leia and I receive the following screen (I want to run LibreElec only from Sd card and keep the Android so on nand-internal minix memory).

    View image

    Thank you

    Edited 3 times, last by Macko ().

  • the last android i had was kitkat. cant recall firm ware.

    done ages ago, just before minix forum disappeared

    I put 17.6 on at that time.


    I installed kodi 18.0RC4-Leia this time

    I have installed to internal as well.


    install was exactly as described in post 1. the only thing i did slightly different was the sequence of boot

    ie power switch on wall switched to on, then depressed reset then tapped box switch and waited 6 sec ,keeping reset depressed.

    when logo starts flashing released reset pin.

    i cant comment on the image you posted. above my pay grade

  • Hi Macko,


    My X8P is on KitKat, latest official fw available (I never went with the beta lollipop).


    I am using a USB3.0 stick (SanDisk Ultra). I put the 18 RC4 version onto it using the LE tool, changed the name of the boot file, unplugged the remote dongle and power, plugged in the usb stick, pressed/held the reset button, plugged in power, pressed/held power button for 5 sec, released power and thereafter released reset button -> LE screen came up and all went automatic from there. Had to repeat this 2-3x as the minix logo appeared i.o. LE screen.


    hope this helps,


    jak

  • @Antjc

    Thank you



    jak455

    Thank you very much. The most useful post for me.

    After more then 20 tries in different combinations of LibreElec versions and dtb. images and so on....I will try the way you explained very very clear this time. Pointed out the big difference between indications from the first post and your technique.


    Quote


    boot the minix while holding reset switch for 5 -6 sec (the bootloader will be patched)

  • after 8 tries.....not a chance..

    MInix logo appear-blinks- release the Power button-release the reset button.....MInix logo stop and then screen said....the file is corrupt (all versions Libreelec 17.6, Leia RC4- 2 sd-cards and one Usb stick).

    I don't understand....

  • not sure how pertinent this may be but being your playing with older boxes sometimes what i think happens is the actual bootloader in the flash on the box gets buggerd and causes the new install to not properly see the bootdisk your trying to install which is why back in the old days we built boot loaders based on the actual bootloader in the box.


    In that type of setup the bootloader we created actually fully overwrites whats in the flash on the box and as long as the bootloader was built based on a dtb based on that actual box and its hardware.


    every old box has its own picky way of interrupting the flashed boot loader so you need to play a bit to figure what actually gets you in.


    a lot of the older boxes sometimes from the newer methods trying to patch the existing bootloader screw up the existing one causing the corrupted file message and not wanting to run it. sometimes what seems to help is to restore the box to original Android software and let it restore the original flash bootloader and then try what your doing.


    eg: The Eny original M8S boxes used to do that all the time which is why i built a M8S specific boot loader based on its exact hardware and then in the project use that file as the bootloader to flash to the system. For some reason some of the older S8xx and earlier boxes seem to fight being patched and can be a real headache while other boxes seem to be easily pushed into working... Freak tab used to be flooded with threads bout old boxes and boot loader issues.


    All the newer boxes (S9xx) i have coded seem to work with the current methods of handling the bootloader whether its booting off a sd-card or installing internally and its just a matter of having the right dtb to get all the hardware recognized...


    just for informations sake... the way you build the actual bootloader is to restore the manufacturers original firwmware and then setup ssh or serial monitor and log into the running box and then dump out all the required memory areas and parts and then put that together to create your specific bootloader for that box and use that as the bootloader... its not as flexible as the newer patchable method but does give you a proper bootloader for that box so for anyone doing a bunch of the same box its a goof proof method of flashing something other then Android to the box.

  • beta lollipop

    you mean the lollipop of Minix caused the misleading information from the first post?

    how to patch the minix bootloader :

    • burn the GZ img to a SD
    • browse the SD and rename "boot_autoscript" to "boot.scr"
    • insert the SD in the minix
    • boot the minix while holding reset switch for 5 -6 sec (the bootloader will be patched)
    • let Libreelec boots and configure ssh, etc
    • restore your cfg if needed


    I am using a USB3.0 stick (SanDisk Ultra). I put the 18 RC4 version onto it using the LE tool, changed the name of the boot file, unplugged the remote dongle and power, plugged in the usb stick, pressed/held the reset button, plugged in power, pressed/held power button for 5 sec, released power and thereafter released reset button -> LE screen came up and all went automatic from there. Had to repeat this 2-3x as the minix logo appeared i.o. LE screen.

    datrh

    you maybe have right

    The Lollipop beta firmware released by Minix caused also the missing files from LibreElec 17.6 gz

  • you mean the lollipop of Minix caused the misleading information from the first post?


    datrh

    you maybe have right

    The Lollipop beta firmware released by Minix caused also the missing files from LibreElec 17.6 gz

    no at the time i have made the 17.6, the needed infos were available on the minix forum as well as a link to the "boot.src" (needed to boot from SD or usb).


    it wasn't never integrated in the image.


    i've integrated it when i started to build LE8.90.x and kodi "Leia" 18 for my minix device (x8-h)


    the lollipop bootloader isn't compatible with the dtb's i use. when your device boot , it doesn't find the system on the SD or usb.

    this why you get the message "files corrupt....."


    kitkat runs with a linux 3.10, a bootloader version "X"

    lollipop runs against another version of linux, a bootloader version "Y"


    my images works with a linux 3.10 and are compatible with a bootloader "X"

  • Datrh

    There is any possibility to extract the lollipop dtb image or bootloader that is running on Minix 8h plus and integrated to leia librelec version ??

    Thank you very much for your work

  • just out of the oven, not tested yet

    #1 updated


    kodi 18 final has almost landed

    Thank you darth !!!


    I am currently on RC4, how do I go about updating to RC5.2 ? Do I need to do a complete re-install or just replace some files on my SD-Card / USB stick, if the latter, which ones ?

  • Thank you darth !!!


    I am currently on RC4, how do I go about updating to RC5.2 ? Do I need to do a complete re-install or just replace some files on my SD-Card / USB stick, if the latter, which ones ?

    you need to know the ip address of your minix.

    check this post : Update from .tar

  • you can create a file called autostart.sh and place a line with


    ifconfig eth0 hw ether xx:xx:xx:xx:xx:xx


    replace the xx's with your mac address you want to set the box to.


    put the autostart.sh file in the config directory and on rebooting the box that should set it to what ever you want.


    if you already have the autostart.sh file on the box just add the above line to the end of the file you've got.

  • This does not seem to make any difference mac address is still changing upon reboot.