LibreELEC 9.0 / Kodi 18.X for Minix X8,X8H,X8H+

  • I upgraded a minix X8-H (with Finless Lollipop rom1.0 ) from Kodi 18.3 to Kodi 18.6


    All works correctly except of movies coded in x265 HVEC (video stuttering), anyone has this issue too ?

  • wowwow...


    As for the Eny M8S (n200's) for some reason Datrh's seems not to make a actual working img... It works great on all the minix devices but the older Eny's for some reason always ends up with a corrupted file system or can't find the proper partition. The compile goes ok and it produces a img but the image always comes up with the filesystem corrupt message or it can't find the partition its looking so it never expands the system on install. The wierd part is that happens when using a linux box to create the sdcard yet if you use windows and libreelecs sdcreator to create the sdcard it will get past the above mentioned errors and do the install but then it runs really unstable...


    I gave up trying to find the issue with datrh's repo on these old n200 based boxes and made some mods to his build setup and made it work and have been testing it for awhile and it seems fine.


    I just finished updating it to Leia 18.7.2 and once i am done a bit of testing if you want a copy to try, let me know and i will upload it someplace... Its intended for the original Eny M8S using the n200_2g device tree...

  • I am interested in your build to test on my M8S box. Is power down and power up OK with your build. I tried with Dementris build, and power down the box is OK but power up is not working. I have to unplug and plug it back in order to boot. Please send me the link so I can test your build.

    Thank you.:thumbup:

  • I also made a custom version for M8S+ devices, which based on the Demetris' source:

    GitHub - dtechsrv/LibreELEC.tv: 'Just enough OS' for Kodi for OTT M8S+ TV boxes

    (Compiled LE image for M8S+: Releases · dtechsrv/LibreELEC.tv · GitHub)


    Maybe my source repo is usable for Eny M8S (n200) devices too, because I also replaced the kernel version to another one.

    The original kernel was unbootable on my M8S+ device, because it encountered a problem with NAND flash pins.


    This is a legacy LE v9.0.2 build with Kodi 18.2, because later versions from Kodi (18.3+) have a very strange issue with Simple IPTV client (very slow channel change, about 8-10 seconds), and I cannot find the correct patches for this issue. Maybe it exists, because on AlexELEC doesn't have this issue with newer Kodis, but sadly Alex cannot update his sources on GitHub.


    I also have an M8S device (n200C_2G, PCB: CS_812M8_V1.3), and it works with same meson8m2_KII.dtb.

    The only thing I had to replace was the remote.conf, but I also patched the LE's remote-config script, so it loads remote.conf from /flash too.

    I tried to solve the power issue, because my M8S's uboot cannot turn on via IR remote control. So now it goes to suspend instead of power off state.

  • Hi dtech,

    Just curiosity whether your M8S build supports AP6330 wifi. If I have a right dtb for my box, will wifi will work.

    Thank you,

  • My builds are tested with two variant of M8S+ box, and it perfectly works with ap6330 and bcm4335b0 as well.

    The two boxes have same PCB, the only difference is just the wifi/bt module, but both are working.

    My M8S (n200C_2G, PCB: CS_812M8_V1.3) build is based on same source, and it also have ap6330 on the PCB, ad it works too.


    Maybe if you have a correct dtb (n200_2G?), it will work, but I cannot test it, because I don't have any n200-based S812 device.

  • Hi dtech,

    I try your build with variety dtb that include n200_2G, MXIII plus but the wifi option is not shown, only wired option is shown. I used Demetris build and and everything is working except turn OFF and turn ON by the remote did not work. I have to unplug and plug it back in in order to boot.

  • Which device do you have? An Eny M8S 2G? And what was the name of image file that worked by Demetris?


    Did you rename the dtb file to dtb.img and copied it to the root of sdcard first partition? If you just copyed the file into device_tree it is not enough.


    And one more thing: my M8S (n200C) and Eny M8S (n200) have different IR remote.

    I found some picture from Eny's remote, and it uses same remote like MXQ (S805) device.



    If you have this remote, you need the correct remote.conf: remote_mxq.zip.

  • Hi dtech,

    I used Demetris version 18.6 and the remote.conf is working fine. I can turn the box OFF no problem, but turn it back ON did not work. So far

    the only Demetris Libreelec version Kodi 18.0 is working perfect on my box. Other version my box had a problem to turn it back on after turn it OFF. I had OTT M8S box with Eny M8S ROM installed. I did rename the copied dtb to dtb.img and put it to the root of the SD card.

  • OMG I saw your kindness too lately!

    Of course I wanna test it How can I sownload your build? Thank you very much!

  • Hi dtech,

    I used Demetris version 18.6 and the remote.conf is working fine. I can turn the box OFF no problem, but turn it back ON did not work. So far

    the only Demetris Libreelec version Kodi 18.0 is working perfect on my box. Other version my box had a problem to turn it back on after turn it OFF. I had OTT M8S box with Eny M8S ROM installed. I did rename the copied dtb to dtb.img and put it to the root of the SD card.

    I don't know the Eny's uboot which power options used. If it supports power off correctly, you can try my M8S+ bulid on your box instead of M8S build.

    My M8S supports suspend mode only, but my box isn't an Eny version.