feedback for test build LibreELEC-RK3328

  • That would be great.

    Deinterlacing is not a problem as all 720i/1080i H264 or mpeg2 uses hardware decoding correctly.

    Addons like Netflix and Amazon Prime display everything in 720p/1080p and there are no interlaced content on there.


    I tested Netflix on your new build:

    CPU usage seem to have gone down, eg using 30-50% CPU on all cores, sometimes with a few spikes when playing 720p Netflix streams with Inputstream h264, software decoded.

    But the audio is crackling and 720p h264 Inputstream software decoding still plays in slow motion with stuttering with this lower CPU usage.

    I hope your new direct-to-plane software decoding can help so video playback in such a case can be smoother.


    Thanks

  • Im using this with the A5X max, i need to use the *mx10 dtb for the video properly display.

    ive noticed after watching a few episodes or a movie * id say an hour+ of use* when i click home or back button on the remote the box loses signal/freezes. every time.

    BUT, if i reset and test within 10 mins of the video playing, it all works fine, as it should.

    i guess my question is... what could be the reason why it locks up/loses signal after an hour+ of use but not initially? all by issuing a button command ( seek and rewind still work properly) its just the back/home buttons causing this. if i let the system continue playing/streaming it works fine. but forcing the menu to pop up is locking it up.

    ( sorry for poorly worded post )

  • I hope your new direct-to-plane software decoding can help so video playback in such a case can be smoother.

    I have a rather hacky first version ready now (HACK: RendererDRMPRIME: render sw decoded frames · Kwiboo/[email protected] · GitHub), I have only tested this on rk3399 and sw decoded video seems to display correctly.

    I have pushed two new rk3328 images to Index of /test/, please test and see if anything improves since last build.

  • I have pushed two new rk3328 images to Index of /test/, please test and see if anything improves since last build.

    Rock64/Netflix : smoothness seems improved, indeed; brightness is OK. Thanks, man! Had one (probably unrelated) crash, but the crashlog is too big to upload.

  • Kwiboo


    A user that has a Sony Bravia tv says with HDMI CEC with the tv's Bravia remote,

    he can't use the remote for up/down left/right run/stop etc. on RK3328 images.

    I asked he must most the model number too.


    Is there a way to get logs for troubleshooting for this remote, what steps to do, or something you can add to CEC code to help with Sony Bravia remotes?

  • what could be the reason why it locks up/loses signal after an hour+ of use but not initially?

    Unsure what could be the reason, I mostly test samples of few seconds to 10 minutes, debug log when the issue happens would help, but sounds very hard/time consuming to reproduce.


    Rock64/Netflix : smoothness seems improved, indeed; brightness is OK. Thanks, man! Had one (probably unrelated) crash, but the crashlog is too big to upload.

    Thanks for testing, this has improvement potential so I should probably setup netflix/amazon addon so I can test myself.


    Is there a way to get logs for troubleshooting for this remote, what steps to do, or something you can add to CEC code to help with Sony Bravia remotes?

    The latest LE master should have some improvements to libcec code (was included in Rockchip: update patches and packages by Kwiboo · Pull Request #3239 · LibreELEC/LibreELEC.tv · GitHub), that was the result after some testing using mainline and an older Sony KD-65X8509C TV.

    Enable debug logging and libcec component logging to get CEC details in kodi log, you can also use echo 2 > /sys/module/cec/parameters/debug to enabled detailed kernel log.

    The issue fixed in libcec affects the initial identification of what TV model is used and short periods of non-working cec (mainly affected mainline).

    On Sony and LG I have noticed that you may have to explicitly select Kodi in the input selection menu to get CEC to work.

  • When watching 1920x960 content there is a thin flickering line on top of the picture.

    Crashes are more frequent than expected at first, usually when starting/stopping playback. [Crashlog]

  • When watching 1920x960 content there is a thin flickering line on top of the picture.

    Crashes are more frequent than expected at first, usually when starting/stopping playback.

    Thanks for testing and logs, I am reworking the code to only work with netflix/amazon (addon video codec) in a second iteration, hopefully it will be more stable and won't depend on a "wrapper" video buffer (looks like the SysMem buffer got removed when buffer was still in use in your crashlog)..

  • I also see if you change the 'Limit GUI Size' to 720p and use Netflix, Amazon then there are a lot of crashes and LE restarts, leaving it on 1080p seems to stop the crashes. 720p GUI with software decoding might decrease CPU load further and work better?

    960x540p streams in Netflix seems to play very smooth now, 720p streams are also smooth until there is fast motion or more moving objects on the screen, then stutters appear and the audio starts to crack then it goes away again after a few seconds.


    Is the CPU using an optimal governor eg. ondemand, interactive in the kernel that can help with spikes in higher usage to smooth it out when more items or motion appear on the screen, not sure if this can also help if changed for software video decoding?

  • I also see if you change the 'Limit GUI Size' to 720p and use Netflix, Amazon then there are a lot of crashes and LE restarts, leaving it on 1080p seems to stop the crashes.

    Very interesting, I will do some tests and see if I can solve such issues, just got Amazon installed to be able to fully test something other then local sample files.

    720p GUI with software decoding might decrease CPU load further and work better?

    I am not sure GUI resolution should affect that much, when there is no subtitle or debug overlay the gui should be completly disabled saving on gpu and memory bandwidth.

    When I test on RK3399 it seems to handle decoding of h264 1080p bluray rips using cpu, I should really switch to my Rock64 Transformer and continue testing.

    Is the CPU using an optimal governor eg. ondemand, interactive in the kernel that can help with spikes in higher usage to smooth it out when more items or motion appear on the screen, not sure if this can also help if changed for software video decoding?

    On RK3328 default is to run both CPU and GPU using performance govenor, i.e. run at full speed. On RK3288/RK3399 gpu use performance and cpu use ondemand.

  • Some videos like this one:

    they do not work correctly. The only thing I see different is "Chroma subsampling: 4: 2: 0 (Type 2)". Could this be the problem?

  • Who can record the video work of the interface KODI (latest LE 9) on ROCK64 by video camera 60 frames per second?

    I want to see how smooth the interface is compared to amlogic s905.

    At Odroid C2, unfortunately, there is no smoothness. The only skin where there is smoothness is confluence.


    I was surprised by the smoothness the interface kodi on RK3288 (Asus tinker board). You can see in video 1080p60 resolution:


    Odroid C2

  • For RK3328, it's the same speed as on RK3288.

    Maybe on RK3288 it is 10% faster.

  • For RK3328, it's the same speed as on RK3288.

    Maybe on RK3288 it is 10% faster.

    I wanted to be see on the video that RK3328 also works smoothly. Can someone show it?

    Unfortunately at youtube there is no video at 60 frames per second for RK3328.

    Odroid C2

  • Can someone help me?


    I have the Rock64 Pro version and tested some different kinds of images. Currently I on the RecallBox from MrFixit.

    I am no programmer so am am very happy with these kind off forums with great guys sharing there great builds.


    I am looking for a Libreelec image with a working 3,5mm jack sound output. Because I am using the machine 80% off the time to listen to music connected to my Edifier speakers with jack. The rest off the usages is for movies, all the images that i have tried are not fitting my needs (all have to much). I am using the Recallbox because of its working jack output, but the board is around 70C when in usages. Also I am not using the games on the image. That is why Libreelec is fitting my needs.


    Is there an image of libreelec with a working 3,5mm jack sound output?


    Thanks in advance.

  • I'm still experiencing hard reboots after some time watching livetv with tvh on my mvr9 box. It doesn't matter if sd or hd channel. I also tried 4.2 and 4.3 development builds of tvheadend with no success.


    I would be thankful for any hint to solve this issue.