Rock64 etherner/usb wifi

  • Hi,

    I’ve tried both master Libreelec or last Raybuntu distro. It works, but there’s no wired or wireless (usb dongle)connection available.

    The problem is I can’t see logs, because I can’t connect to the device? Any ideas? It seems my only option at this moment is UART,right?

    Did anyone experience the same problem with no ethernet?


  • Thank you for an answer. I’m aware of all of this. I’m not asking to finish it right now. What I was asking is if anyone had the similar problem(whatever device) or an opinion how someone more experienced will proceed. What is the best procedure for this kind of debugging when there’s no connection over network to read the log files. Afaik there’s no simple solution to run command line from Kodi,right?

  • Did anyone experience the same problem with no ethernet?

    Ethernet works on my rock64.

    My USB wifi dongle not working.

    LibreELEC Krypton/Leia/Agile build for Odroid C2, Rock64, WeTek Hub, WeTek Play2

    Rock64 4gb/EEMC 64gb LibreELEC-rock64.arm-rb-leia24

    It works with Android as well.

  • It is the same thing for me, ethernet work perfectly on my Rock64 with rb-leia24. I do not test wifi dongle.

    Libreelec : Raspberry 4, Orange pi lite2, Orange pi PC(and +), Pine H64, Rock64, RockPro64, soon Orange Pi 3 and PC2

    Divers : NVidia Shield Pro, NVidia Shield Tube, N2 and C4

    Edited once, last by mike2002 ().

  • I made an mistake with UBOOT_SYSTEM

    I haven't been able to boot LE via SD Card unless Stock Android eMMC is removed.

    Didn't want to start a new thread as the official release isn't available yet.

    I read at 1684dc5dc829d878b5f93b41782ab35dd8c0231f · Kwiboo/ · GitHub

    Can anyone advise if they have tried this.

    I just need to test before official release.

  • Couldn't download any image from link provided and don't know or have the tools to build the image. I believe all builds are consolidated here.. Going to test ROCK64 builds downloaded from there (need a few extra microSD cards).

  • I just installed Android TV version Android-7.1-rock-64-rock64_atv-v0.3.13-r115-raw.img to eMMC and fresh SD Card RB LE 24

    It BOOTED LE via SD card with the eMMC inserted.

    Lots of errors after boot up screen. Sometimes boots with no error notifications but FREEZES within 30 seconds.

    Kernel panics etc. Pulled out eMMC and boots up with no freezes or errors.

    Main thing is it boots.

    Save this for the official release.