8.2.4 MR audio issue

  • Hello, I'm having this issue since I updated to the newest version 8.2.4 MR, the problem is that the audio has a crackling noise when I use tvheadend, I have the RPI 3 (not the new one), If I open the channel from the network with VLC I don't notice any crackling noise.

    I copied an image of the previous version and there is no noise but when I update to the new version (8.2.4 MR) the noise is back so I'm sure it's a problem with the newest update of Libreelec.

    I use the 3.5 jack with the analog "audio output device" setting.

    Edited once, last by Petes ().

  • I am seeing the same issue. I have an RPI3 and updated from 8.2.3 to 8.2.4. Went back to 8.2.3 and audio cleared up. For Audio, I use HDMI to my TV.

  • I did it and the 8.2.4 firmware is the problem, went back to 8.2.3 and there is no crackling sound.

  • Hello,

    Crackling sound here too on a raspberry 3B+.

    I2s output.

    audio_pwm_mode=2 didn't fix.

    Reducing audio level in kodi by 2 steps make it disappear but a better fix is welcome ;)

    Edit : still slight clipping distorsion with 2 steps reduction. 3 steps is safer with loud tracks

    Edited once, last by grael ().

  • grael

    Do you get the same issue when using the newer firmware on 8.2.3 builds?

    Do you have Resample Qualtiy set to "GPU accelerated" in Settings->System->Audio (settings level must be advanced or expert to see/change that)?

    Does it go away when changing Resampling Quality to Medium or High?

    so long,


  • I tried audio_pwm_mode=2 and it didn't work, the "Resample Qualtiy" is medium but no matter what I set it to the problem is not solved.

    Something that I noticed is that if I change the "Audio output device" from "analogue" to "hdmi" or "analogue and hdmi" while playing a channel the audio gets distorted, it's like a low pitch so everything has a grave sound. The only way I know to fix the pitch issue is to reboot libreelec.

  • HiassofT

    Resample Quality is set to Medium

    But there is no resampling as 'Audio output configuration' is set to 'Best match'

    I may try a 8.2.3 build with newer firmware but it will take a few time (I need to rebuild from sources to use a custom overlay...)

  • The audio_pwm_mode will only affect analogue audio (as in original post in this thread).

    Other audio issues are probably unrelated.

  • Yes, audio_pwm_mode=0 fixed the noise issue for me.

    Can you remove that line and try disabling deinterlace?

    Does that help? If it does, then does switching to Bob deinterlace help?

  • +1 , 8.2.4 has been really problematic for me on RPI2. I experienced system freezes during playback which only reboot fixed. The only workaround that seem to fix this is rolling back to 8.2.3

  • deancan your issue doesn't seem related to the analogue audio issue reported.

    Please create a new thread and include some information if you want help (e.g. a debug log).

  • Disabling deinterlace fixes it, Bob (half) is better, Bob is the worse (and I think that "Auto" selects this one), the two Advanced options also fix the issue.

    Edited once, last by Petes ().