• Hello Thanks for the great work.

    For some reason Librespot is not playing on any of my snapclients.. I have test all clients using mopidy server and they do work.. So its not my snapclients..

    My snapserver seems to be working as i see when i start it, my clients receive data..

    Librespot works as i can use it to stream music from my phone to libreelec.. It seems that (after digging) Librespot is not piping audio to the sink file...

    snapclient log:

    snapserver log:

    Please let me know if you need any further logs etc.

  • Hi,

    I have just moved from OSMC to LibreELEC to take advantage of my Raspberry Pi 4 and was very excited to see that there is an easy way to cast Kodi output through Snapcast.

    However, after installing the addon, I do not see the PULSE: Snapserver device in the audio output selection box.


    I did a bit more digging and found that Pulseaudio could not start because of Bluetooth being disabled.

    After enabling it, I got pulseaudio starting.

    The device name in Kodi was still PULSE: Default Bluetooth, but selecting this made snapcast work just fine

    Edited once, last by ronan.l.n ().

  • Hello, I have a random question. MY current setup is Two Pi's, one running snapserver, and other running snapclient. All works perfectly! The snapserver is not connected to a TV/Screen as i just use if for music for my outdoor area. In the add-on settings we have three sinks/streams - Airplay, Spotify, Kodi/default. now i have set my default sink/stream to be spotify as this is what i mainly use. but if i want to airplay something from my phone to snapserver i need to set the add-on to stream this rather than Spotify. Is there a way i can trigger snapserver to change the stream without having to connect the pi to a display?

    Thanks again for the amazing development here!!!

  • I am currently running the millhouse development version of Libreelec based on Kodi 19 Alpha

    is there a version of Snapserver which will run on this yet ?

    it appears to be failing because of the move to Python 3 in Kodi 19

    Rasp3Libre:~/.kodi/temp # grep -i python kodi.log

    2020-03-06 12:39:08.307 T:1338 INFO <general>: CAddonMgr::FindAddons: xbmc.python v3.0.0 installed

    2020-03-06 12:39:12.561 T:1365 INFO <general>: initializing python engine.

    File "/usr/lib/python3.7/", line 1319, in do_open

    File "/usr/lib/python3.7/", line 1252, in request

    File "/usr/lib/python3.7/", line 1298, in _send_request

    File "/usr/lib/python3.7/", line 1247, in endheaders

    File "/usr/lib/python3.7/", line 1026, in _send_output

    File "/usr/lib/python3.7/", line 966, in send

    File "/usr/lib/python3.7/", line 1422, in connect

    File "/usr/lib/python3.7/", line 423, in wrap_socket

    File "/usr/lib/python3.7/", line 870, in _create

    File "/usr/lib/python3.7/", line 1139, in do_handshake

    File "/usr/lib/python3.7/", line 222, in urlopen

    File "/usr/lib/python3.7/", line 525, in open

    File "/usr/lib/python3.7/", line 543, in _open

    File "/usr/lib/python3.7/", line 503, in _call_chain

    File "/usr/lib/python3.7/", line 1362, in https_open

    File "/usr/lib/python3.7/", line 1321, in do_open

    File "/usr/lib/python3.7/", line 341, in loads

    2020-07-13 13:12:02.265 T:1357 ERROR <general>: CAddonInstallJob[service.snapserver]: The dependency on xbmc.python version 2.1.0 could not be satisfied.

    2020-07-13 13:12:18.234 T:1358 ERROR <general>: CAddonInstallJob[service.snapserver]: The dependency on xbmc.python version 2.1.0 could not be satisfied.

    2020-07-13 13:12:26.799 T:1357 ERROR <general>: CAddonInstallJob[service.snapserver]: The dependency on xbmc.python version 2.1.0 could not be satisfied.

  • Hi There,

    Question after installing SnapServer addon on LibreELEC (official): 9.2.1 (RPi4.arm), and after rebooting, I then go to system audio settings; However the additional pulse audio output option that is added is "Pulse Audio: Null, Null, ......"

    I selected it anyway as the audio output device; installed snap client on my android (which notices the snap server on my pi right away) play a video on my pi; the onscreen video freezes immediately; no sound (or anything) on my android phone.

    What I'd love to do is hook up wifi headphones (e.g. audio only via wifi from my pi to my android).

    Any thoughts on what I should do next @awiouy

  • hello,

    If I have LE box(arm) and RaspberryPi4 with Volumio, is it possible to stream sound from LE to Volumio using snapcast? This addon avaliable for both of them.

    I've installed snapcast to both devices, but don't know what to do next, could someone help?

  • First thanks for the addon!

    Is there any way to make kodi believe it is playing music while snapclient is in use? It would be neat if kodi would show a visualizer while playing music via snapclient :)

  • First off, thanks so much for your hard work!

    I have a similar issue to ronan.l.n above.

    Running Kodi 18.9.0

    and libreELEC 9.2.7

    on a raspberry pi3.

    I can install snapserver and snapclient as per snapcast: add streaming from kodi by awiouy · Pull Request #2597 · LibreELEC/ · GitHub.

    BUT when I go to try to find PULSE: Snapserver in Settings/System/Audio/Audio output device, it's not listed as one of the options. Weird thing is though, I've had it working once and available in the last 24 hours. It appeared, I selected it, then the system worked beautifully and my pi downstairs picked it up straightaway. After rebooting PULSE: Snapserver disappeared. Only PULSE:bluetooth is left, which doesn't appear to work.

    Any thoughts on getting PULSE: Snapserver in Settings/System/Audio/Audio output device? I tried disabling and reenabling bluetooth, but no joy.

    Any thoughts?

  • So I installed the Snapclient from the LibreElec Add-On repository, was excited that an official Add-On was there! However, it doesn't work. Audio doesn't play, and the service appears to keep bouncing on/off/on/off.

    Logging in via SSH, I find this error from the current STDOUT for the Snapclient bin.

    Controller::onException: Can't open hdmi:CARD=PCH,DEV=0 PCM device: Device or resource busy

    I selected the HDMI output (my receiver is hooked up to Kodi that way, wanted to play audio through it), which is what Kodi is set to use. How do I get Kodi/LibreElec to play nice and output audio? Should I go and install PulseAudio add-on or what not?

    I'm Linux savvy, but unfamiliar with the specifics of how LibreElec/Kodi runs things under the hood, only ever used it as a media player/front end.