Beelink GT1 Ultimate unable to install LibreELEC

  • Same here. I've checked /proc/meminfo on android, showed 3GB ram. Now I was able to boot with gxm_q200_2g.dtb but LE showing total of 2GB ram. Any ideas?

    It´s fake ram.

    LE shows the truth.

  • Try this one. Worked for me on my ultimate gt1.

    Based in GERMANY — working in cigar business — part time freelance webdesigner — PS4 Console Gamer and TV Show Junkie :cool:

    S912 with CE on NAND — S905x with CE on SD-Card (with EmulationStation&KODI shanti‘s build) - Odroid N2 with CE on emmc and EmuELEC on SD-Cad — 4K 65“ Sony — 4K Onkyo DD/DTSHD/ATMOS Receiver

  • Hi guys,

    THE LAN WORKS!!!!!8)8)8)8)8)

    got the LAN working with a dtb file i found online somewhere in this (mega link below) called: gxm_q200_k3_pro.dtb

    usiing this libre elec: LibreELEC-S912.arm-8.2.5-Chroma.422.10bit

    MEGA (Kodi Krypton-AML)<3<3<3

    good luck.

    and much love

  • I own both the Beelink GT1 1GB DDR 16 GB drive and the Beelink GT1 Ultimate with 3GB DDR and 36GB drive.

    I have been able to install LibreELEC on the first Beelink GT1 but not on the ULTIMATE version of the box.

    I used LibreELEC-912.arm-8.2- and have tried the device tree files gxm_q200_3g.dtb ,gxm_q201_3g.dtb, q200_2g.dtb and q200_2g.dtb without any success.

    I started the box using the normal toothpick method and all I get is the Beelink Android symbol on the start up screen and nothing happens after that.

    I also tried booting into Android 7.1 and installing a Terminal Emulator and used the command 'reboot update' with the micro SD card installed with no success.

    I used the program LibreELEC.USB-SD.Creator.Win32 to flash the class 10 micro SD card.

    Having had no problems with the earlier Beelink GT1 box I cannot understand why I am having no success with the later box.

    Any help will be much appreciated. Thanks :(

    Can you explain how you install libreelec on beelink gt1?

  • For kicks you could try this image on a spare SD card LibreELEC-AMLGX.arm-9.80-nightly-20200324-aeb6e84-box.img.gz - It won't be great for playback (still a bit experimental) but might help set the u-boot environment up better. I've had issues with other Beelink firmware; to make things boot quicker some of the normal wait points in the boot sequence are time-reduced which makes it harder to release the reset button at the right point to trigger the u-boot recovery mode (which is how the toothpick method works).

  • Hi Chewitt,

    I have tried it and It lags alot on playback and I had to restart it everything I forward the video and it gets stuck.

    I have been looking around for a stable older release to test playback on my device.