Problems playing audio and video files

  • I am having trouble playing any videos or music from my server using LibreElec. I can access the files and play them using other platforms. Also, when this happens, no other files play either (e.g. YouTube files). None of these files will play UNLESS I go into the context menu and select “play using...” and then select VideoPlayer instead of Default. Then and only then will those files play. Anyone have any idea why this randomly happens and how to fix it??!! Maddening!!!! This is occurring on LibreElec on both my HTPC and my raspberrypi2.

  • It reminds me of issues seen occasionally when people import configuration from other Kodi platforms (e.g. Win to Linux). Best thing to do is use the log upload function in the LE settings add-on, then share the URL so we can see the config of things and what kind of media is being [not] played?

  • Ok...nothing plays. Not my network movies, music, or even YouTube videos. Except when I use the context menu and use the “play with” function instead of the default player. If I can do that the file plays...


    Ubuntu Pastebin

  • No further support will be provided until you provide a debug logfile showing a system without pirate add-on repo's installed.

  • I am joining this tread as I have the same problem reported here. I can not play any video (even youtube) or music files at all.


    My USB drives are attached to the LE box directly (via a 8 port USB hub). I have, even though I didn't think it mattered, changed the min SMB version to 1, but no effect on this issue.


    The motherboard is an AsRock single board (Intel) computer and video/audio is via HDMI to a Marantz 7702mk2 processor. No h/w changes at all on the LE box. KODI system information reports the following video information: GPU Mesa DRI Intel HD Graphics 405 - (Braswell); OpenGL Vendor: Intel Open Source Technology Center; OpenGL Version: 3.0 Mesa 17.1.3


    Interestingly, I can play video from this LE box, when I attach to it from a Mac running Kodi 17.6. So, it would appear that the filesystem is functioning correctly on the server LE box. Must be something with the player? Music won't play either, so I'm thinking not a video issue per se.


    Today I tried using the context menu, play using: video player. This works. The video is a bit choppy, but it plays. So this now really does seem to point to the player as the culprit.


    I was running. 8.0.2 and all was golden. Then I installed 8.2.0 by copying the update .img to my updates share. At first things looked ok, but then I noticed the remote was getting double keystrokes. I read the release notes and turned off lirc. When I rebooted, I no longer had working video. No idea how (or if) changing that setting could have caused this problem. Anyway, I turned lirc back on and it did not help. Currently it is off again.


    Subsequent to the 8.2.0 update, I used LE's administration panel to do another update to 8.2.1, hoping maybe something related to my issue got fixed. No change. Only way I can get video or music to play is by using the context menu.

  • Some additional information. I have tried using HW acceleration on and off. Both work fine as long as I select VideoPlayer rather than default. What is the default player? Somehow it is broken for my installation OR something on my configuration is causing problems for the default player.

  • Sorry, I thought you already had a log file from the other user, so I didn't send mine. It is attached.


    You will see the issue starting around line 2040 of the log file

  • Ok, so I didn't have all that much so called "unsupported" stuff, but I did remove any repositories and add-ons to the best of my ability. I think all is gone as I checked against the "list" and removed anything I found there.


    Anyway, I rebooted and tested again. Same issue.


    Here are the new log files.

  • It almost seems like the default player is not defined. It should be video player shouldn't it? Has this changed since 8.0.2?

  • but I did remove any repositories and add-ons to the best of my ability. I think all is gone as I checked against the "list" and removed anything I found there.

    I think you need to try a little harder than that.


    Quote

    DudeHere - 2016 - forums.tvaddons.ag

    You still have crap installed on your LibreELEC setup.


    Why don't you start with a fresh, clean setup, add your local server(s), and simply play a local file?

    Without installing any add-ons?

  • (In a nice way) If I wanted to do a fresh install I would not have asked for help here. That is sort of the last option, I'd like to do at this time.


    Honestly, I don't know how else to remove stuff. I removed all the repositories and all the add ons I could find using the "files" menu and "add-on" menu. I did see that last quote you made, but don't know why it's there or how to remove it. The repository that contains it was removed and I didn't see that add-on showing under "my add-ons/all"


    So if you have some assistance on either getting rid of anything that is offending OR how to fix the problem, please advise.

  • Honestly, I don't know how else to remove stuff

    The LibreELEC Settings Add-on has two reset options for a clean start, a Soft Reset and a Hard Reset.

    The latter doing a full reformat of the storage partition. I'd suggest starting with the Soft reset.


    If you want to save any other files, then first use the Backup tool. Also available in the Settings Add-on.

  • Sort of like calling Microsoft and being told to re-install windows. Again, not being sarcastic, but I was hoping someone could look at the log and help me just fix this problem.


    I looked at my add-on's again. There was one more that was questionable so I removed it as well. If there are additional "offending" add-on's I'd like to know which and how I can get rid of them. I don't want them anyway.


    Regarding my problem. This can't be that complicated problem to diagnose. Video/music play from context menu, but doesn't from the normal menu. What is the difference here? Are both methods supposed to use the same player?

  • Here is a new full DEBUG log. The problem seems to be "Error creating player for item" followed by "does file exist?". I'm not an expert, but it looks like there is a rules match for video player, but then some issue passing the arguments to the player?